5.9 Inter-Area MPLS TE with OSPF

Hi,

 

Is inter-area MPLS TE with OPSF/ISIS is supported on dynamips? because here i have apply config but in the end tunnel not showing up/up. Verified all the configs are upto mark.

R1#sh int des | in Tu
Tu0                            up             down    
R1#

R1#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.1.2.2, 01:06:21, FastEthernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
O IA     3.3.3.3 [110/3] via 10.1.2.2, 01:05:10, FastEthernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
O IA     4.4.4.4 [110/3] via 10.1.2.2, 01:05:21, FastEthernet0/0
      5.0.0.0/32 is subnetted, 1 subnets
O IA     5.5.5.5 [110/4] via 10.1.2.2, 00:57:38, FastEthernet0/0
      6.0.0.0/32 is subnetted, 1 subnets
O IA     6.6.6.6 [110/4] via 10.1.2.2, 01:05:41, FastEthernet0/0
      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O IA     10.19.20.0/24 [110/5] via 10.1.2.2, 01:06:21, FastEthernet0/0
      19.0.0.0/32 is subnetted, 1 subnets
O IA     19.19.19.19 [110/5] via 10.1.2.2, 01:05:56, FastEthernet0/0
      20.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O        20.2.3.0/24 [110/2] via 10.1.2.2, 01:16:59, FastEthernet0/0
O        20.2.4.0/24 [110/2] via 10.1.2.2, 01:16:59, FastEthernet0/0
O IA     20.3.4.0/24 [110/3] via 10.1.2.2, 01:06:21, FastEthernet0/0
O IA     20.3.6.0/24 [110/3] via 10.1.2.2, 01:16:59, FastEthernet0/0
O IA     20.4.5.0/24 [110/3] via 10.1.2.2, 00:57:38, FastEthernet0/0
O IA     20.4.6.0/24 [110/3] via 10.1.2.2, 01:16:59, FastEthernet0/0
O IA     20.5.6.0/24 [110/4] via 10.1.2.2, 01:06:21, FastEthernet0/0
O IA     20.5.19.0/24 [110/4] via 10.1.2.2, 00:57:38, FastEthernet0/0
O IA     20.6.19.0/24 [110/4] via 10.1.2.2, 01:06:21, FastEthernet0/0
O IA     20.20.20.20/32 [110/6] via 10.1.2.2, 01:06:06, FastEthernet0/0
R1# 

 

Regards,

Yasir

Comments

  • Hi mate,

    Yes, I have done this setup in GNS and it worked. I can send you the relevant GNS confg files.

    Alternatively, provide us  the config to troubleshoot the problem

  • So do I. It works.

     

     

  • You must use explicit LOOSE path options in order for it to work. This is supported in GNS3, I've done it before. It was not working for me at the beggingin because I was not using the loose path options. As soon as I changed my explicit paths to loose, it worked. 

     

    This definitly caused some confusion for me, so just be sure to keep this in mind.

  • Hi Guys,

    Sorry to hijack. Am having reachability issues for the MPLS TE Tunnel. From the debugs I am unable to reach XR2 Lo0 IP address. This is what I got from the debugs:

     

    E-PCALC-PATH: 1.1.1.1_71->20.20.20.20_0 {7}: Area (ospf 1  area 1) Path Lookup begin

    TE-PCALC-PATH: Area (ospf 1  area 1): Dest ip addr 20.20.20.20 not found

    TE-PCALC-PATH: lsr_exists:first Loose Hop is to addr 3.3.3.3

    Path from 1.1.1.1 -> 3.3.3.3:

      20.2.3.3->0.0.0.0 (admin_weight=2):

      20.2.3.2->0.0.0.0 (admin_weight=2):

      10.1.2.2->0.0.0.0 (admin_weight=1):

      10.1.2.1->0.0.0.0 (admin_weight=1):

      num_hops 5, accumlated_aw 2, min_bw 75000

    TE-PCALC: Verify Path Lookup: 1.1.1.1_71->20.20.20.20_0 {7}: (  area nil)

      Flags:  METRIC_TE

      Last Strict Router: 3.3.3.3

      sub-lsp weight:0 (Total LSP weight:2)

      Hop List:

        10.1.2.1

        10.1.2.2  

    R1#

        20.2.3.2

        20.2.3.3

        3.3.3.3

        5.5.5.5 Loose

    TE-PCALC-VERIFY: VERIFY to 3.3.3.3 BEGIN:

    TE-PCALC-VERIFY: Verify: 

    TE-PCALC-VERIFY:  1.1.1.1, 10.1.2.1 points to 

    TE-PCALC-VERIFY:  2.2.2.2, 10.1.2.2

    TE-PCALC-VERIFY: Verify: 

    TE-PCALC-VERIFY:  2.2.2.2, 20.2.3.2 points to 

    TE-PCALC-VERIFY:  3.3.3.3, 20.2.3.3

    TE-PCALC-VERIFY: VERIFY to 3.3.3.3 PASSED

    TE-PCALC-PATH: 1.1.1.1_71->20.20.20.20_0 {7}: Area (ospf 1  area 1) Path Lookup end: path found

    TE-PCALC-API: 1.1.1.1_71->20.20.20.20_0 {7}: P2P LSP Path Lookup result: success

    TE-SIG-HE: Tunnel0 [71]->20.20.20.20: RSVP head-end open

    TE-SIG-HE: Tunnel0 [71]->20.20.20.20: received Path Error from 10.19.20.20: Routing Problem:  (flags 0)

    TE-SIG-HE: Tunnel0 [71]: path error (unprotected)

    TE-SIG-HE: Tunnel0 [71]->20.20.20.20: RSVP head-end close

     

    From IGP perspective it seems ok. 

    R1#sh ip route ospf

    Gateway of last resort is not set

     

          2.0.0.0/32 is subnetted, 1 subnets

    O        2.2.2.2 [110/2] via 10.1.2.2, 00:39:16, FastEthernet0/0

          3.0.0.0/32 is subnetted, 1 subnets

    O IA     3.3.3.3 [110/3] via 10.1.2.2, 00:38:09, FastEthernet0/0

          4.0.0.0/32 is subnetted, 1 subnets

    O IA     4.4.4.4 [110/3] via 10.1.2.2, 00:37:13, FastEthernet0/0

          5.0.0.0/32 is subnetted, 1 subnets

    O IA     5.5.5.5 [110/5] via 10.1.2.2, 00:35:31, FastEthernet0/0

          6.0.0.0/32 is subnetted, 1 subnets

    O IA     6.6.6.6 [110/4] via 10.1.2.2, 00:35:31, FastEthernet0/0

          10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

    O IA     10.19.20.0/24 [110/5] via 10.1.2.2, 00:31:59, FastEthernet0/0

          19.0.0.0/32 is subnetted, 1 subnets

    O IA     19.19.19.19 [110/5] via 10.1.2.2, 00:31:59, FastEthernet0/0

          20.0.0.0/8 is variably subnetted, 10 subnets, 2 masks

    O        20.2.3.0/24 [110/2] via 10.1.2.2, 00:39:16, FastEthernet0/0

    O        20.2.4.0/24 [110/2] via 10.1.2.2, 00:39:16, FastEthernet0/0

    O IA     20.3.4.0/24 [110/3] via 10.1.2.2, 00:37:13, FastEthernet0/0

    O IA     20.3.6.0/24 [110/3] via 10.1.2.2, 00:38:09, FastEthernet0/0

    O        20.4.5.0/24 [110/3] via 10.1.2.2, 00:37:13, FastEthernet0/0

    O IA     20.4.6.0/24 [110/3] via 10.1.2.2, 00:37:13, FastEthernet0/0

    O IA     20.5.6.0/24 [110/4] via 10.1.2.2, 00:35:31, FastEthernet0/0

    O IA     20.5.19.0/24 [110/5] via 10.1.2.2, 00:35:31, FastEthernet0/0

    O IA     20.6.19.0/24 [110/4] via 10.1.2.2, 00:35:31, FastEthernet0/0

    O IA     20.20.20.20/32 [110/6] via 10.1.2.2, 00:29:31, FastEthernet0/0

     

    Any tips on the troubleshooting process??

Sign In or Register to comment.