Task 2.4 IGP redistribution with NSSA area 38

I interpret this question as follows:
Change the area 38 into a NSSA area and redistribute as told on R1, R3 and R5. Take into account that you raise the External AD on R1 and R3.

 

R1

router eigrp 1024
redistribute ospf 1 metric 1 1 1 1 1
network 150.1.1.1 0.0.0.0
network 174.1.13.1 0.0.0.0
network 174.1.145.1 0.0.0.0
no auto-summary
eigrp router-id 150.1.1.1
router ospf 1
log-adjacency-changes
area 38 nssa
redistribute eigrp 1024 subnets
network 174.1.31.1 0.0.0.0 area 38
distance ospf external 180

R3

router eigrp 1024
redistribute ospf 1 metric 1 1 1 1 1
network 150.1.3.3 0.0.0.0
network 174.1.13.3 0.0.0.0
no auto-summary
eigrp router-id 150.1.3.3
router ospf 1
log-adjacency-changes
area 38 nssa
redistribute eigrp 1024 subnets
network 174.1.38.3 0.0.0.0 area 38
distance ospf external 180

 Would this get me points?

 

 

Comments

  • I did the same thing..

     

    R1

     

    router eigrp 1024

     redistribute ospf 1 metric 1500 1 255 1 1500 route-map OSPF->EIGRP

     network 150.1.1.1 0.0.0.0

     network 174.1.13.1 0.0.0.0

     network 174.1.145.1 0.0.0.0

     no auto-summary

     eigrp router-id 150.1.1.1

    router ospf 1

     log-adjacency-changes

     area 38 nssa

     redistribute eigrp 1024 subnets route-map EIGRP->OSPF

     network 174.1.31.1 0.0.0.0 area 38

     distance 171 0.0.0.0 255.255.255.255 EIGRP-EXTERNAL-109

    !

     

    ip access-list standard EIGRP-EXTERNAL-109

     permit 174.1.23.0 0.0.0.255

     permit 174.1.26.0 0.0.0.255

     permit 150.1.3.0 0.0.0.255

     permit 150.1.2.0 0.0.0.255

    !


    route-map OSPF->EIGRP deny 10

     match tag 90

    !

    route-map OSPF->EIGRP permit 20

     set tag 110

    !

    route-map EIGRP->OSPF deny 10

     match tag 110

    !

    route-map EIGRP->OSPF permit 20

     set tag 90




    and the same thing on R3..


    I also was reading the question that I needed to change the stub area to NSSA [:S]

     

     

  • Thanks, what i did notice though was that I initially did not add  area 38 nssa default-information-originate to router 3. This caused me to run into trouble with the BGP questions. Traffic started blackholing on SW4.

  • I did the same however this question is very unclear for me

    Rack1R1#sh run | sec router ospf
    router ospf 1
     log-adjacency-changes
     area 38 nssa
     redistribute eigrp 1024 subnets
     network 174.1.31.1 0.0.0.0 area 38
     distance ospf external 180

    anyway it meets question requirerments.

  • This question is badly written and the solution doesn't really suit the question.

    The question states "Redistribute between OSPF and EIGRP on R1 and R3."

    But in the SG they do not do mutual redistribution on R1.

    And since area 38 is a stub, you can't redistribute anyway.

    My solution was the same as above -change area 38 to NSSA and mutually redistribute between EIGRP and OSPF on R1 and R3.

     

    The SG ignoes the requirment to "Redistribute between OSPF and EIGRP on R1 and R3."

  • I agree with every post here, I changed area 38 to NSSA and upped the AD for external ospf routes on R1 & R3

  • I'm happy to see I'm not the only one that changed from stub to nssa and increased AD for ospf external to > 170 !

     

  • Me too. Did the same thing. Changed area 38 to NSSA and increased the OSPF ext. distance to 180.

    Would be nice to have a comment from one of the INE guys on that one.

     

  • I don't mean to sound like a broken record, but I completely thought this task was going to be way more involved. I contemplated changing all of area 38 to NSSA to support externaling routing along with solving route-feedback issues and AD issues.

    This task has left me baffled with less trust in my understanding of redistribution.

    Sometimes, INE configures redistribution for topological changes and sometimes they don't. If you're like me, you first want to look for all the possible ways to redistribute and ways to have problems. When the solution is too simple, you feel like you're wrong for looking too deep into the task. Reverse this method and you'll find a lab that has way more configuration than you expected.

    Oh well, I'll keep studying the topics.

    Mike

     

  • JoeMJoeM ✭✭✭

    Thanks for finding this thread.   I was working on this lab today. 

    I did the same as everyone above did for AREA 38:

          1) changed Area38 from STUB to NSSA (to allow redistribution)

          2)  completed two-way (eigrp<-->ospf) redistribution on R1 and R3

          3)  increased AD for OSPF external on R1/R3  (larger than EIGRP external)

     

    I was surprised at the solution's answer, but just for fun, I held on to my configuration (nssa).

    This is probably one of those we should "ask the proctor".

  • Hi everybody,

     

    I wake up this post, because I did this task this evening. Even if the wording of the task is quite "foggy", I applied the SG solution to see. For me it looked quite strange to do so, because I get a nice loop with the default router...

    R3 advertise a def router to stub are 38, which is advertised by R1 to eigrp, which is then again sent to R3, who installs it in routing table.

    D*EX 0.0.0.0/0 [170/2560512256] via 174.1.13.1, 00:24:04, Serial1/2

    Well, if a ccie makes this on a real network, this would be weird ! :)

    More, imagine the link R1-R3 goes down, a part of the network continues to get full routing, but the rest stays in the dark.

    I hope I won't get such scenario during the lab [^o)]

     

    Any input is appreciate :)

    Thanks,

    Olivier

  • I know this topic has been tackled in detail but I wanted to know why the OSPF distance needed to be bumped up. Could someone please help me with the rational behind increasing the OSPF external distance.

     

    Thanks

  • JoeMJoeM ✭✭✭

    Hi Rasbog,

    This is to avoid sub-optimal routing (detour through R1/AREA 38) for traffic coming from VLAN_52.    This is only if we changed Area 38 to an NSSA.

    RIP >> EIGRP 170 >>  120 OSPF NSSA

  • Chaps, +1 more for the NSSA area, but i went one further for the last point.

    The last point reads "Eliminate any IGP issues preventing full reachability."

    So i went around the routers redistributing connected interfaces that were not activly involved in an IGP & unreachable, like SW1's Vlan 7 interface etc.

    Sure there may be a question later on that says, "woa lad, do this XYZ for BGP/MPLS etc, but I am pretty rubbish at remembering the labs. I read them though and am like "oh thats nice, and forgett everything!! ... "

     

    But for me to satisfy the last point I added all the connected interfaces to get my TCL ping working. Heres my scrip, its nice as it only shows failed pings & keeps my OCD happy as i have a clean terminal window!!

    foreach I {
    X.X.X.X
    } {
    if {[regexp "!!" [exec "ping $I rep 2>]} {} {puts "$I FAILED"}
    }

    Sam

Sign In or Register to comment.