9.23 IPv6 NAT-PT 'IPv6 NAT:v4tov6 entry not found'

Hi,

I have configured exercise 9.23 in my dynamips lab.

Its all the same except that instead of fa0/0.67 and fa0/0.146 on R6 I have g2/0 and g1/0

Anyway, after I apply the NAT config my pings don't work.

the debug ipv6 nat detailed command on R6 gives me this:

*Oct 20 08:40:14.107: IPv6 NAT:v4tov6 entry not found

*Oct 20 08:40:14.675: IPv6 NAT:v4tov6 entry not found

When i run the pings i get this:

*Oct 20 08:41:26.611: IPv6 NAT: ipv6nat_find_entry_v4tov6:
         ref_count = 1,
                                usecount = 0, flags = 257, rt_flags = 0,
                                more_flags = 0

*Oct 20 08:41:26.619: IPv6 NAT: ipv6nat_find_entry_v4tov6:
         ref_count = 1,
                                usecount = 0, flags = 513, rt_flags = 0,
                                more_flags = 0

*Oct 20 08:41:26.623: IPv6 NAT: Dropping v6tov4 packet
R6(config)#
*Oct 20 08:41:28.339: IPv6 NAT:v4tov6 entry not found

 

My config on R6 is:

sh run int gi2/0
Building configuration...

Current configuration : 154 bytes
!
interface GigabitEthernet2/0
 ip address 155.1.67.6 255.255.255.0
 ip rip advertise 10
 negotiation auto
 ipv6 address FC00:1:0:67::6/64
 ipv6 nat

sh run int gi1/0
Building configuration...

Current configuration : 386 bytes
!
interface GigabitEthernet1/0
 ip address 155.1.146.6 255.255.255.0
 ip pim sparse-mode
 ip rip advertise 10
 ip ospf 1 area 1
 negotiation auto
 ipv6 address 2001:1:0:146::/64 eui-64
 ipv6 nat
 ipv6 eigrp 100
 ipv6 authentication mode eigrp 100 md5
 ipv6 authentication key-chain eigrp 100 eigrp-auth
 ipv6 rip RIPNG enable
 ipv6 rip RIPNG default-information originate metric

ipv6 nat v4v6 source 150.1.4.4 2000::9604:404
ipv6 nat v6v4 source FC00:1:0:67::7 155.1.146.7
ipv6 nat prefix 2000::/96

Anyone see what i'm missing?

 

Comments

  • Ah actually got it working!

    It was because i hadn't advertsied 150.1.4.4 into OSPF, so R6 didn't have a route to it.

    Once i added that in, the pings worked, however i still see the IPv6 NAT:v4tov6 entry not found in the debugs....

    See this:

     

    Oct 20 08:50:17.235: IPv6 NAT:v4tov6 entry not found

    R6#
    *Oct 20 08:50:18.331: IPv6 NAT:v4tov6 entry not found

    R6#
    *Oct 20 08:50:19.839: IPv6 NAT: ipv6nat_find_entry_v4tov6:
             ref_count = 1,
                                    usecount = 0, flags = 64, rt_flags = 0,
                                    more_flags = 0

    *Oct 20 08:50:19.847: IPv6 NAT: icmp src (FC00:1:0:67::7) -> (155.1.146.7), dst (2000::9604:404) -> (150.1.4.4)
    *Oct 20 08:50:19.935: IPv6 NAT: ipv6nat_find_entry_v4tov6:
             ref_count = 1,
                                    usecount = 0, flags = 64, rt_flags = 0,
                                    more_flags = 0

    *Oct 20 08:50:19.939: IPv6 NAT: ipv6nat_find_entry_v4tov6:
             ref_count = 1,
                                    usecount = 0, flags = 64, rt_flags = 0,
                                    more_flags = 0

    *Oct 20 08:50:20.011: IPv6 NAT: ipv6nat_find_entry_v4tov6:
             ref_count = 1,
                                    usecount = 0, flags = 64, rt_flags = 0,
                                    more_flags = 0

    *Oct 20 08:50:20.019: IPv6 NAT: icmp src (FC00:1:0:67::7) -> (155.1.146.7), dst
    R6#(2000::9604:404) -> (150.1.4.4)
    *Oct 20 08:50:20.123: IPv6 NAT: ipv6nat_find_entry_v4tov6:
             ref_count = 1,

     

     

  • JoeMJoeM ✭✭✭

    I get the same result with the nat debug:     v4tov6 entry not found

    I do not believe this has anything to do with the ping, because the error happens without the ping test (while the ping/translation does work). It also happens on a periodic bases from a couple of sources.  One is at about 10 second intervals.

    I added another debug:  debug ip packet detail .   It looks to me, like it is a result of the underlying IPv4 routing protocol hellos.   These do not have the v4tov6 nat mappings for the IPv4 multicast addresses.  This is my guess.

Sign In or Register to comment.