Task 1.2

Hi all, I am trying to do the Task 1.2 but i am getting this msg Rack2SW2(config-if-range)#switchport mode dynamic auto
Command rejected: Conflict between 'nonegotiate' and 'dynamic' status. can someone help pls.

 

regards,

 

Sadrach Costa

Comments

  • Hi,

     

    Show me your run int config for all trunked ports on SW2.

    Which ports are in trunking mode?

     

    Regards,

     

  • This is an order of operation issue, based on the fact that DTP is required to run the port in dynamic mode.

    Starting with the defaults for a switch port (3550) as show below, lets try to disable DTP

    SW1#sho int e3/0 sw
    Name: Et3/0
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: down
    Administrative Trunking Encapsulation: negotiate
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Administrative Native VLAN tagging: enabled
    Operational Native VLAN tagging: disabled
    Voice VLAN: none
    Administrative private-vlan host-association: none
    Administrative private-vlan mapping: none
    Operational private-vlan: none
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL

    SW1(config)#int e3/0
    SW1(config-if)#sw no
    SW1(config-if)#sw nonegotiate
    Command rejected: Conflict between 'nonegotiate' and 'dynamic' status.
    SW1(config-if)#

    This is telling us that we can not disable DTP when the admin state is dynamic.
    OK so lets take the port out of its dynamic state

    SW1(config-if)#sw mode tru
    SW1(config-if)#sw mode trunk
    Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
    SW1(config-if)#

    Similar type of problem. We cannot set the mode to trunk while the encapsulation is set to auto.
    OK. Take another step back and lets set the encapsulation to dot1q, then set the mode to trunk and then disable DTP (switchport nonegotiate)

    SW1(config-if)#switchport trunk encapsulation d
    SW1(config-if)#switchport trunk encapsulation dot1q
    SW1(config-if)#sw mo
    SW1(config-if)#sw mode t
    SW1(config-if)#sw mode trunk
    SW1(config-if)#sw
    SW1(config-if)#switchport no
    SW1(config-if)#switchport nonegotiate

    This time we were able to do it

    Now from this position lets enter the command you were having problems with

    SW1(config-if)#switchport mode dynamic auto
    Command rejected: Conflict between 'nonegotiate' and 'dynamic' status.
    SW1(config-if)#

    Now we get the error that you encountered.

    If however we turn DTP back on first we can can then set the mode to dynamic

    SW1(config-if)#sw no no
    SW1(config-if)#no sw no
    SW1(config-if)#no sw nonegotiate
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#
    SW1(config-if)#switchport mode dynamic auto
    SW1(config-if)#


    SW1#sho int e3/0 sw
    Name: Et3/0
    Switchport: Enabled
    Administrative Mode: dynamic auto
    Operational Mode: down
    Administrative Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Administrative Native VLAN tagging: enabled
    Operational Native VLAN tagging: disabled
    Voice VLAN: none
    Administrative private-vlan host-association: none
    Administrative private-vlan mapping: none
    Operational private-vlan: none
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL

     

    Hope this helps

  • This was my solutions also for this task,thanks.

  • In link level if switchport nonegotiate is configured on the link. It will disable the Dynamic trunking protocol feature of the interface. You may configs on your link as switchport mode trunk and switchport nonegotiate- this means trunk is enabled in the link and Dynamic trunking protocol is disable but it should be configured in both side. if in the other is configured as switchport mode dynamic [auto/desirable] connection will be failed because of the statement defined in the other link switchport nonegotiation. Negotiation on trunk line will be OFF. Check with the command show interface [physical interface] switchport.

     

    Hope this will help :)

     

Sign In or Register to comment.