DHCP snooping not working

Hi,

 

I am doing section number 7.4 of INE workbook Volume1 of dhcp snooping where DHCP server is R3 & R1 is dhcp client I configured SW1 with the following commands

Rack1SW1#sh run | incl dhcp
ip dhcp snooping vlan 13
ip dhcp snooping database flash:/dhcp-bindings.txt
ip dhcp snooping database write-delay 15
ip dhcp snooping
 ip dhcp snooping limit rate 10
 ip dhcp snooping trust

Outputs are below

 

Rack1SW1#sh ip dhcp snooping
Switch DHCP snooping is enabled
DHCP snooping is configured on following VLANs:
13
DHCP snooping is operational on following VLANs:
13
DHCP snooping is configured on the following L3 Interfaces:

Insertion of option 82 is enabled
   circuit-id format: vlan-mod-port
    remote-id format: MAC
Option 82 on untrusted port is not allowed
Verification of hwaddr field is enabled
Verification of giaddr field is enabled
DHCP snooping trust/rate is configured on the following Interfaces:

Interface                    Trusted     Rate limit (pps)
------------------------     -------     ----------------
FastEthernet0/1              no          10
FastEthernet0/3              yes         unlimited

Rack1SW1#sh ip dhcp snooping binding
MacAddress          IpAddress        Lease(sec)  Type           VLAN  Interface
------------------  ---------------  ----------  -------------  ----  --------------------
Total number of bindings: 0

Rack1SW1#more flash:/dhcp-bindings.txt
502d8d49
TYPE DHCP-SNOOPING
VERSION 1
BEGIN
END

Please let me know where exactly the fault is so that I am able to achieve appropirate output

Comments

  • What issue are you facing? R1 not getting an IP Address? 

    If that's the problem, there are a several ways to fix it, but try to disable the insertion of option 82 on the switch with the following global config command:

    no ip dhcp snooping information option

    You may want to shutdown and no shutdown R1's interface afterwards to trigger a DHCP discover. Please let me know if it works for you.

    HTH

    Good luck!

Sign In or Register to comment.