INE labs and GNS3

So this may be a newbie problem but it seems I cannot  load the .net file used for the WB VOL II topologies without dynamips /GNS3 crashing.   I can build pretty complex topologies all day long with no issue but when I load the .net file and start the routers I get a "error unable to comunicate with dynamips server" message.  I'm running on windows 7 box.  I've tried boosting the RAM allocated per IOS image, but still no luck.   I've tried the distributed hypervisor method but am running into other problmes with that set up.  ANyone have any hints or tips?

 

 

Comments

  • Hi,

    How many hypervisors are you using? It would be good to take a look into your .net file. Would you mind posting it here?

    Let us know!

  • right now just using localhost as hypervisor, nothing external.  .Net is below.  Thanks for having a look.....

     

     


    autostart = False

    version = 0.8.2

    [localhost:7200]

    workingdir = C:UsersstielincAppDataLocalTemp

    udp = 10000

    [[3725]]

    image = C:UsersstielincDesktopCCIEGNS3c3725-adventerprisek9-mz.124-25d.bin.unpacked

    ram = 256

    idlepc = 0x60a800f0

    ghostios = True

    [[ROUTER R4]]

    model = 3725

    console = 2004

    aux = 2103

    cnfg = initial.configsR4.initial.config.gns3.cfg

    wic0/0 = WIC-2T

    s0/0 = FR0 5

    s0/1 = R5 s0/1

    f0/0 = SW2 f1/4

    f0/1 = SW4 f1/4

    x = -685.0

    y = 90.0

    z = 1.0

    [[ROUTER R5]]

    model = 3725

    console = 2005

    aux = 2104

    cnfg = initial.configsR5.initial.config.gns3.cfg

    wic0/0 = WIC-2T

    s0/0 = FR0 6

    s0/1 = R4 s0/1

    f0/0 = SW1 f1/5

    f0/1 = SW3 f1/5

    x = -503.0

    y = 256.0

    z = 1.0

    [[ROUTER R6]]

    model = 3725

    console = 2006

    aux = 2105

    cnfg = initial.configsR6.initial.config.gns3.cfg

    wic0/0 = WIC-2T

    s0/0 = BB1 s0/0

    f0/0 = SW2 f1/6

    f0/1 = SW4 f1/6

    x = -336.0

    y = 180.0

    z = 1.0

    [[ROUTER R1]]

    model = 3725

    console = 2001

    aux = 2100

    cnfg = initial.configsR1.cfg

    wic0/0 = WIC-2T

    s0/0 = FR0 1

    s0/1 = R3 s1/2

    f0/0 = SW1 f1/1

    x = -288.0

    y = -53.0

    z = 1.0

    [[ROUTER R2]]

    model = 3725

    console = 2002

    aux = 2101

    idlepc = 0x614ac27c

    cnfg = initial.configsR2.cfg

    wic0/0 = WIC-2T

    s0/0 = FR0 2

    s0/1 = R3 s1/3

    f0/0 = SW2 f1/2

    x = -648.0

    y = -62.0

    z = 1.0

    [[ROUTER R3]]

    model = 3725

    console = 2003

    aux = 2102

    cnfg = initial.configsR3.cfg

    f0/0 = SW1 f1/3

    f0/1 = SW3 f1/3

    slot1 = NM-4T

    s1/0 = FR0 3

    s1/1 = FR0 4

    s1/2 = R1 s0/1

    s1/3 = R2 s0/1

    x = -462.0

    y = -102.0

    z = 1.0

    [[ROUTER BB2]]

    model = 3725

    console = 2012

    aux = 2111

    cnfg = initial.configsBB2.cfg

    f0/0 = SW2 f1/0

    x = -777.0

    y = -208.0

    z = 1.0

    [[FRSW FR0]]

    1:102 = 2:201

    1:103 = 3:301

    1:104 = 5:401

    1:105 = 6:501

    1:113 = 4:311

    2:201 = 1:102

    2:203 = 3:302

    2:204 = 5:402

    2:205 = 6:502

    2:213 = 4:312

    3:301 = 1:103

    3:302 = 2:203

    3:304 = 5:403

    3:305 = 6:503

    4:311 = 1:113

    4:312 = 2:213

    4:314 = 5:413

    4:315 = 6:513

    5:401 = 1:104

    5:402 = 2:204

    5:403 = 3:304

    5:405 = 6:504

    5:413 = 4:314

    6:501 = 1:105

    6:502 = 2:205

    6:503 = 3:305

    6:504 = 5:405

    6:513 = 4:315

    1 = R1 s0/0

    2 = R2 s0/0

    3 = R3 s1/0

    4 = R3 s1/1

    5 = R4 s0/0

    6 = R5 s0/0

    x = -469.5

    y = 77.5

    z = 1.0

    [[ROUTER SW1]]

    model = 3725

    console = 2007

    aux = 2106

    cnfg = initial.configsSW1.cfg

    slot1 = NM-16ESW

    f1/1 = R1 f0/0

    f1/3 = R3 f0/0

    f1/5 = R5 f0/0

    f1/7 = SW2 f1/7

    f1/8 = SW2 f1/8

    f1/9 = SW2 f1/9

    f1/10 = SW3 f1/7

    f1/11 = SW3 f1/8

    f1/12 = SW3 f1/9

    f1/13 = SW4 f1/7

    f1/14 = SW4 f1/8

    f1/15 = SW4 f1/9

    x = -602.0

    y = -344.0

    z = 1.0

    [[ROUTER SW3]]

    model = 3725

    console = 2009

    aux = 2108

    cnfg = initial.configsSW3.cfg

    slot1 = NM-16ESW

    f1/0 = BB3 f0/0

    f1/3 = R3 f0/1

    f1/5 = R5 f0/1

    f1/7 = SW1 f1/10

    f1/8 = SW1 f1/11

    f1/9 = SW1 f1/12

    f1/10 = SW2 f1/10

    f1/11 = SW2 f1/11

    f1/12 = SW2 f1/12

    f1/13 = SW4 f1/13

    f1/14 = SW4 f1/14

    f1/15 = SW4 f1/15

    x = -294.0

    y = -337.0

    z = 1.0

    [[ROUTER SW2]]

    model = 3725

    console = 2008

    aux = 2107

    cnfg = initial.configsSW2.cfg

    slot1 = NM-16ESW

    f1/0 = BB2 f0/0

    f1/2 = R2 f0/0

    f1/4 = R4 f0/0

    f1/6 = R6 f0/0

    f1/7 = SW1 f1/7

    f1/8 = SW1 f1/8

    f1/9 = SW1 f1/9

    f1/10 = SW3 f1/10

    f1/11 = SW3 f1/11

    f1/12 = SW3 f1/12

    f1/13 = SW4 f1/10

    f1/14 = SW4 f1/11

    f1/15 = SW4 f1/12

    x = -616.0

    y = -186.0

    z = 1.0

    [[ROUTER BB3]]

    model = 3725

    console = 2013

    aux = 2112

    cnfg = initial.configsBB3.cfg

    wic0/0 = WIC-2T

    s0/0 = BB1 s0/1

    f0/0 = SW3 f1/0

    x = -210.0

    y = -94.0

    z = 1.0

    [[ROUTER SW4]]

    model = 3725

    console = 2010

    aux = 2109

    cnfg = initial.configsSW4.cfg

    slot1 = NM-16ESW

    f1/4 = R4 f0/1

    f1/6 = R6 f0/1

    f1/7 = SW1 f1/13

    f1/8 = SW1 f1/14

    f1/9 = SW1 f1/15

    f1/10 = SW2 f1/13

    f1/11 = SW2 f1/14

    f1/12 = SW2 f1/15

    f1/13 = SW3 f1/13

    f1/14 = SW3 f1/14

    f1/15 = SW3 f1/15

    x = -296.0

    y = -179.0

    z = 1.0

    [[ROUTER BB1]]

    model = 3725

    console = 2011

    aux = 2110

    cnfg = initial.configsBB1.initial.config.gns3.cfg

    wic0/0 = WIC-2T

    s0/0 = R6 s0/0

    s0/1 = BB3 s0/0

    x = -221.0

    y = 100.0

    z = 1.0

    [GNS3-DATA]

    configs = initial.configs

  • As far as I rember the INE topology uses two hypervisor instances, one on port 7200 and another on port 7201. There is a bat script for starting the INE topology correct, which starts the two hypervisors

    - Perhaps your problem is that you only load one hypervisor, and that's the reason for your dynamips error?

    --Anders

  • ahhhh, let me compare working and non-working .net files and see, Thanks!

  • autostart = False

    version = 0.8.2

    [localhost:7200]

        workingdir = C:UsersANENST~1.NTIAppDataLocalTemp1

        udp = 10000

        [[3725]]

            image = C:Usersanenstiel.NTIS2DesktopGNS3c3725-adventerprisek9-mz.124-25d.bin.unpacked

            ram = 128

            idlepc = 0x614ac21c

            ghostios = True

        [[ROUTER R4]]

            model = 3725

            console = 2004

            aux = 2103

            cnfg = initial.configsR4.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = FR0 5

            s0/1 = R5 s0/1

            f0/0 = SW2 f1/4

            f0/1 = SW4 f1/4

            x = -685.0

            y = 90.0

            z = 1.0

        [[ROUTER R5]]

            model = 3725

            console = 2005

            aux = 2104

            cnfg = initial.configsR5.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = FR0 6

            s0/1 = R4 s0/1

            f0/0 = SW1 f1/5

            f0/1 = SW3 f1/5

            x = -503.0

            y = 256.0

            z = 1.0

        [[ROUTER R6]]

            model = 3725

            console = 2006

            aux = 2105

            cnfg = initial.configsR6.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = BB1 s0/0

            f0/0 = SW2 f1/6

            f0/1 = SW4 f1/6

            x = -336.0

            y = 180.0

            z = 1.0

        [[ROUTER R1]]

            model = 3725

            console = 2001

            aux = 2100

            cnfg = initial.configsR1.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = FR0 1

            s0/1 = R3 s1/2

            f0/0 = SW1 f1/1

            x = -288.0

            y = -53.0

            z = 1.0

        [[ROUTER R2]]

            model = 3725

            console = 2002

            aux = 2101

            idlepc = 0x614ac27c

            cnfg = initial.configsR2.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = FR0 2

            s0/1 = R3 s1/3

            f0/0 = SW2 f1/2

            x = -648.0

            y = -62.0

            z = 1.0

        [[ROUTER R3]]

            model = 3725

            console = 2003

            aux = 2102

            cnfg = initial.configsR3.initial.config.gns3.cfg

            f0/0 = SW1 f1/3

            f0/1 = SW3 f1/3

            slot1 = NM-4T

            s1/0 = FR0 3

            s1/1 = FR0 4

            s1/2 = R1 s0/1

            s1/3 = R2 s0/1

            x = -462.0

            y = -102.0

            z = 1.0

        [[ROUTER BB2]]

            model = 3725

            console = 2012

            aux = 2111

            cnfg = initial.configsBB2.initial.config.gns3.cfg

            f0/0 = SW2 f1/0

            x = -777.0

            y = -208.0

            z = 1.0

        [[FRSW FR0]]

            1:102 = 2:201

            1:103 = 3:301

            1:104 = 5:401

            1:105 = 6:501

            1:113 = 4:311

            2:201 = 1:102

            2:203 = 3:302

            2:204 = 5:402

            2:205 = 6:502

            2:213 = 4:312

            3:301 = 1:103

            3:302 = 2:203

            3:304 = 5:403

            3:305 = 6:503

            4:311 = 1:113

            4:312 = 2:213

            4:314 = 5:413

            4:315 = 6:513

            5:401 = 1:104

            5:402 = 2:204

            5:403 = 3:304

            5:405 = 6:504

            5:413 = 4:314

            6:501 = 1:105

            6:502 = 2:205

            6:503 = 3:305

            6:504 = 5:405

            6:513 = 4:315

            1 = R1 s0/0

            2 = R2 s0/0

            3 = R3 s1/0

            4 = R3 s1/1

            5 = R4 s0/0

            6 = R5 s0/0

            x = -469.5

            y = 77.5

            z = 1.0

        [[ROUTER SW1]]

            model = 3725

            console = 2007

            aux = 2106

            cnfg = initial.configsSW1.initial.config.gns3.cfg

            slot1 = NM-16ESW

            f1/1 = R1 f0/0

            f1/3 = R3 f0/0

            f1/5 = R5 f0/0

            f1/7 = SW2 f1/7

            f1/8 = SW2 f1/8

            f1/9 = SW2 f1/9

            f1/10 = SW3 f1/7

            f1/11 = SW3 f1/8

            f1/12 = SW3 f1/9

            f1/13 = SW4 f1/7

            f1/14 = SW4 f1/8

            f1/15 = SW4 f1/9

            x = -602.0

            y = -344.0

            z = 1.0

        [[ROUTER SW3]]

            model = 3725

            console = 2009

            aux = 2108

            cnfg = initial.configsSW3.initial.config.gns3.cfg

            slot1 = NM-16ESW

            f1/0 = BB3 f0/0

            f1/3 = R3 f0/1

            f1/5 = R5 f0/1

            f1/7 = SW1 f1/10

            f1/8 = SW1 f1/11

            f1/9 = SW1 f1/12

            f1/10 = SW2 f1/10

            f1/11 = SW2 f1/11

            f1/12 = SW2 f1/12

            f1/13 = SW4 f1/13

            f1/14 = SW4 f1/14

            f1/15 = SW4 f1/15

            x = -294.0

            y = -337.0

            z = 1.0

        [[ROUTER SW2]]

            model = 3725

            console = 2008

            aux = 2107

            cnfg = initial.configsSW2.initial.config.gns3.cfg

            slot1 = NM-16ESW

            f1/0 = BB2 f0/0

            f1/2 = R2 f0/0

            f1/4 = R4 f0/0

            f1/6 = R6 f0/0

            f1/7 = SW1 f1/7

            f1/8 = SW1 f1/8

            f1/9 = SW1 f1/9

            f1/10 = SW3 f1/10

            f1/11 = SW3 f1/11

            f1/12 = SW3 f1/12

            f1/13 = SW4 f1/10

            f1/14 = SW4 f1/11

            f1/15 = SW4 f1/12

            x = -616.0

            y = -186.0

            z = 1.0

        [[ROUTER BB3]]

            model = 3725

            console = 2013

            aux = 2112

            cnfg = initial.configsBB3.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = BB1 s0/1

            f0/0 = SW3 f1/0

            x = -210.0

            y = -94.0

            z = 1.0

        [[ROUTER SW4]]

            model = 3725

            console = 2010

            aux = 2109

            cnfg = initial.configsSW4.initial.config.gns3.cfg

            slot1 = NM-16ESW

            f1/4 = R4 f0/1

            f1/6 = R6 f0/1

            f1/7 = SW1 f1/13

            f1/8 = SW1 f1/14

            f1/9 = SW1 f1/15

            f1/10 = SW2 f1/13

            f1/11 = SW2 f1/14

            f1/12 = SW2 f1/15

            f1/13 = SW3 f1/13

            f1/14 = SW3 f1/14

            f1/15 = SW3 f1/15

            x = -296.0

            y = -179.0

            z = 1.0

        [[ROUTER BB1]]

            model = 3725

            console = 2011

            aux = 2110

            cnfg = initial.configsBB1.initial.config.gns3.cfg

            wic0/0 = WIC-2T

            s0/0 = R6 s0/0

            s0/1 = BB3 s0/0

            x = -221.0

            y = 100.0

            z = 1.0

    [GNS3-DATA]

        configs = initial.configs

     

     

  • so the INE .net is in fact missing the hypervisor entry for localhost :7201, which I see in a .net that works fine.  I tried copying what I thought was missing and adding it in but I'm still having same problem.   I tried posting the .net file here but I keep getting an message saying the moderator will need to review first.

    Anyone have a .net for the INE workbook that knows it works that I could have a look at?

  • Could you just copy and paste the text from your .net file here instead, I don't think this forum allows for files being uploaded until approved by INE?

  • If you download the INE topology from here: http://www.ine.com/downloads/internetwork.expert.topologies.zip you'll see when you unpack the file, that there is a folder called "sample labs" under there you'll find a file called "ine.routing.and.switching.topology.5.00.net" if you open that with a text editor you can see that there is two defined instances:

    ##################################################
    #
    # Define global router parameters for instance 1
    #
    ##################################################

    and

    ##################################################
    #
    # Define global router parameters for instance 2
    #
    ##################################################

    Which respectively opens an instance:

    [localhost:7200] and [localhost:7201]

    In the root of the unpacked zip file, you'll find a file called "dynamips-start.cmd" which has the following content in it:

    @echo off
    rem Launch a local copy of dynamips
    start /belownormal /min "Dynamips" "dynamips.exe" -H 7200
    start /belownormal /min "Dynamips" "dynamips.exe" -H 7201

    That's a bat fil that starts the two instances of dynamips, referencing to the defined instances in the .net file.

    So what you'll need to do is first fun the file "dynamips-start.cmd", and the afterwards load the .net file into your Dynagen front-end. You'll see then you open "dynamips-start.cmd" that two minimized cmd prompts are opened. Also please see the readme file attached to the zip file :)

    -- For Windows overwrite the dynamips-start.cmd shortcut
    -- This allows multiple dynamips hypervisor instances to run

    - For Dynagen under Windows
    -- Launch the ine.routing.and.switching.topology.5.00.net file

    --Anders

  • Thanks Anders, I tried copying and pasting the ine.routing.and.switching.topology.5.00.gns3 file here but thats when I get the moderator message, but it's all good I think you've point me in the right direction.  Saw the readme but was a little confused as to what was meant by overwriting the .cmd shortcut.

    when i try runing "dnamips-start.cmd" I get an error stating "cannot find dynamips.exe"

    when I run the dynamips 'test' from within GNS3, I get the 'Dynamips has successfully started' message.

    If you ask me this is more difficult then the CCIE content :)

     

     

     

  • if you are using windows 7, then local host will not work. you should use 127.0.0.1. give it a try.

  • I have uploaded a sample INE .net file to my profile, you can use this one as a base for your own .net file.

    Hope this helps

    http://ieoc.com/members/qqabdal/default.aspx

    Good luck!

  • thank you, the sample .net file helped me figure out what I was doing wrong, I'm up and running now!  Thanks!

  • thank you, the sample .net file helped me figure out what I was doing wrong, I'm up and running now!  Thanks!

    You are welcome. 

    Good luck with your studies!

Sign In or Register to comment.