Help With BGP!!!

Hi,

I have a question about BGP. Say you have 4 routers (R1, R2, R3 and R4). R1 is in AS 1. R2 and R4 are in the AS 24. R3 is connected to R2 and R4 and is not running BGP. OSPF is running between R2, R3 and R4 so all there interfaces and loopback are reachable. how can R4 get to R1's loopback without BGP running on R3 or adding a default route(or use redistribution)?

(AS1)      (   OSPF Ar 0       )
(R1)------(R2)---(R3)---(R4)

R4
router bgp 4
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 4
neighbor 2.2.2.2 update-source loopback 1
bgp confederation identifier 24
bgp confederation peers 2

R2
router bgp 2
neighbor 4.4.4.4 remote-as 4
neighbor 4.4.4.4 ebgp-multihop 4
neighbor 4.4.4.4 update-source loopback 1
bgp confederation identifier 24
bgp confederation peers 4

neighbor 1.1.1.1 remote-as 1

R1
router bgp 1
neighbor 2.2.2.2 remote-as 24
network 1.1.1.0 mask 255.255.255.0

Comments

  • Hi Pop,

    First i dont see any BGP neighborship between R1 and R2, Please configure that.

    You can have a tunnel between R2 and R4 and run BGP on top of that. this way R3 can remain a non-bgp router.

     

    Tahir 

  • Thanks for your reply. The above is just a sample of the config for you to get an idea how it's configured and not the full config. But is there any other way other then using a tunnel?

  • Is this a lab/problem solving question, or a real world question?  If the latter, what's the issue with adding a default route on r3 to one (or both) of the remaining OSPF neighbors in the AS?

  • how can R4 get to R1's loopback without BGP running on R3 or adding a default route(or use redistribution)?

    You are eliminating default route, redistribution and also tunnel, i dont think there can be other way besides these unless you use some trick to manipulate routing such as policy routing here.

  • You could use a GRE tunnel in this case.

    Why do you need this? Is this for real-world or a lab scenario? Just curious here.

  • You could use a GRE tunnel in this case.

    He has also eliminated tunnel option. Is there any other way ?

  • He has also eliminated tunnel option. Is there any other way ?

    As you stated, he pretty much eliminated all the possibilities. PBR may be the only way out, but did not have a chance to lab it up yet.

  • Hi,

    Thank you all for replying. This question is just for my general
    knowledge. I wanted to know if there is a way you can have non BGP routers with
    BGP router and it would work. I am studding for BGP exam and just wanted to know. Thanks again.

Sign In or Register to comment.