IGMP Access-group

Topology:  Source ----RP/MA----Rx----Receiver       (Sparse Dense mode)

Configure Rx so receiver can only join multicast group-1

 

Rx: ip access-list standard <ACL>

           permit <multicast group-1 >

      interface facing receiver> ip igmp access-group <ACL>

Receiver:

       int > ip igmp join <multicast group-1>

              ip igmp join <multicast group-2>               

 

Test from source:

1.  Ping multicast group-1   : should be allowed (ok).

2.  Ping multicast group-2   : should be rejected, 

     but i keep getting reply.

 

What i'm missing here ?

 

Comments

  • This configuration looks fine if you are using igmpv1 or v2 and the this ACL is applied on the router interface connecting to the receivers. you should not see multicast-group-2 entry in the output "show ip igmp group" on the router connected to the receivers.

  • On Rx disable cef and fast switching and run...

    "debug ip igmp"

    "debug ip packet"

    "debug ip mpacket"

     

    And take a look if you can see anythin interesting. In my eyes config also should be fine.

    Hint: config it the way it should work and reboot everything. Is this real gear or dynamips?

     

    Regards!

    Markus

  • Do you have pim enabled on the receiver facing the Rx?

    If yes...disable it because it will initiate a pim join and not a igmp request then.

    Regards!

    Markus

  • Do you have pim enabled on the receiver facing the Rx?

    If yes...disable it because it will initiate a pim join and not a igmp request then.

    PIM send a join to upstream pim neighbor only when its interface joins the igmp group, the better way to test the igmp access-group like this

    SW1(f0/1)----------(f0/0)R1------Multicast network

    Configure PIM on both sw1 and R1 interfaces with multicast enable on them. Apply igmp access-group on R1's f0/0. configure sw1's f0/1 to join igmp groups and check the "show ip igmp group" it should not show denied igmp group finally try to pim that deny igmp group from source.

  • PIM send a join to upstream pim neighbor only when its interface joins the igmp group, the better way to test the igmp access-group like this

    Hmm gotta read through that I think...

  • Markus

    You're right :)  Thanks !


     

    Do you have pim enabled on the receiver facing the Rx?  YES

    If yes...disable it because it will initiate a pim join and not a igmp request then.

     

    Ping to multicast group-2 get NO reply now.

     

     

  • Hi!

    Just for details! You deactivated PIM on the Router-Interface that will get demand the multicast-group with "ip igmp join-group x.x.x.x" right? Not that we are talking about two different things. Thatll be not nice :).

     

    Regards!

    Markus

Sign In or Register to comment.