BGP LAB ISSUE?

hi Team

 

today i create full mesh BGP LAB now i get problem that when i run SHOW IP BGP i get rib failure massage in output this lab Scenario i create from Jeff Doyle Vol 2 book and in book they did same configuration what i did but there in no rib-failure error in it u can refere page number 187 of this lab IBGP without IGP.I know the reason behind Rib-failure becoz there is better low adminstrative distance route present in routing table and i advertise that prefix through bgp thats why get rib-failure error but its lab demand we have to not use IGP so i have to advertise prefixes to make it full mesh..............pls help me how to fix it and why book has not show rib-failure if m right

M posting my config

 

ALTA

 

!
!
! Last configuration change at 19:33:42 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ALTA
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.50.1 255.255.255.0
 !
!
interface Loopback1
 ip address 192.168.75.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.1.201 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial1/0
 ip address 192.168.1.205 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.200 mask 255.255.255.252
 network 192.168.50.0
 network 192.168.75.0
 neighbor 192.168.1.206 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

ASPEN

!
!
! Last configuration change at 19:47:01 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ASPEN
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.222 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 ip address 192.168.1.198 255.255.255.252
 duplex auto
 speed auto
 !
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.196 mask 255.255.255.252
 network 192.168.1.220 mask 255.255.255.252
 neighbor 192.168.1.197 remote-as 100
 neighbor 192.168.1.221 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

TAHOE

!
!
! Last configuration change at 19:40:28 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TAHOE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.250.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.1.213 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial1/0
 ip address 192.168.1.210 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.212 mask 255.255.255.252
 network 192.168.250.0
 neighbor 192.168.1.209 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

TAOS

!
!
! Last configuration change at 19:35:15 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TAOS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.100.1 255.255.255.0
 !
!
interface Loopback1
 ip address 192.168.200.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.1.217 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial1/0
 ip address 192.168.1.225 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.216 mask 255.255.255.252
 network 192.168.100.0
 network 192.168.200.0
 neighbor 192.168.1.226 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

TELLURIDE

!
!
! Last configuration change at 19:42:23 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TELLURIDE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.197 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial1/0
 ip address 192.168.1.206 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.204 mask 255.255.255.252
 neighbor 192.168.1.198 remote-as 100
 neighbor 192.168.1.205 remote-as 400
 neighbor 192.168.1.221 remote-as 100
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

VAIL

!
!
! Last configuration change at 19:44:31 UTC Sat Feb 18 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VAIL
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.221 255.255.255.252
 duplex auto
 speed auto
 !
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial1/0
 ip address 192.168.1.209 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/1
 ip address 192.168.1.226 255.255.255.252
 serial restart-delay 0
 !
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.208 mask 255.255.255.252
 network 192.168.1.224 mask 255.255.255.252
 neighbor 192.168.1.197 remote-as 100
 neighbor 192.168.1.210 remote-as 300
 neighbor 192.168.1.222 remote-as 100
 neighbor 192.168.1.225 remote-as 200
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
 !
!
!
!
!
!
gatekeeper
 shutdown
!
alias interface show do show
alias configure show do show
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
line vty 5 15
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 no login
!
end

 

 

ALTA#sh ip bgp
BGP table version is 15, local router ID is 192.168.75.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.196/30 192.168.1.206                          0 100 i
*> 192.168.1.200/30 0.0.0.0                  0         32768 i
r> 192.168.1.204/30 192.168.1.206            0             0 100 i
*> 192.168.1.208/30 192.168.1.206                          0 100 i
*> 192.168.1.212/30 192.168.1.206                          0 100 300 i
*> 192.168.1.216/30 192.168.1.206                          0 100 200 i
*> 192.168.1.220/30 192.168.1.206                          0 100 i
*> 192.168.1.224/30 192.168.1.206                          0 100 i
*> 192.168.50.0     0.0.0.0                  0         32768 i
*> 192.168.75.0     0.0.0.0                  0         32768 i
*> 192.168.100.0    192.168.1.206                          0 100 200 i
*> 192.168.200.0    192.168.1.206                          0 100 200 i
*> 192.168.250.0    192.168.1.206                          0 100 300 i

 

TAHOE#sh ip bgp
BGP table version is 15, local router ID is 192.168.250.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.196/30 192.168.1.209                          0 100 i
*> 192.168.1.200/30 192.168.1.209                          0 100 400 i
*> 192.168.1.204/30 192.168.1.209                          0 100 i
r> 192.168.1.208/30 192.168.1.209            0             0 100 i
*> 192.168.1.212/30 0.0.0.0                  0         32768 i
*> 192.168.1.216/30 192.168.1.209                          0 100 200 i
*> 192.168.1.220/30 192.168.1.209                          0 100 i
*> 192.168.1.224/30 192.168.1.209            0             0 100 i
*> 192.168.50.0     192.168.1.209                          0 100 400 i
*> 192.168.75.0     192.168.1.209                          0 100 400 i
*> 192.168.100.0    192.168.1.209                          0 100 200 i
*> 192.168.200.0    192.168.1.209                          0 100 200 i
*> 192.168.250.0    0.0.0.0                  0         32768 i

 

 

image

Comments

  • today i create full mesh BGP LAB now i get problem that when i run SHOW IP BGP i get rib failure massage in output this lab Scenario i create from Jeff Doyle Vol 2 book and in book they did same configuration what i did but there in no rib-failure error in it u can refere page number 187 of this lab IBGP without IGP.I know the reason behind Rib-failure becoz there is better low adminstrative distance route present in routing table and i advertise that prefix through bgp thats why get rib-failure error but its lab demand we have to not use IGP so i have to advertise prefixes to make it full mesh..............pls help me how to fix it and why book has not show rib-failure if m right

    If you are not using any IGP in AS 100 just IBGP then you should not get rip-failure.

  • Hi Dcancerian then why m getting pls check i add output and config if u wana i post complete lab

     

    pls help to fix it

  • Hi Dcancerian then why m getting pls check i add output and config if u wana i post complete lab


    pls help to fix it

  • Hi praveen,

    Looks like you are getting rib-failures for your directly connected networks. Please check if you are advertising your serial links into BGP. If so, remove them.

    Cheers!

  • Hi Qqabdal

    what u r saying is right but if u refer the same lab in Jeff doyle vol 2 page 184 with same config there is no issue then why m getting such issue and how to fix it

  • Can you please post the topology you are working on? That would make it a little bit easier. You say that you are running a full-mesh of BGP, but that does not seem to be the case here.

    Thanks in advance.

  • On which machine do you get the RIB failure?

    Topology would be nice indeed!

     

  • Hi Dcancerian then why m getting pls check i add output and config if u wana i post complete lab

    Wo.. your config is too large to review alright, lets take on one case out of two where rib failure occurs i.e Alta and Telluride.

    Connected routes are also consider as special type of IGP with AD 0 so they also belong to routing table "show ip route connected" just like any other IGPs. This is why we can advertise connected route via network statement as if these are IGP learned routes.

    This topology has ebgp between Alta and Telluride on link 192.168.1.204/30 connected between them, Telluride is advertising connected route192.168.1.204/30 via network statement under bgp process. This routes reaches to Alta as ebgp AD=20, Alta also has same connected route 192.168.1.204/30 with AD=0 though Alta install this route in bgp table as best route but since it also has the same route as connected with less administrative distance therefore rip=failure occurs. Similarly on the Tahoe router.

  • Hello,

    the million dollar question is: WHAT'S A RIB FAILURE?[:D]

    You get a RIB when you have a prefixe in your BGP table but you have learned that same prefixe via another routing protocol with a better Administrative distance.

    You are advertising your connected routes through BGP. You learned the /30 prefixes from your BGP peers but you already have a route in your routing table since the network is a connected one. A show ip bgp of the prefix or a show ip bgp rib-failures will show you which prefixes were silently ignored by the BGP process. 

    It does not hurt but in turn it's not a best practice and I do not know a case where you will need to advertise your connnected interfaces through BGP.


    HTH


     

  • Hi Malick,

    Awesome explanation!!

  • Malick,

    Awesome explanation!


  • Malick,

    Awesome explanation!

  • Hi Ndiayemalick

     

    thanks for your reply this topology is from jeff doyle vol2 book its jef case studys and there he wants connected routes to be advertise i know rib-failure cause due to best AD exist for prefix but i try in lab to make AD higher even  then i am getting Rib-failure ................actually i use OSPF in between and change ospf metric while redistribution to 210 so as per me now it has to select IBGP learned route but its still choose OSPF routes and show rib-failure..........

Sign In or Register to comment.