Task 8.2 - Traffic Marking

Here is my answer to the question 8.2. Is this correct? It says to mark all outgoing packet except VOIP and OSPF packets with DE-bit.


!

class-map match-all CRITICAL

 match not packet length min 80 max 100

 match not protocol ospf

 match any

!


policy-map STRICT

 class CRITICAL

  set fr-de

!


I am not sure I agree with SG with the way it classified the traffic. Wouldn't class ANY set fr-de on all packet including the OSPF and VOIP because it is not excluded from the ANY class! Pls help.


class-map match-any CRITICAL

 match packet length min 80 max 100

 match protocol ospf



!

policy-map MARK

 class CRITICAL 

 class ANY

 set fr-de

Comments


  • Your solution is correct and the SG solution is correct as well.

     

    With the SG solution class-map CRITICAL sort of exempts OSPF and VoIP packets from the class-default. So when you reference the class-map CRITICAL under the MARK policy-map you are excluding OSPF and VoIP from being set with the de bit.

     

    HTH

    Good luck!

  • Here is my answer to the question 8.2. Is this correct? It says to mark all outgoing packet except VOIP and OSPF packets with DE-bit.

    class-map match-all CRITICAL

     match not packet length min 80 max 100

     match not protocol ospf

     match any

    !policy-map STRICT

     class CRITICAL

      set fr-de

    !I am not sure I agree with SG with the way it classified the traffic. Wouldn't class ANY set fr-de on all packet including the OSPF and VOIP because it is not excluded from the ANY class! Pls help.


    class-map match-any CRITICAL

     match packet length min 80 max 100

     match protocol ospf

    policy-map MARK

     class CRITICAL 

     class ANY

     set fr-de

    Both solutions are correct, in this we just need somehow exclude ospf and voip traffic from setting fr-de. This can be another solution

    class-map ospf

    match protocol ospf

    class-map voip

    match packet length min 80 max 100

     

    policy-map POLICY

    class ospf

    class voip

    class class-default

    set fr-de

     

  • Hi,

    the way i approached this was as follows:

    class-map match-any NOT_VOIP_OR_OSPF
     match not packet length min 80 max 100
     match not protocol ospf


    policy-map MARK_WITH_FR_DE
     class NOT_VOIP_OR_OSPF
      set fr-de

    so voip and ospf with be sent unmarked in class default.

     

    would this score the point in the actual exam? as the other above configs?

     

    regards

  • class-map match-any NOT_VOIP_OR_OSPF
     match not packet length min 80 max 100
     match not protocol ospf

    policy-map MARK_WITH_FR_DE
     class NOT_VOIP_OR_OSPF
      set fr-de

    so voip and ospf with be sent unmarked in class default.

    This solution seems to be correct and i think you should score points in the lab.

  • The question said "between 80 and 100 bytes", and since these are intger values, the interval between them would be the following range, right?

    Beginning at 81 through and including 99?

    For example I did:

    class-map match-all class_voip
     match packet length min 81 max 99

     

    Last time with a question dealing with a start time of 13 hours they wanted 12 hours 59 minutes in the answer, so that is why I'm trying to pay attention to this level of detail now.

     

    Also, my policy-map was similar to this:

    policy-map map_frameout
     class class_voip
     class class_ospf
     class class-default
      set fr-de

     

  • Here is my solution:

     


    ip access-list extended OSPF

      permit ospf any any 

    !

    exit

    !

    class-map match-any MATCH_NOT

      match not access-group name OSPF

      match not packet length min 80 max 100

    !

    exit

    policy-map MARK_DE

      class MATCH_NOT

      set fr-de

    !

    exit

    !

    interface Serial0/0.134 multipoint

      service-policy output MARK_DE

    !

     

    Also very similar to what has been discussed here already. My train of thought with this one was to explicitly exempt the desired traffic from being marked by NOT matching it with the class-map. The way the SG does it acomplishes the same thing, it's just that my way of thinking about it is different. I have not really ever done it how they did it in the SG, listing a class-map under a policy-map with no "set" options just to list it so that it gets exempted from the catch-all at the end.

    Pablo

  • I also did something similar which was a bit different to SG:

     

    class-map match-all VOIP
     match packet length min 80 max 100
    class-map match-all OSPF
     match access-group name OSPF

     

    ip access-list extended OSPF
    permit ospf any any

    policy-map MARKING
     class VOIP
     class OSPF
     class class-default
      set fr-de

    I believe this would be an acceptable solution

     

Sign In or Register to comment.