original config between BB1 and R6

Greets again, i'm trying to validate if there's something specific i'm missing in original Layer2 configuration that should be applied to BB1 and R6. 

In my case it seems they are connected over frame relay switch cloud connection... 

zzz

 

I am running dynamips so here how my BB1 interfaces assigned :

RS.1.1.BB1#sh ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down   
FastEthernet0/1            unassigned      YES NVRAM  administratively down down   
Serial1/0                  172.16.4.1      YES NVRAM  up                    up     
Serial1/1                  unassigned      YES NVRAM  up                    down   
Serial1/1.51               54.1.3.254      YES NVRAM  down                  down   
Serial1/1.100              54.1.2.254      YES NVRAM  down                  down   
Serial1/1.101              54.1.1.254      YES NVRAM  down                  down   
Serial1/1.201              unassigned      YES unset  down                  down   
Serial1/1.301              unassigned      YES unset  down                  down   
Serial1/1.401              unassigned      YES unset  down                  down   
Serial1/2                  unassigned      YES NVRAM  administratively down down   
Serial1/3                  unassigned      YES NVRAM  administratively down down   
BVI1                       54.1.10.254     YES NVRAM  down                  down   
Virtual-Access1            54.1.7.254      YES TFTP   down                  down   
Virtual-Template1          54.1.7.254      YES NVRAM  down                  down   
Virtual-Access2            54.1.8.254      YES TFTP   down                  down   
Virtual-Access3            unassigned      YES unset  down                  down   
Virtual-Template11         54.1.8.254      YES NVRAM  down                  down   
Loopback112                112.0.0.1       YES NVRAM  up                    up     
Loopback113                113.0.0.1       YES NVRAM  up                    up     
Loopback114                114.0.0.1       YES NVRAM  up                    up     
Loopback115                115.0.0.1       YES NVRAM  up                    up     
Loopback116                116.0.0.1       YES NVRAM  up                    up

hovewer BB1 DLCI's just in inactive state - they go up for few seconds after i reboot but the shut down again...

BB1 :

Serial1/1.51 (down): point-to-point dlci, dlci 51(0x33,0xC30), broadcast
          status defined, inactive
Serial1/1.100 (down): point-to-point dlci, dlci 100(0x64,0x1840), broadcast
          status defined, inactive
Serial1/1.101 (down): point-to-point dlci, dlci 101(0x65,0x1850), broadcast
          status defined, inactive
Serial1/1.201 (down): point-to-point dlci, dlci 201(0xC9,0x3090), broadcast
          status defined, inactive
Serial1/1.301 (down): point-to-point dlci, dlci 301(0x12D,0x48D0), broadcast
          status defined, inactive
Serial1/1.401 (down): point-to-point dlci, dlci 401(0x191,0x6410), broadcast
          status defined, inactive

R6 :

Serial0/0 (up): ip 54.1.1.254 dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status deleted

=====================================================================================

Whenever i setup frame relay end-to-end connection between them and set "no keepalive" ping works fine !!!

Enable FR debug packets but there's not much chatter, perhaps something in my .net file or its something simple i'm not seeing ?

[[Router BB1]]
  model = 3725
  console = 2011
  autostart = False
  slot1 = NM-4T
  S1/0 = BB3 S1/0
  S1/1 = FRSW 21


  # R6 to FRSW
  6:51 = 21:51
  6:100 = 21:100
  6:101 = 21:101
  6:201 = 21:201
  6:301 = 21:301
  6:401 = 21:401

 

Comments

  • Looks OK to me. Can you paste how R6 is connected in your .net file. Can you also paste running config of interfaces for R6 and BB1.

    If you debug LMI do you see anything?

  • unsobill - I think this is back-to-back FR. So no FR SW in between.

    "[[Router BB1]]
    .....
    S1/1 = FRSW 21"

    Andrius
  • Hey Daniel,  here it is... i've noticed slot1 commented out for some reason...

    [[Router R6]]
      model = 3725
      console = 2006
      autostart = False
      #slot1 = NM-4T
      F0/0 = nio_linux_eth:eth8 # SW2 F0/6
      F0/1 = nio_linux_eth:eth7 # SW4 F0/6
      S0/0 = FRSW 6

     

     

    ---- debug lmi displaying  on :

    BB1 -  Serial1/1(down): DCE LMI timeout

    R6 - Mar  1 00:00:36.987: Serial0/0: FR invalid/unexpected pak received on DLCI 51
    *Mar  1 00:00:36.991: Serial0/0(i): dlci 101(0x1851), pkt type 0x800, datagramsize 104


    *Mar  1 00:00:37.371: Serial0/0: FR invalid/unexpected pak received on DLCI 401
    *Mar  1 00:00:39.199: Serial0/0(out): StEnq, myseq 3, yourseen 0, DTE up
    *Mar  1 00:00:39.203: datagramstart = 0x8700E94, datagramsize = 13
    *Mar  1 00:00:39.203: FR encap = 0xFCF10309
    *Mar  1 00:00:39.203: 00 75 01 01 01 03 02 03 00


    **Mar  1 00:00:49.199: Serial0/0(out): StEnq, myseq 1, yourseen 0, DTE down
    *Mar  1 00:00:49.203: datagramstart = 0x8700854, datagramsize = 13
    *Mar  1 00:00:49.203: FR encap = 0xFCF10309
    *Mar  1 00:00:49.207: 00 75 01 01 01 03 02 01 00
    *Mar  1 00:00:49.211:

     

     

  • Can you post configs from routers as well? Looks like there could be a mismatch in LMI type? Not sure what the unexpected pak message means but could have something to do with LMI type since it is working with back to back frame relay. 

  • Can you please post the config of BB1 and R6? This could also be that the interface type on BB1 is dce, just a thought..

  • Rack1R6#sh fram lmi

    LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = CISCO
      Invalid Unnumbered info 0             Invalid Prot Disc 0
      Invalid dummy Call Ref 0              Invalid Msg Type 0
      Invalid Status Message 0              Invalid Lock Shift 0
      Invalid Information ID 0              Invalid Report IE Len 0
      Invalid Report Request 0              Invalid Keep IE Len 0
      Num Status Enq. Sent 13               Num Status msgs Rcvd 0
      Num Update Status Rcvd 0              Num Status Timeouts 12
      Last Full Status Req 00:00:09         Last Full Status Rcvd never
    Rack1R6#sh run int s0/0
    Building configuration...

    Current configuration : 182 bytes
    !
    interface Serial0/0
     ip address 54.1.1.6 255.255.255.0
     encapsulation frame-relay
     clock rate 2000000
     frame-relay map ip 54.1.1.254 101 broadcast
     frame-relay lmi-type cisco
    end

     

     

    RS.1.1.BB1#sh frame lmi

    LMI Statistics for interface Serial1/1 (Frame Relay DCE) LMI TYPE = CISCO
      Invalid Unnumbered info 0             Invalid Prot Disc 0
      Invalid dummy Call Ref 0              Invalid Msg Type 0
      Invalid Status Message 0              Invalid Lock Shift 0
      Invalid Information ID 0              Invalid Report IE Len 0
      Invalid Report Request 0              Invalid Keep IE Len 0
      Num Status Enq. Rcvd 0                Num Status msgs Sent 0
      Num Update Status Sent 0              Num St Enq. Timeouts 14
    RS.1.1.BB1#sh run int s1/1
    Building configuration...

    Current configuration : 167 bytes
    !
    interface Serial1/1
     description Connected to R6
     no ip address
     encapsulation frame-relay
     serial restart-delay 0
     clock rate 64000
     frame-relay intf-type dce
    end

     RS.1.1.BB1#sh run int s1/1.101
    Building configuration...

    Current configuration : 343 bytes
    !
    interface Serial1/1.101 point-to-point
     description PVC 101 to R6
     ip address 54.1.1.254 255.255.255.0
     ip authentication mode eigrp 10 md5
     ip authentication key-chain eigrp 10 EIGRP
     snmp trap link-status
     ipv6 address FE80::254 link-local
     ipv6 address 2001:54:254:1::254/64
     ipv6 rip RIPng enable
     frame-relay interface-dlci 101  
    end

     

  • I don't think this is back to back frame-relay...at least I did not make it back to back, so I think you should remove the fram-relay intf-type dce.

  • qqabdal - I said FR back-to-back because I always thought that INE had r6-bb1 configured as FR back-to-back. However unsobill decided not to configure that way.

     

    unsobill - How are you configured the FR switch? What is the status of PVC on bb1+r6?

    In case you decide to configure them as back-to-back, this is your config.

    ============================


    hostname r1

    interface s0/0

     ip address 10.0.0.1 255.255.255.0

     encapsulation frame-relay

     frame-relay map ip 10.0.0.2 101 cisco

     no keepalive

     no shut

    line con 0

     exec-timeout 0

    end

     

    hostname r2

    interface s0/0

     ip address 10.0.0.2 255.255.255.0

     encapsulation frame-relay

     frame-relay map ip 10.0.0.1 101 cisco

     no keepalive

     no shut

    line con 0

     exec-timeout 0

    end

    ---------------------------------------------------

    r1#sh frame-relay pvc 

    PVC Statistics for interface Serial0/0 (Frame Relay DTE)

     

                  Active     Inactive      Deleted       Static

      Local          0            0            1            0

     

    DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = DELETED, INTERFACE = Serial0/0

     

    r1#sh frame-relay lmi 

    LMI Statistics for interface Serial0/0 (Frame Relay DTE) LMI TYPE = CISCO

      Invalid Unnumbered info 0 Invalid Prot Disc 0

      Invalid dummy Call Ref 0 Invalid Msg Type 0

      Invalid Status Message 0 Invalid Lock Shift 0

      Invalid Information ID 0 Invalid Report IE Len 0

      Invalid Report Request 0 Invalid Keep IE Len 0

      Num Status Enq. Sent 8 Num Status msgs Rcvd 0

      Num Update Status Rcvd 0 Num Status Timeouts 7

      Last Full Status Req 00:00:09 Last Full Status Rcvd never

     

    r1#sh ip int b

    Serial0/0                  10.0.0.1        YES manual up                    down    

     

    r1(config)#int s0/0

    r1(config-if)#no keepalive 

     

    r1#sh ip int b   

    Interface                  IP-Address      OK? Method Status                Protocol

    Serial0/0                  10.0.0.1        YES manual up                    up      

     

    r1#sh frame-relay lmi 

     

    r1#sh frame-relay pvc 

     

    PVC Statistics for interface Serial0/0 (Frame Relay DTE)

     

                  Active     Inactive      Deleted       Static

      Local          1            0            0            0

    DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0

     

    r1#ping 10.0.0.2

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/12 ms

    ============================

    Andrius

  • andrius got it now..if this is not b2b, then he should remove the fram-relay intf-type dce..

  • qqabdal - You are right, remove " frame-relay intf-type dce" on bb1.
    Also, " frame-relay map ip 54.1.1.254 101 broadcast", needs to be
    change to 100 or whatever PVC have you assigned to r6 end.

    correct config below:
    ============================================================
    hostname bb1
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    serial restart-delay 0
    clock rate 64000
    interface Serial0/0.101 point-to-point
    ip address 54.1.1.254 255.255.255.0
    frame-relay interface-dlci 101
    exi
    line con 0
    exec-timeout 0
    end

    hostname r6
    interface Serial0/0
    ip address 54.1.1.6 255.255.255.0
    encapsulation frame-relay
    clock rate 2000000
    frame-relay map ip 54.1.1.254 100 broadcast
    frame-relay lmi-type cisco
    exit
    line con 0
    exec-timeout 0
    end

    hostname frsw
    frame-relay switching
    interface s0/0
    encap frame-relay
    frame-relay intf-type dce
    frame-relay lmi-type cisco
    frame-relay route 101 interface serial 0/1 100
    no shutdown
    interface s0/1
    encap frame-relay
    frame-relay intf-type dce
    frame-relay lmi-type cisco
    frame-relay route 100 interface serial 0/0 101
    no shutdown
    line con 0
    exec-timeout 0
    end
    ============================================================

    Andrius
  • I guess my question was : was it intended to be B2B and R6 missing "no keepalive" command, or there's mistake in default INE configuration file that i need to fix ?

  • unsobill - I guess it depends if there is a FR switch in between :) But they never display how BB are interconnected.

    However looking at the diagram above you can guess b2b, as there is only one dlci shown.

     

    Andrius

  • on my .net file I am using a FRSW between BB1 and R6, so don't use the no keepalive command. You will only need this command if you have B2B...

    I am using an old .net, so I am not sure if they recently changed to B2B frame.

  • Is it possible for you to share that old .net file so i can compare ?

    Thanks.

  • I don't have it handy now, but it was something like this:

     


        [[ROUTER R6]]

            model = 3725

            console = 2006

            aux = 2105

            wic0/0 = WIC-2T

            s0/0 = FRO 6

            f0/0 = SW2 f1/6

            f0/1 = SW4 f1/6

     

        [[ROUTER BB1]]

            model = 3725

            console = 2011

            aux = 2110

            wic0/0 = WIC-2T

            s0/0 = FRO 11

            s0/1 = BB3 s0/0

     

     

  • Can you see if you can load Layer 2 configuration on all routers and BBB's and then try to ping from R6 to BB1 over DLCI 101?

  • You should use the .net from http://www.ine.com/resources/iosonpc.htm

    Just make the IOS and dirs match with your computer. If you have any issues after that I'll help you out.

  • You right indeed, that initial config for BB1 worked with R6 without any changes...

    Here is difference between BB1 initial config from there and BB1 Layer 2 config:

     

     

    BB1 initial config :

    !
    interface Serial1/1
     description Serial to FRS
     no ip address
     encapsulation frame-relay
     no fair-queue
     no shutdown

     

    BB1 Layer 2 config :

    !
    interface Serial1/1
    description Connected to R6
    no ip address
    encapsulation frame-relay
    clockrate 64000
    frame-relay intf-type dce
    no shutdown

     

     

    Apparently layer 2 config using "frame-relay intf-type dce" statement for some unknown reason...

     

     

  • Yes - as I said you should remove the frame-relay intf-type dce in order to have it working.

     

    Glad you sorted it out.

Sign In or Register to comment.