3.10 - Gre Tunnel - Can't ping loopback from SW3 to SW4

I am learning all the routes of loopbacks from R1 to R6 to SW1 on SW3, BUT i can't seem to get the routes for SW2 or SW4. Both have RIP enabled, but for some reason it's not showing. All the routers from R1 to R6 are learning SW1 and SW3 loopbacks but for some reason SW2 and SW4 are missing from the ip route tables.

 

 

SW3 - Show ip route  - You won't find SW2 and SW4 loopback but SW1

 155.1.0.0/24 is subnetted, 12 subnets
R       155.1.146.0 [120/2] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.23.0 [120/2] via 155.1.79.7, 00:00:15, Vlan79
C       155.1.9.0 is directly connected, Vlan9
R       155.1.13.0 [120/2] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.0.0 [120/2] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.7.0 [120/1] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.5.0 [120/3] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.58.0 [120/3] via 155.1.79.7, 00:00:15, Vlan79
R       155.1.45.0 [120/3] via 155.1.79.7, 00:00:16, Vlan79
R       155.1.37.0 [120/1] via 155.1.79.7, 00:00:16, Vlan79
C       155.1.79.0 is directly connected, Vlan79
R       155.1.67.0 [120/1] via 155.1.79.7, 00:00:16, Vlan79
     172.16.0.0/32 is subnetted, 1 subnets
C       172.16.0.9 is directly connected, Loopback1
     150.1.0.0/24 is subnetted, 8 subnets
R       150.1.7.0 [120/1] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.6.0 [120/2] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.5.0 [120/3] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.4.0 [120/3] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.3.0 [120/2] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.2.0 [120/3] via 155.1.79.7, 00:00:17, Vlan79
R       150.1.1.0 [120/3] via 155.1.79.7, 00:00:18, Vlan79
C       150.1.9.0 is directly connected, Loopback0

 

 

SW2 - show ip route - No SW1 or SW3 loopback, only SW4

155.1.0.0/24 is subnetted, 4 subnets
R       155.1.10.0 [120/1] via 155.1.108.10, 00:00:01, Port-channel1
C       155.1.8.0 is directly connected, Vlan8
C       155.1.58.0 is directly connected, Vlan58
C       155.1.108.0 is directly connected, Port-channel1
     150.1.0.0/24 is subnetted, 2 subnets
R       150.1.10.0 [120/1] via 155.1.108.10, 00:00:01, Port-channel1
C       150.1.8.0 is directly connected, Loopback0

 

SW4 - show ip route - No SW1 or SW3 only SW2 showing here.

  155.1.0.0/24 is subnetted, 4 subnets
C       155.1.10.0 is directly connected, Vlan10
R       155.1.8.0 [120/1] via 155.1.108.8, 00:00:19, Port-channel1
R       155.1.58.0 [120/1] via 155.1.108.8, 00:00:19, Port-channel1
C       155.1.108.0 is directly connected, Port-channel1
     172.16.0.0/32 is subnetted, 1 subnets
C       172.16.0.10 is directly connected, Loopback1
     150.1.0.0/24 is subnetted, 2 subnets
C       150.1.10.0 is directly connected, Loopback0
R       150.1.8.0 [120/1] via 155.1.108.8, 00:00:19, Port-channel1

Comments

  • sherlock123 - Let's see your R5 config + "show ip route".

    Andrius

  • R5 - show ip route - I think i see the probem, it's not learning anything from fa 0/0 VLAN 58 and i am not able to ping 155.1.58.8 vlan interface of switch 2.

     

     155.1.0.0/24 is subnetted, 12 subnets

    R       155.1.146.0 [120/1] via 155.1.45.4, 00:00:04, Serial0/1/0

                        [120/1] via 155.1.0.4, 00:00:08, Serial0/0/0

                        [120/1] via 155.1.0.1, 00:00:18, Serial0/0/0

    R       155.1.23.0 [120/1] via 155.1.0.3, 00:00:20, Serial0/0/0

    R       155.1.9.0 [120/3] via 155.1.0.3, 00:00:20, Serial0/0/0

    R       155.1.13.0 [120/1] via 155.1.0.3, 00:00:20, Serial0/0/0

                       [120/1] via 155.1.0.1, 00:00:18, Serial0/0/0

    C       155.1.0.0 is directly connected, Serial0/0/0

    R       155.1.7.0 [120/2] via 155.1.0.3, 00:00:20, Serial0/0/0

    C       155.1.5.0 is directly connected, FastEthernet0/1

    C       155.1.58.0 is directly connected, FastEthernet0/0

    C       155.1.45.0 is directly connected, Serial0/1/0

    R       155.1.37.0 [120/1] via 155.1.0.3, 00:00:02, Serial0/0/0

    R       155.1.79.0 [120/2] via 155.1.0.3, 00:00:02, Serial0/0/0

    R       155.1.67.0 [120/2] via 155.1.45.4, 00:00:13, Serial0/1/0

                       [120/2] via 155.1.0.4, 00:00:17, Serial0/0/0

                       [120/2] via 155.1.0.3, 00:00:02, Serial0/0/0

                       [120/2] via 155.1.0.1, 00:00:27, Serial0/0/0

         150.1.0.0/24 is subnetted, 8 subnets

    R       150.1.7.0 [120/2] via 155.1.0.3, 00:00:02, Serial0/0/0

    R       150.1.6.0 [120/2] via 155.1.45.4, 00:00:13, Serial0/1/0

                      [120/2] via 155.1.0.4, 00:00:17, Serial0/0/0

                      [120/2] via 155.1.0.1, 00:00:27, Serial0/0/0

    C       150.1.5.0 is directly connected, Loopback0

    R       150.1.4.0 [120/1] via 155.1.45.4, 00:00:13, Serial0/1/0

                      [120/1] via 155.1.0.4, 00:00:17, Serial0/0/0

    R       150.1.3.0 [120/1] via 155.1.0.3, 00:00:02, Serial0/0/0

    R       150.1.2.0 [120/2] via 155.1.0.3, 00:00:02, Serial0/0/0

    R       150.1.1.0 [120/1] via 155.1.0.1, 00:00:27, Serial0/0/0

    R       150.1.9.0 [120/3] via 155.1.0.3, 00:00:02, Serial0/0/0

     

    R5 - show run


    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname Rack1R5

    !

    boot-start-marker

    boot-end-marker

    !

    logging message-counter syslog

    !

    no aaa new-model

    dot11 syslog

    ip source-route

    !

    ip cef

    no ip domain lookup

    no ipv6 cef

    !

    multilink bundle-name authenticated

     

    archive

     log config

      hidekeys

    interface Loopback0

     ip address 150.1.5.5 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 155.1.58.5 255.255.255.0

     duplex auto

     speed auto

    !

    interface FastEthernet0/1

     ip address 155.1.5.5 255.255.255.0

     duplex auto

     speed auto

    !

    interface Serial0/0/0

     ip address 155.1.0.5 255.255.255.0

     encapsulation frame-relay

     frame-relay map ip 155.1.0.1 501 broadcast

     frame-relay map ip 155.1.0.2 502 broadcast

     frame-relay map ip 155.1.0.3 503 broadcast

     frame-relay map ip 155.1.0.4 504 broadcast

     no frame-relay inverse-arp

     frame-relay lmi-type cisco

    !

    interface Serial0/1/0

     ip address 155.1.45.5 255.255.255.0

    !

    router rip

     version 2

     network 150.1.0.0

     network 155.1.0.0

     no auto-summary

    !

    ip forward-protocol nd

    no ip http server

    no ip http secure-server

    !

    !

     

    control-plane

    !

    !

    !

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous

    line aux 0

     exec-timeout 0 0

     privilege level 15

    line vty 0 4

     password cisco

     login

    !

    scheduler allocate 20000 1000

    end

     

     

  • SW2 - show run 


    version 12.2

    no service pad

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname Rack1SW2

    !

    boot-start-marker

    boot-end-marker

    !

    !

    no aaa new-model

    system mtu routing 1500

    ip subnet-zero

    ip routing

    no ip domain-lookup

    !

    spanning-tree mode pvst

    spanning-tree extend system-id

    !

    vlan internal allocation policy
    ascending

    !

     

    interface Loopback0

    ip address 150.1.8.8 255.255.255.0

    !

    interface Port-channel1

    no switchport

    ip address 155.1.108.8 255.255.255.0

    !

    interface FastEthernet0/1

    !

    interface FastEthernet0/2

    switchport access vlan 22

    switchport mode access

    spanning-tree portfast

    !

    interface FastEthernet0/3

    !

    interface FastEthernet0/4

    switchport access vlan 43

    switchport mode access

    spanning-tree portfast

    !

    interface FastEthernet0/5

    !

    interface FastEthernet0/6

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/7

    !

    interface FastEthernet0/8

    !

    interface FastEthernet0/9

    !

    interface FastEthernet0/10

    !

    interface FastEthernet0/11

    !

    interface FastEthernet0/12

    !

    interface FastEthernet0/13

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/14

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/15

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/16

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/17

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/18

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/19

    no switchport

    no ip address

    channel-group 1 mode on

    !

    interface FastEthernet0/20

    no switchport

    no ip address

    channel-group 1 mode on

    !

    interface FastEthernet0/21

    switchport trunk encapsulation dot1q

    switchport mode trunk

    !

    interface FastEthernet0/22

    !

    interface FastEthernet0/23

    !

    interface FastEthernet0/24

    switchport access vlan 22

    switchport mode access

    spanning-tree portfast

    !

    interface GigabitEthernet0/1

    !

    interface GigabitEthernet0/2

    !

    interface Vlan1

    no ip address

    shutdown

    !

    interface Vlan8

    ip address 155.1.8.8 255.255.255.0

    !

    interface Vlan58

    ip address 155.1.58.8 255.255.255.0

    !

    router rip

    version 2

    network 150.1.0.0

    network 155.1.0.0

    no auto-summary

    !

    ip classless

    ip http server

    ip http secure-server

    !

    !

    !

    control-plane

    !

    !

    line con 0

    exec-timeout 0 0

    privilege level 15

    logging synchronous

    line vty 0 4

    password cisco

    login

    line vty 5 15

    password cisco

    login

    !

    end

  • sherlock123 - Make sure you have:

    SW2:
     "vlan 5,7-10,22,43,58,67,79,146"
    
    
    SW1:
    interface FastEthernet0/5
    no shutdown
    switchport access vlan 58
    switchport mode access
    !
    Also:
    Check "show spaning-tree vlan 58" on both sw1+sw2. Check if trunk are ok.
  • GOT IT !!! you won't believe what it was and i Thank YOU for narrowing the problem down for me. Cable from R5 from F0/0 was plugged into SW2 fa 0/5 instead of SW1 fa 0/5. So when i checked R5 the fa 0/0 showed up and up, so it was plugged in but the problem was it was plugged into the wrong switch. As soon as i shut the R5 fa o/o down, i saw WOW why is SW2 fa 0/5 went down. As soon as i plugged it in to SW1 VOILA !!!! TUnnel 0 UP !!  I spent almost all day yesterday figuring out what was the problem and it all came down to a wire plugged into a wrong switch.

     

    Thank you Andrius2 for all your help, i really appreciate it. I learned a very good lesson, thank you again for taking your time out.

  • Sorry I just had one question :

    Remove all previous static and policy routing configurations.
    ?  Enable RIPv2 on all links in the 150.X.0.0 and 155.X.0.0 address space
    on all internal devices and disable auto-summary.
    Create a GRE tunnel between SW3 and SW4 using the IP addresses
    10.34.0.Y/24.

    Why is it 10.34.0.9 and 10.34.0.10 ?

  • Hi,

        You are not given all the info (in lab you will be given), yes, but on INE racks the last octet represents the device number(R1=1, R2=2.......SW1=7,SW2=8,SW3=9,SW4=10).

    Good luck with your studies!

  • Oh thanks for clarifying it ! i was under impression that it should be 3 and 4 but forgot about Router's numbers :)

     

    Can you help me to see why I'm having diffuculties getting this lab to work ?

    I'm running dynamips, using default configuration files and standard INE solution and here's what i see :

     

    SW4 Lo0 cant ping SW3 Lo0, SW4 Lo0 can ping SW2 Lo0 over etherchannel and able to learn R2 routes...

    Now for SW3 and SW4 is completely different story... neither SW3/SW4 see each other routes... I'm not sure if i should manually fix that or...

     

     

  • Hi,

      I don't really understand what you're trying to accomplish; in this task you need to create  a loopback1 on SW3 and SW4, create a GRE tunnel between SW3 and SW4 sourced/destined to/from loopback0 and create two static routes so that traffic between lopback1 is routed over the GRE tunnel. No other routes should be learned over the GRE tunnel. So what is the problem?

    Good luck with your studies!

  • Thanks, I was able to get fresh start, reload everything next day and get this task completed.

     

  • I thought that the Loopbacks should have been 3 and 4 too.. Thanks for inquiring about this Unsobill...

  • Good one Andrius,

    I was also facing SW2 not learning rip routes and as soon as I checked and changed access vlan to 58 on SW1 the rip routes appeared.

    Now I only have SW4 missing rip route because of dynamips not able to do L3 etherchanenel.

    Do you guys know any solution to get R4 learning rip routes on dynamips?

    Thanks

    AC

  • Hi Andre,

    Instead of using L3 PortChannel between SW2 and SW4, I did the following:

    - create VLAN 108 on the VLAN DB on all 4 switches

    - assign one port connecting SW2 to SW4 to VLAN108

    - create one SVI 108 on SW2 and SW4 to assign IP Addresses.

    HTH

    Good luck!

  • Hi again,

     

    I created SVI 146 on SW4 and started to learn rip routes and tunn0 also came up.

     

    Cheers

    AC

  • Hi qqabdal,

    I've created SVI 146 on SW4 and start to learn rip routes and tun0 came also up.

     

    Vlan10                     155.1.10.10     YES manual up                    up     
    Vlan146                    155.1.146.10    YES manual up                    up     
    Loopback0                  150.1.10.10     YES manual up                    up     
    Loopback1                  172.16.0.10     YES manual up                    up     
    Tunnel0                    10.34.0.10      YES manual up                    up     
    Rack1SW4#

     

    Why your idea of VLAN 108 to simulate L3 etherchannel between SW2 and SW4?

     

    Cheers

    AC

  • Hi qqabdal,

    Also tried your way and  worked:

     

    Rack1R5#
    *Mar  1 00:52:52.031: IP: tableid=0, s=150.1.10.10 (FastEthernet0/0), d=150.1.9.9 (Serial0/1), routed via FIB
    *Mar  1 00:52:52.035: IP: s=150.1.10.10 (FastEthernet0/0), d=150.1.9.9 (Serial0/1), g=155.1.45.4, len 124, forward, proto=47

     

    Vlan108                    155.1.108.10    YES manual up                    up          
    Rack1SW2#

     

    Vlan108                    155.1.108.8     YES manual up                    up

    Rack1SW4#

     

    thanks

    AC

  • Actaully now is tacking the right path via the FR cloud and not via R5 b2b R4 as per my previous reply( FR interface on R3 was admin down).

     

    *Mar  1 01:12:28.583: IP: tableid=0, s=150.1.10.10 (FastEthernet0/0), d=150.1.9.9 (Serial0/0), routed via FIB
    *Mar  1 01:12:28.587: IP: s=150.1.10.10 (FastEthernet0/0), d=150.1.9.9 (Serial0/0), g=155.1.0.3, len 124, forward, proto=47
    *Mar  1 01:12:28.647: IP: tableid=0, s=150.1.9.9 (Serial0/0), d=150.1.10.10 (FastEthernet0/0), routed via FIB
    *Mar  1 01:12:28.651: IP: s=150.1.9.9 (Serial0/0), d=150.1.10.10 (FastEthernet0/0), g=155.1.58.8, len 124, forward, proto=47

     

     

    Thanks for your help

    AC

Sign In or Register to comment.