Wierd PfR observations with active probes

 

below are my active probes configured on the master

active-probe tcp-conn 150.1.6.6 target-port 1026       <<<<<R6

 active-probe tcp-conn 150.1.1.1 target-port 1111      <<<<<<<R1

 active-probe tcp-conn 150.1.4.4 target-port 1024   <<<<<R4

-----------------------------------------------


R5 = Master


Rack1R5#show ip sla statistics

IPSLAs Latest Operation Statistics


IPSLA operation id: 51              <<<<<<<<<<<<<<goes to 150.1.1.1   <sh IP sla configuration>

Type of operation: tcp-connect

        Latest RTT: 12 milliseconds

Latest operation start time: *17:32:51.118 UTC Tue Nov 29 2011

Latest operation return code: OK

Number of successes: 2

Number of failures: 0

Operation time to live: Forever




IPSLA operation id: 52

Type of operation: tcp-connect

        Latest RTT: 0 milliseconds

Latest operation start time: *17:32:55.674 UTC Tue Nov 29 2011

Latest operation return code: Socket connect error       <<<<<150.1.4.4

Number of successes: 0

Number of failures: 2

Operation time to live: Forever




IPSLA operation id: 53

Type of operation: tcp-connect

        Latest RTT: 0 milliseconds

Latest operation start time: *17:32:55.678 UTC Tue Nov 29 2011

Latest operation return code: Socket connect error       <<<<<150.1.6.6

Number of successes: 0

Number of failures: 2

Operation time to live: Forever

-------------------------------------------------------------------------------------------

responder config on each target device 




Rack1R1#sh run | i responder

ip sla monitor responder type tcpConnect ipaddress 150.1.8.8 port 1111




Rack1R6#sh run | i responder

ip sla responder tcp-connect ipaddress 150.1.8.8 port 1026






Rack1R4#sh run | i responder

ip sla responder tcp-connect ipaddress 150.1.8.8 port 1024



--------------------------------------------------------------------------------------------------

check tcp brief 



Rack1R5#sh tcp brief

TCB       Local Address               Foreign Address             (state)




6538FCC4  150.1.5.5.50450             150.1.5.5.3949              ESTAB

65D0C2B0  155.1.0.5.48566             155.1.23.3.179              ESTAB

68FE0374  150.1.5.5.30081             150.1.1.1.1111              TIMEWAIT       <<<<R1 is here but R4 and R6 are NOT

669F46EC  150.1.5.5.3949              150.1.2.2.24382             ESTAB

66BD1CD4  155.1.58.5.179              155.1.108.10.51903          ESTAB

68FA9C90  150.1.5.5.3949              150.1.3.3.53179             ESTAB

65B7AC18  155.1.58.5.57403            155.1.58.8.179              ESTAB

66C02840  155.1.45.5.179              155.1.45.4.39152            ESTAB

66DD1994  155.1.0.5.179               155.1.0.2.18105             ESTAB

65390300  150.1.5.5.3949              150.1.5.5.50450             ESTAB



----------------------------------------------------------

confirmed by active-probes checked on master


Rack1R5#sh oer mas active-probes

        OER Master Controller active-probes

Border   = Border Router running this Probe

State    = Un/Assigned to a Prefix

Prefix   = Probe is assigned to this Prefix

Type     = Probe Type

Target   = Target Address

TPort    = Target Port

How      = Was the probe Learned or Configured

N - Not applicable


The following Probes exist:


State      Prefix             Type     Target          TPort   How     Codec

Assigned   150.1.6.0/24       tcp-conn 150.1.6.6        1026  Cfgd         N

Assigned   150.1.1.0/24       tcp-conn 150.1.1.1        1111  Cfgd         N

Assigned   150.1.6.0/24       echo     150.1.6.6           N  Lrnd         N

Assigned   150.1.1.0/24       echo     150.1.1.1           N  Lrnd         N

Unassigned                    tcp-conn 150.1.4.4           1024  Cfgd         N


The following Probes are running:


Border          State    Prefix             Type     Target          TPort

150.1.3.3       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111

150.1.3.3       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111

150.1.5.5       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111






*** all other configs are fine...trust me on that one...




------------------------------------------------------------------------------




thing is at one point i SAW active-probes running from .6 and .4..however the TCP brief showed nothing and ip sla stats showed a socket connect error....





i guess what keeps bothering me that, USING THE SAME SET OF COMMANDS i configure active probes for R1 R4 and R6...however R1s TCP-connect shows up under the show tcp brief command and the show ip sla statiastics command but not the other 2....WHY?




<EDIT..JUST CAUGHT IT>>>



look below....there is an active probe running for target 150.1.4.4 BUT IT DOES NOT SHOW IN THE TCP BRIEF?????*****







proof that al else is configured fine.....


Rack1R5#sh oer master prefix

OER Prefix Statistics:

 Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),

 P - Percentage below threshold, Jit - Jitter (ms),

 MOS - Mean Opinion Score

 Los - Packet Loss (packets-per-million), Un - Unreachable (flows-per-million),

 E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable

 U - unknown, * - uncontrolled, + - control more specific, @ - active probe all

 # - Prefix monitor mode is Special, & - Blackholed Prefix

 % - Force Next-Hop, ^ - Prefix is denied


Prefix                  State     Time Curr BR         CurrI/F         Protocol

                      PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos

                      ActSDly  ActLDly   ActSUn   ActLUn      EBw      IBw

                      ActSJit  ActPMOS  ActSLos  ActLLos

--------------------------------------------------------------------------------

112.0.0.0/8             DEFAULT*       29 U               U               U     

150.1.1.0/24            DEFAULT*       @2 150.1.5.5       Se0/1/0         U     

                               U        U        0        0        0        0

                              42       27        0        0       10        4

                               N        N

150.1.4.0/24            DEFAULT*      @76 U               U               U     

150.1.6.0/24            DEFAULT*     1800 150.1.5.5       Se0/1/0         U     

                               U        U        0        0        0        0

                               U        U  1000000  1000000        1        1

                               N        N

Rack1R5#













Rack1R5#show oer master active-probes

        OER Master Controller active-probes

Border   = Border Router running this Probe

State    = Un/Assigned to a Prefix

Prefix   = Probe is assigned to this Prefix

Type     = Probe Type

Target   = Target Address

TPort    = Target Port

How      = Was the probe Learned or Configured

N - Not applicable


The following Probes exist:


State      Prefix             Type     Target          TPort   How     Codec

Assigned   150.1.4.0/24       tcp-conn 150.1.4.4        1024  Cfgd         N

Assigned   150.1.4.0/24       echo     150.1.4.4           N  Lrnd         N

Assigned   150.1.6.0/24       tcp-conn 150.1.6.6        1026  Cfgd         N

Assigned   150.1.1.0/24       tcp-conn 150.1.1.1        1111  Cfgd         N

Assigned   150.1.6.0/24       echo     150.1.6.6           N  Lrnd         N

Assigned   150.1.1.0/24       echo     150.1.1.1           N  Lrnd         N


The following Probes are running:


Border          State    Prefix             Type     Target          TPort

150.1.3.3       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111

150.1.3.3       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111

150.1.5.5       ACTIVE   150.1.1.0/24       tcp-conn 150.1.1.1        1111

150.1.5.5       ACTIVE   150.1.4.0/24       tcp-conn 150.1.4.4        1024

150.1.3.3       ACTIVE   150.1.4.0/24       tcp-conn 150.1.4.4        1024

150.1.3.3       ACTIVE   150.1.4.0/24       tcp-conn 150.1.4.4        1024


--------


Rack1R5#show tcp brief    <<<<<<you dont see port 1024 anywhere....WHY???

TCB       Local Address               Foreign Address             (state)

6538FCC4  150.1.5.5.50450             150.1.5.5.3949              ESTAB

65D0C2B0  155.1.0.5.48566             155.1.23.3.179              ESTAB

68FE0374  150.1.5.5.31343             150.1.1.1.1111              TIMEWAIT

669F46EC  150.1.5.5.3949              150.1.2.2.24382             ESTAB

66BD1CD4  155.1.58.5.179              155.1.108.10.51903          ESTAB

68FA9C90  150.1.5.5.3949              150.1.3.3.53179             ESTAB

65B7AC18  155.1.58.5.57403            155.1.58.8.179              ESTAB

66C02840  155.1.45.5.179              155.1.45.4.39152            ESTAB

66DD1994  155.1.0.5.179               155.1.0.2.18105             ESTAB

65390300  150.1.5.5.3949              150.1.5.5.50450             ESTAB








 

Sign In or Register to comment.