RIP: build update entries - suppressing null update

Scenario:

R1------RIP---------R2

----210.1.21.0/24----

R2#sh run | s r r
router rip
 version 2
 network 210.1.0.0
 network 219.172.1.0
 network 219.172.2.0
 network 219.172.3.0
 network 219.172.4.0
 network 219.172.5.0
 no auto-summary

R2#sh run int loop 219
interface Loopback219
 description RIP Networks
 ip address 219.172.5.254 255.255.255.0 secondary
 ip address 219.172.4.254 255.255.255.0 secondary
 ip address 219.172.3.254 255.255.255.0 secondary
 ip address 219.172.2.254 255.255.255.0 secondary
 ip address 219.172.1.254 255.255.255.0

Info: R1, R2 are directly connected, able to ping. Both running RIPv2. No authentication configured.

Issue: R2 not advertising any network to R1. Debug ip RIP reveals:

RIP: build update entries - suppressing null update

Please suggest the remedy

Thanks,

 

Comments

  • Hi,

       In order to make distance vector protocols advertise secondary subnets, you need to disable split horizon on the interface (no ip split-horizon for RIP and no ip split-horizon eigrp AS for EIGRP). This is because of how disatnce vector functions, where vector means direction. You need to disable split horizon in order to make it advertise a prefix back on the same interface it was received on, as that prefix is directly connected to it.

    Good luck with your studies!

  • Thanks Cris for the prompt reply. I got the issue resolved. But it was not the Split Horizon issue (SH causes issue in FR).  I found that RIP expects a more specific subnet advertisement (classfull) between
    two RIP peering routers irrespective of whether ver 2 and no auto-summary is configured.

    In my case I advertised 210.1.0.0 (supernet) instead of 210.1.21.0 in both the routers and that caused the problem.

    Would feel great if you could add more expert knowledge on this.

    Many Thanks,

  • Hi,

        You need to disable split horizon for this scenario to work; in your case, because you are using  frame-relay on the main interface, it is disabled by default (issue show ip interface serialx/y to see it); if you remake this scenarion on an etherenet interface you'll see you need to disable split horizon to make a distance vector advertise secondary subnets. More specific is not classfull but classless (of course is not related to version 2 and auto-rummary, do not confuse features).

    Good luck with your studies!

  • Well its early in the morning and I actually do not get why split horizon needs to be disabled here? It hast to be disabled on the interface pointing to R1 right? I admit that I never ever used that command before and did never run into problems. -.-

  • Hi,

      I think i was clear enough in my first post. For a distance vector (RIP,IGRP,EIGRP) to announce a secondary subnet, you need to disable split-horizon at the interface level (where you have multiple subnets configured). This is how it works, i also justified it.

    Good luck with your studies!












  • Split-horizon does not need to be disabled in this case since
    the secondary address are on the Loopback interface, if you move the secondary
    addresses to the interface pointing to R1, then yes, you need to disabled
    split-horizon. However, as Cris pointed out, because you are using FR on the
    main physical interface, it’s not required, as it is disabled by default.

     

    As to why this didn’t work in the first place, that’s due to the
    fact that 210.1.21.0/24 is a Class C address, so you really need to enter
    network 210.1.21.0, going all the way up to the third octet, otherwise, it will
    not encompass that subnet. This is a limitation with RIP as it does not allow
    the use of wildcard masks as we can do with EIGRP and OSPF.

     

    Hope this helps

     

    From: [email protected]
    [mailto:[email protected]] On Behalf Of zool85

    Sent: Thursday, November 24, 2011 7:36 AM

    To: [email protected]

    Subject: Re: [CCIE R&S] RIP: build update entries - suppressing null
    update

     

    Well its early in the morning and I actually do not get why split horizon
    needs to be disabled here? It hast to be disabled on the interface pointing to
    R1 right? I admit that I never ever used that command before and did never run
    into problems. -.-







    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx





  • Split-horizon does not need to be disabled in this case since the secondary address are on the Loopback interface, if you move the secondary addresses to the interface pointing to R1, then yes, you need to disabled split-horizon. However, as Cris pointed out, because you are using FR on the main physical interface, it’s not required, as it is disabled by default.

     

    As to why this didn’t work in the first place, that’s due to the fact that 210.1.21.0/24 is a Class C address, so you really need to enter network 210.1.21.0, going all the way up to the third octet, otherwise, it will not encompass that subnet. This is a limitation with RIP as it does not allow the use of wildcard masks as we can do with EIGRP and OSPF.

     

    Hope this helps

  • Ok just overread the "secondary" ... well this should work with redistribute connected I think.

  • I agree with qqabdal here. I believe Christian missed the "interface loopback 219". The config is smashed together. 

    If you don't turn RIP on the correct interface, RIP isn't going to advertise anything. "show ip protocols" would have revealed this error.  

    network 210.1.21.0 not 210.1.0.0 - that's a different class C subnet. Therefore, RIP will not be enabled on the interface connecting these two devices. 

  • Hi,

    Yes i've missed the loopback part :) However things remain the same in general for DV protocols: in order to advertise secondary subnets you need to disable split-horizon on that interface.

    Good luck with your studies!

Sign In or Register to comment.