SCCP command missing suddently (sccp ccm group, dspfarm profile etc.)


Hello,
   I was configuring the following command:
 
voice-card 0
no dspfarm
dsp services dspfarm

sccp local f0/1
sccp ccm 177.1.10.20 identifier 1 version 7
sccp ccm 177.1.10.10 identifier 2 version 7
sccp ip precedence 3
sccp

sccp ccm group 1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 1 register R2_XCODER

dspfarm profile 1 trans


And then I suddenly realise I should not use voice-card 0. My 2811 uses NM-HDV with PVDM-12 and E1. So I use command:

voice-card 1
dsp service dspfarm

Then I found that I cannot have these command any more:

sccp ccm 177.1.10.20 identifier 1 version 7
sccp ccm 177.1.10.10 identifier 2 version 7

sccp ccm group 1

dspfarm profile 1 trans

Now what I see is like:

R2(config)#sccp ccm ?
  Hostname or A.B.C.D  Specify the IP address of the Call Manager

R2(config)#sccp ccm 177.1.10.20 ?
  priority  Specify the Call Managers priority



It was not like this before. There was more optioins than that. I delete some of my call-manager-fallback settings. I also shutdown E1 controller. I reloaded the router several times. I use "no" to all the above dsp-related command to delete them.  But things didnot change.

I tried to find the answers online for several hours without results.
I think this is not hardware or IOS version issue because I successfully use the command before. It might be the DSP resource allocate to some device and it was still being used?  I found people had similar experience but problem wasn't solved.

I will attach the config file and please let me know if you need more output from the router. Thanks!

 

-------------


R2#s run
Building configuration...

Current configuration : 3118 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$6gx3$oTD3gsDmsxuXb2V/bl2t61
!
no aaa new-model
clock timezone CST -6
no network-clock-participate slot 1
network-clock-participate wic 2
!
voice-card 0
!
voice-card 1
 dspfarm
 dsp services dspfarm
!
dot11 syslog
ip source-route
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 177.2.11.1 177.2.11.99
ip dhcp excluded-address 177.2.11.200 177.2.11.255
!
ip dhcp pool Test
   network 177.2.11.0 255.255.255.0
   option 150 ip 177.1.10.10
   default-router 177.2.11.1
!
!
ip host PSTN 177.1.254.254
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice service voip
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  registrar server
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^1718301(....)/ /1/
!
!
voice translation-profile Incoming
 translate called 1
!
!
!
application
 global
  service alternate default
 !
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
controller T1 0/2/0
 shutdown
!
controller E1 1/0/0
 shutdown
!
!
!
!
!
interface Loopback0
 ip address 177.1.254.2 255.255.255.255
!
interface FastEthernet0/0
 description == Internet
 ip address 192.168.1.233 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 177.2.11.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
!
interface Serial0/3/0
 description FR = PSTN_FR S0/1
 ip address 177.0.101.2 255.255.255.0
 encapsulation frame-relay
 frame-relay interface-dlci 102
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
ccm-manager switchback immediate
ccm-manager fallback-mgcp
ccm-manager redundant-host 177.1.10.10
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
!
mgcp
mgcp call-agent 177.1.10.20 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp fax t38 ecm
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
sccp local FastEthernet0/1
sccp
!
!
!
dial-peer voice 1 pots
 translation-profile incoming Incoming
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 911 pots
 destination-pattern 911
 direct-inward-dial
 forward-digits 3
!
dial-peer voice 900 pots
 destination-pattern 9[2-9]......$
!
dial-peer voice 901 pots
 destination-pattern 91[2-9]..[2-9]......$
 prefix 1
!
dial-peer voice 902 pots
 destination-pattern 9011T
 prefix 011
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 08224F470C
 login
line vty 5 15
 exec-timeout 0 0
 password 7 094F4D001C
 login
!
scheduler allocate 20000 1000
ntp source Loopback0
ntp server 177.0.101.1
end

Comments

  • Is this a new setup or was this working in the past?

    Your call-manager-fallback settings would not interfere with this.  

    If you refer to Cisco Command Reference guide for IOS Voice Commands, you'll see the following blurb under "sccp ccm":

    NM-HDV or NM-HDV-FARM Voice Network Modules


    sccp ccm {ip-address | dnspriority priority [port port-number] [version 3.0 | 3.1+]

    no sccp ccm {ip-address | dns}

    It looks like the NM-HDV does not support the "identifier" parameter under "sccp ccm".

    http://www.cisco.com/en/US/docs/ios/12_3t/voice/command/reference/vrht_s01.html#wp1249777

  • William,


    On Sun, Nov 20, 2011 at 11:49 PM, WilliamZ <[email protected]> wrote:


    Hello,
       I was configuring the following command:
     
    voice-card 0
    no dspfarm
    dsp services dspfarm

    sccp local f0/1
    sccp ccm 177.1.10.20 identifier 1 version 7
    sccp ccm 177.1.10.10 identifier 2 version 7

    sccp ip precedence 3
    sccp

    sccp ccm group 1
    associate ccm 1 priority 1
    associate ccm 2 priority 2
    associate profile 1 register R2_XCODER

    dspfarm profile 1 trans


    And then I suddenly realise I should not use voice-card 0. My 2811 uses NM-HDV with PVDM-12 and E1. So I use command:


    voice-card 1
    dsp service dspfarm

    Then I found that I cannot have these command any more:

    sccp ccm 177.1.10.20 identifier 1 version 7
    sccp ccm 177.1.10.10 identifier 2 version 7

    sccp ccm group 1


    dspfarm profile 1 trans

    Now what I see is like:

    R2(config)#sccp ccm ?
      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm 177.1.10.20 ?
      priority  Specify the Call Managers priority




    It was not like this before. There was more optioins than that. I delete some of my call-manager-fallback settings. I also shutdown E1 controller. I reloaded the router several times. I use "no" to all the above dsp-related command to delete them.  But things didnot change.


    I tried to find the answers online for several hours without results.
    I think this is not hardware or IOS version issue because I successfully use the command before. It might be the DSP resource allocate to some device and it was still being used?


    I will attach the config file and please let me know if you need more output from the router. Thanks!

     

    -------------

    R2#s run
    Building configuration...

    Current configuration : 3118 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption

    !
    hostname R2
    !
    boot-start-marker
    boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin
    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$6gx3$oTD3gsDmsxuXb2V/bl2t61
    !

    no aaa new-model
    clock timezone CST -6
    no network-clock-participate slot 1
    network-clock-participate wic 2
    !
    voice-card 0
    !
    voice-card 1
     dspfarm
     dsp services dspfarm
    !
    dot11 syslog


    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#sccp ?
      ccm         Specify the Call Manager related parameters value
      codec       The codec related commands
      ip          Specify the IP related parameters values

      local       Specify the local gateway related parameters values
      mtp         Specify the MTP related parameters values
      switchback  Specify the Switchback related parameters values
      <cr>

    R2(config)#sccp ccm ?

      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm ?
      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm 177.1.10.20 ?
      priority  Specify the Call Managers priority


    R2(config)#sccp ccm 177.1.10.20 z^Z                                ^
    % Invalid input detected at '^' marker.

    R2#s run
    Building configuration...

    Current configuration : 3118 bytes
    !
    version 12.4

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin

    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$6gx3$oTD3gsDmsxuXb2V/bl2t61
    !
    no aaa new-model
    clock timezone CST -6
    no network-clock-participate slot 1
    network-clock-participate wic 2

    !
    voice-card 0
    !
    voice-card 1
     dspfarm
     dsp services dspfarm
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 177.2.11.1 177.2.11.99

    ip dhcp excluded-address 177.2.11.200 177.2.11.255
    !
    ip dhcp pool Test
       network 177.2.11.0 255.255.255.0
       option 150 ip 177.1.10.10
       default-router 177.2.11.1
    !
    !
    ip host PSTN 177.1.254.254

    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    isdn switch-type primary-net5
    !
    !
    !
    voice service voip
     sip
      bind control source-interface Loopback0
      bind media source-interface Loopback0

      registrar server
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 1
     rule 1 /^1718301(....)/ /1/
    !
    !
    voice translation-profile Incoming
     translate called 1
    !
    !
    !
    application

     global
      service alternate default
     !
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    controller T1 0/2/0
     shutdown
    !
    controller E1 1/0/0
     shutdown
    !
    !

    !
    !
    !
    interface Loopback0
     ip address 177.1.254.2 255.255.255.255
    !
    interface FastEthernet0/0
     description == Internet
     ip address 192.168.1.233 255.255.255.0
     duplex auto
     speed auto
    !

    interface FastEthernet0/1
     ip address 177.2.11.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface Serial0/0/0
     no ip address
     clock rate 2000000
    !
    interface Serial0/3/0
     description FR = PSTN_FR S0/1

     ip address 177.0.101.2 255.255.255.0
     encapsulation frame-relay
     frame-relay interface-dlci 102
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd

    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    ccm-manager switchback immediate
    ccm-manager fallback-mgcp
    ccm-manager redundant-host 177.1.10.10

    ccm-manager mgcp
    no ccm-manager fax protocol cisco
    ccm-manager music-on-hold
    !
    mgcp
    mgcp call-agent 177.1.10.20 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp fax t38 ecm

    mgcp bind control source-interface Loopback0
    mgcp bind media source-interface Loopback0
    !
    mgcp profile default
    !
    sccp local FastEthernet0/1
    sccp
    !
    !
    !
    dial-peer voice 1 pots
     translation-profile incoming Incoming

     incoming called-number .
     direct-inward-dial
    !
    dial-peer voice 911 pots
     destination-pattern 911
     direct-inward-dial
     forward-digits 3
    !
    dial-peer voice 900 pots
     destination-pattern 9[2-9]......$

    !
    dial-peer voice 901 pots
     destination-pattern 91[2-9]..[2-9]......$
     prefix 1
    !
    dial-peer voice 902 pots
     destination-pattern 9011T
     prefix 011
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0

    line aux 0
    line vty 0 4
     exec-timeout 0 0
     password 7 08224F470C
     login
    line vty 5 15
     exec-timeout 0 0
     password 7 094F4D001C
     login
    !
    scheduler allocate 20000 1000
    ntp source Loopback0

    ntp server 177.0.101.1
    end




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • William,
        can you share a show tech / hardware from the device?  and just for grins, did you try doing a wr erase and reload the config with the voice-card 1? I've seen some funny things when you allocate DSP resources and change the config.


    On Sun, Nov 20, 2011 at 11:49 PM, WilliamZ <[email protected]> wrote:


    Hello,
       I was configuring the following command:
     
    voice-card 0
    no dspfarm
    dsp services dspfarm

    sccp local f0/1
    sccp ccm 177.1.10.20 identifier 1 version 7
    sccp ccm 177.1.10.10 identifier 2 version 7

    sccp ip precedence 3
    sccp

    sccp ccm group 1
    associate ccm 1 priority 1
    associate ccm 2 priority 2
    associate profile 1 register R2_XCODER

    dspfarm profile 1 trans


    And then I suddenly realise I should not use voice-card 0. My 2811 uses NM-HDV with PVDM-12 and E1. So I use command:


    voice-card 1
    dsp service dspfarm

    Then I found that I cannot have these command any more:

    sccp ccm 177.1.10.20 identifier 1 version 7
    sccp ccm 177.1.10.10 identifier 2 version 7

    sccp ccm group 1


    dspfarm profile 1 trans

    Now what I see is like:

    R2(config)#sccp ccm ?
      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm 177.1.10.20 ?
      priority  Specify the Call Managers priority




    It was not like this before. There was more optioins than that. I delete some of my call-manager-fallback settings. I also shutdown E1 controller. I reloaded the router several times. I use "no" to all the above dsp-related command to delete them.  But things didnot change.


    I tried to find the answers online for several hours without results.
    I think this is not hardware or IOS version issue because I successfully use the command before. It might be the DSP resource allocate to some device and it was still being used?


    I will attach the config file and please let me know if you need more output from the router. Thanks!

     

    -------------

    R2#s run
    Building configuration...

    Current configuration : 3118 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption

    !
    hostname R2
    !
    boot-start-marker
    boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin
    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$6gx3$oTD3gsDmsxuXb2V/bl2t61
    !

    no aaa new-model
    clock timezone CST -6
    no network-clock-participate slot 1
    network-clock-participate wic 2
    !
    voice-card 0
    !
    voice-card 1
     dspfarm
     dsp services dspfarm
    !
    dot11 syslog


    R2#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    R2(config)#sccp ?
      ccm         Specify the Call Manager related parameters value
      codec       The codec related commands
      ip          Specify the IP related parameters values

      local       Specify the local gateway related parameters values
      mtp         Specify the MTP related parameters values
      switchback  Specify the Switchback related parameters values
      <cr>

    R2(config)#sccp ccm ?

      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm ?
      Hostname or A.B.C.D  Specify the IP address of the Call Manager

    R2(config)#sccp ccm 177.1.10.20 ?
      priority  Specify the Call Managers priority


    R2(config)#sccp ccm 177.1.10.20 z^Z                                ^
    % Invalid input detected at '^' marker.

    R2#s run
    Building configuration...

    Current configuration : 3118 bytes
    !
    version 12.4

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot system flash c2800nm-adventerprisek9-mz.124-22.YB8.bin

    boot-end-marker
    !
    logging message-counter syslog
    enable secret 5 $1$6gx3$oTD3gsDmsxuXb2V/bl2t61
    !
    no aaa new-model
    clock timezone CST -6
    no network-clock-participate slot 1
    network-clock-participate wic 2

    !
    voice-card 0
    !
    voice-card 1
     dspfarm
     dsp services dspfarm
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 177.2.11.1 177.2.11.99

    ip dhcp excluded-address 177.2.11.200 177.2.11.255
    !
    ip dhcp pool Test
       network 177.2.11.0 255.255.255.0
       option 150 ip 177.1.10.10
       default-router 177.2.11.1
    !
    !
    ip host PSTN 177.1.254.254

    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    isdn switch-type primary-net5
    !
    !
    !
    voice service voip
     sip
      bind control source-interface Loopback0
      bind media source-interface Loopback0

      registrar server
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 1
     rule 1 /^1718301(....)/ /1/
    !
    !
    voice translation-profile Incoming
     translate called 1
    !
    !
    !
    application

     global
      service alternate default
     !
    !
    !
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    controller T1 0/2/0
     shutdown
    !
    controller E1 1/0/0
     shutdown
    !
    !

    !
    !
    !
    interface Loopback0
     ip address 177.1.254.2 255.255.255.255
    !
    interface FastEthernet0/0
     description == Internet
     ip address 192.168.1.233 255.255.255.0
     duplex auto
     speed auto
    !

    interface FastEthernet0/1
     ip address 177.2.11.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface Serial0/0/0
     no ip address
     clock rate 2000000
    !
    interface Serial0/3/0
     description FR = PSTN_FR S0/1

     ip address 177.0.101.2 255.255.255.0
     encapsulation frame-relay
     frame-relay interface-dlci 102
    !
    router ospf 1
     log-adjacency-changes
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd

    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    ccm-manager switchback immediate
    ccm-manager fallback-mgcp
    ccm-manager redundant-host 177.1.10.10

    ccm-manager mgcp
    no ccm-manager fax protocol cisco
    ccm-manager music-on-hold
    !
    mgcp
    mgcp call-agent 177.1.10.20 service-type mgcp version 0.1
    mgcp dtmf-relay voip codec all mode out-of-band
    mgcp fax t38 ecm

    mgcp bind control source-interface Loopback0
    mgcp bind media source-interface Loopback0
    !
    mgcp profile default
    !
    sccp local FastEthernet0/1
    sccp
    !
    !
    !
    dial-peer voice 1 pots
     translation-profile incoming Incoming

     incoming called-number .
     direct-inward-dial
    !
    dial-peer voice 911 pots
     destination-pattern 911
     direct-inward-dial
     forward-digits 3
    !
    dial-peer voice 900 pots
     destination-pattern 9[2-9]......$

    !
    dial-peer voice 901 pots
     destination-pattern 91[2-9]..[2-9]......$
     prefix 1
    !
    dial-peer voice 902 pots
     destination-pattern 9011T
     prefix 011
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0

    line aux 0
    line vty 0 4
     exec-timeout 0 0
     password 7 08224F470C
     login
    line vty 5 15
     exec-timeout 0 0
     password 7 094F4D001C
     login
    !
    scheduler allocate 20000 1000
    ntp source Loopback0

    ntp server 177.0.101.1
    end




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Thank you for your replies.

    Hello,Matthew. Thanks for your infomation. That's very helpful
    This is the first time I config SCCP in the router. It's never working before.
    I think the document explains very clearly. That's what should happen in my case.

    I did have configure these command successfully before:

    NM-HDV2 or NM-HD-1V/2V/2VE Voice Network Modules

    sccp ccm {ip-address | dns} identifier identifier-number [priority priority] [port port-number]
    [version version-number]

    And I didn't change any hardware then the command is not available. My guess is that I was using voice-card 0 which is built in the 2811 and is something like NM-HDV2. That's why I can use those advanced command before.

    I also have to clarify that I don't have any PVDM2 in the router. And there is a VWIC-1MFT-T1 in the slot 0 which it's not supposed to be there since the slot 0 supports only VWIC2. The VWIC-1MFT-T1 is not working and I am using the E1 in NM-HDV all the time.



    But now I cannot use those commands for some reasons.I don't know why. The command I can use now change to those fit for NM-HDV.

    ---

    Thanks, Michael.



    I followed your idea to erase and reload the router. I did think about that before and I think it would work like I did 2 days ago. And it works! I can type those command just like I did last time.

    This is some output from the router:

    R2#s run | sec sccp
    sccp local FastEthernet0/1
    sccp ccm 177.1.10.10 identifier 2 version 7.0
    sccp ccm 177.1.10.20 identifier 1 version 7.0
    sccp ip precedence 3
    sccp
    sccp ccm group 1
     associate ccm 1 priority 1
     associate ccm 2 priority 2
     associate profile 1 register R2_XCODER


    Then I type:

    R2(config)#dspfarm profile 1 transcode

    R2(config-dspfarm-profile)#associate application sccp

    R2(config-dspfarm-profile)#maximum sessions ?
      <0-0>  Number of sessions assigned to this profile



    R2(config-dspfarm-profile)#do s run | sec dsp
     dsp services dspfarm
     dspfarm
    dspfarm profile 1 transcode
     associate application SCCP
     shutdown


    The maximum session is 0. I think this is because I don't have PVDM2 in the voice-card 0. I am not sure if I can share the PVDM in NM-HDV to voice-card 0 though I don't think it's possible. I should buy PVDM2 to save this kind of trouble.
    Here if I configure the voice-card 1 again I would probably end up lacking those sccp command again. I didn't try it.

     

    I will attach the show files. It was run before I erased everything. The sh run is the latest.

    I cannot attach file in the forum. I made a 38k zip file. You can get it from here.

    Thanks again!

    William

Sign In or Register to comment.