Incoming Calling pary settings....

HI....I am trying to prefix + and +1 on my H323 gateway under Incoming calling party prefix settings....but for some reason its just not working....the + is not being prefixed....anybody any idea why this is happening ?

 

 

thanks & Regards....sham

Comments

  • To clarify, are you trying to prefix a + or +1 under the H.323 gateway configuration page from within CUCM?  

    Type-A phones, including the Cisco Unified IP Phone 7905, 7912, 7940, and 7960, do not support the + character.  The phones you listed above are Type B phones and do support the character.

    Is there any chance you have a calling party transformation pattern stripping the +, thereby preventing the display of the + on the phone screen?

  • Thanks for the Reply....I am trying to prefix only + & yes, there is a calling party transformation pattern but the phones calling party transformation CSS do not have the partition of calling party transformation pattern.....I also deleted the calling party transformation pattern just to be be 100% positive, but its still not working....and FYI the + prefix is absolutely working fine with the MGCP gateway

     

    Thanks & regards....

  • Can you walk me through the process and explain at each step what numbers are being passed and how it is being treated?


    • PSTN > Gateway
    • Gateway > CUCM
    • CUCM Gateway Config > Phone Device Pool
    • Phone Device Pool > Phone
  • PSTN > Gateway --- PSTN(6178632683)......Gateway(8632683)...for Subscriber

    PSTN > Gateway --- PSTN(2123942123)......Gateway(2123942123)...for National

    dial-peers on Gateway pointing towards CUCM

    dial-peer voice 7 pots
     destination-pattern 9[2-9]......
     port 0/1/0:23
     forward-digits 7
    dial-peer voice 11 pots
     destination-pattern 91[2-9]..[2-9]......
     port 0/1/0:23

    On CUCM gateway configuration I have Prefixed + under all these incoming calling party settings

    National Number
    International Number
    Unknown Number
    Subscriber Number

    For your Info I also tried prefixing + with Voice translation-rules
    & applied them to the dial peers on the gateway but still didn't
    work

  • The dial peers you posted are PSTN-bound dial-peers, not CUCM dial-peers.  We're dealing with INBOUND calls to CUCM phones, right?

    What are the DID ranges of the numbers in CUCM?

    If the DID range was +19523334444, you'd set the following for the gateway settings in CUCM:


    • National: +1 (if the carrier was sending 10 digits and that's what you send on to CUCM)
    • International: + (if the carrier was sending full E.164)
    • Unknown: <blank>
    • Subscriber: +1952 (because carrier is likely sending 7 digits)
  • Sorry...I apologize...I posted the wrong dial peers by mistake....here are the actual dial peers pointing towards the CUCM

     

    dial-peer voice 1000 voip
     destination-pattern 6178631...
     voice-class codec 1
     voice-class h323 1
     session target ipv4:192.168.1.62
     incoming called-number .
     dtmf-relay h245-alphanumeric
     no vad
    dial-peer voice 1001 voip
     preference 1
     destination-pattern 6178631...
     voice-class codec 1
     voice-class h323 1
     session target ipv4:192.168.1.61
     dtmf-relay h245-alphanumeric
     no vad

    The CUCM DID ranges are 617863XXXX & 212394XXXX

  • Two things:

    1. If you try to prefix anything else than + , let's say 999. does it work?!

    2. What does DN Analyzer say when choosing this H323 GW to call 6178631<dn of phone>?

  • ^ Good point.. Choose the h323 gw in DNA and post the results.

    If you havent already done so, reset the h.323 gateway in CUCM.  It has fixed other problems Ive had with h.323 gateways not working as expected in CUCM.

  • Hey Thanks for all the Help Guys.....I found out the problem.....I had forgotten to bind the source address on the gateway....the "h323-gateway voip bind srcaddr" command fixed the issue :-) ....

     

    Thanks & Regards....Sham

  • Way to go!  How did you figure it out?  Did you come across a blog post or (better yet) a Cisco doc?

    Here's a snapshot of the "h323-gateway voip bind srcaddr" command from the IOS Voice Command Reference Guide:

    http://www.cisco.com/en/US/docs/ios/12_3t/voice/command/reference/vrht_h1_ps5207_TSD_Products_Command_Reference_Chapter.html#wp1053156


    h323-gateway voip bind srcaddr

    To designate a source IP address for the voice gateway, use the h323-gateway voip bind srcaddr command in interface configuration mode. To remove the source IP address, use the no form of the command.

    h323-gateway voip bind srcaddr ip-address

    no h323-gateway voip bind srcaddr

    Usage Guidelines

    You do not have to issue this command on the interface that you defined as the voice gateway interface (although it may be more convenient to do so). Use this command the interface that contains the IP address to which you want to bind.

    Examples

    The following example assigns a source IP address of 10.1.1.1:


    h323-gateway voip bind srcaddr 10.1.1.1

  • Thanks :-) I had enough with checking the config and digging through the documentation on the CUCM side thats why I paid attention to the gateway configuration and referred the documentation....then came to know that the command was missing....

     

    Thanks & Regards....Sham

  • So the call worked but CUCM just didn't add the + . And after you issued the h323 bind command on the interface CUCM suddenly started prefixing with + as it was intended.

    OK but here's the queston. If you hadn't the bind command and the GW initiated the call with another IP address (the one closer to CUCM)  than the CUCM would've ignored the call. Isn't this the default behaviour? Because the source IP is different than the one declared on CUCM GW page.

    It's just strange how the + thing is linked with h323 bind command. :)

  • It is very strange... I'm thinking becuase you didnt have the right source ip address, the incoming call didnt match the gateway configured in CUCM.. However, Im going to guess that you had an h.323 trunk that it may have been matching?

  • No I Don have any H.323 trunk configured in my CUCM environment....I have configured a loopback as a Device name (Gateway address in CUCM)....I wasn't able to prefix any character or letter within CUCM incoming calling party settings before without the Bind srcaddr command....

    Thanks & Regards....Sham

     

     

  • Hi there,

    I am facing the same issue on H323 Gateway. I cant seem to see globalized display.

     

    Any suggestions?

  • The way to go was Table 14 'Configuring + for the International Escape Character' in the CUCM system guide 9.1

    http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/9_1_1/ccmsys/CUCM_BK_C5565591_00_cucm-system-guide-91.pdf

     

    I configured it at Device Pool Level and that worked!

    - See more at: https://supportforums.cisco.com/discussion/12516856/h323-gw-incoming-calling-party-prefix-globalization#sthash.F8OKIbuV.dpuf

Sign In or Register to comment.