L3VPN/CSC Solution not working

Hello guys

I am hoping someone can point me in the right direction as i have really hit a brick wall with this.

Below is the sample topology i was playing with on the gigavelocity routers. i narrowed it down to where the solution stops working so below is the silm down version of the topology.

 

CSC-PE 1 & CSC-PE2 --> in AS1 (XR Routers)

C-PE1 & C-PE2 --> in AS2

 

 

                    7200                12kXR              12K XR           7200

CE1------------C-PE1-----------CSC-PE1--------CSC-PE2--------C-PE2----------CE2

                                         AS1                       AS1                      AS2             

 

As you see from the topology above, i was trying out a CSC solution. The problem i ran into was when i configured BGP between CSC-PE to the C-PE routers.

If i configure the sample configuration below, the initial L3VPN which is the first step between AS1 and AS2 works just fine. C-PE1 will be able to ping C-PE2.

 

CSC-PE1

router bgp 1

  address-family ipv4 unicast

  address-family vpnv4 unicast

 

vrf CSC

  rd 1:1

  address-family ipv4 unicast

    network 172.9.0.11 mask 255.255.255.255

    allocate-label all

 

 neighbor 172.9.11.1

   remote-as 2

   address-family ipv4 unicast

      route-policy PASS in

      route-policy PASS out

      as-override

 

C-PE1

router bgp 2

 no bgp default ipv4-unicast

neighbor 172.9.11.2 remote-as 1

address-family ipv4

neighbor 172.9.11.2 activate

neighbor 172.9.11.2 send-community both

network 172.9.0.1 mask 255.255.255.255

redist ospf 1 match internal

 

The config is pretty much identical across on CSC-PE2 and C-PE2. I realise that some of the config above is not required for a pure L3VPN however the solution works fine uptill this point. I can ping from C-PE1 to C-PE2.

 

Now for the problem. Next step was to enable LSP path between C-PE1 & C-PE2 so we can have a CSC solution and enable CE1 and CE2 to have ip reachability once vpnv4 BGP is configured between C-PE1 & C-PE2. So the following sample config was added/ammended on the CSC-PE and C-PE routers.

 

CSC-PE1

router bgp 1

  address-family ipv4 unicast

  address-family vpnv4 unicast

 

vrf CSC

  rd 1:1

  address-family ipv4 unicast

    network 172.9.0.11 mask 255.255.255.255

    allocate-label all

 

 neighbor 172.9.11.1

   remote-as 2

   no address-family ipv4 unicast ---> Taken out from the config and replaced it with the config in bold

      route-policy PASS in

      route-policy PASS out

      as-override

 

address-family ipv4 labeled-unicast

     route-policy PASS in

      route-policy PASS out

      as-override

 

C-PE1

router bgp 2

 no bgp default ipv4-unicast

neighbor 172.9.11.2 remote-as 1

address-family ipv4

neighbor 172.9.11.2 activate

neighbor 172.9.11.2 send-community both

neighbor 172.9.11.2 send-label

network 172.9.0.1 mask 255.255.255.255

redist ospf 1 match internal

 

At this point, the whole solution breaks. C-PE1 to C-PE2 cannot ping reach each other. What makes it more confusing is the i can now ping from C-PE1 to CSC-PE1's loopback address of 172.9.0.11 however, when i ping from CSC-PE1 (XR router) to C-PE1 using either the source loopback address of 172.9.0.11 or the directly connected interface, i get U.U.U (unreachable) as a result (yes i am generating the pings within the VRF CSC).

 

Steps taken to remedy the issue

1) Clear BGP *

2) Enabled both the address-familes ipv4 unicast and labeled-unicast under the VRF CSC neighbor statements.

3) Deleted the neighbor and configured it again but that didnt work either.

Layer 3 routes were being recieved on all relevant routers along with the BGP labels but i couldnt even ping my directly connected C-PE from the CSC-PE routers. I could however ping the directly connected interface hence the BGP peering sessions remained up between CSC-PE and PE routers.

This was happening on both XR routers. I could only ping the C-PE router loopbacks from the XR routers when i enabled address-family ipv4 unicast by itself. Every time, i enabled address-family ipv4 labeled-unicast, the solution stopped working. I spent significant time on this but i couldnt get it to work.

If i am missing something then please do tell me as i have reached a dead end on this one. For this to happen on both XR routers doesnt seem to be a one off issue. If anyone has an idea then please do tell :(

 

Comments

  • have a try add to a static route on xr

    router static

    vrf CSC

    172.9.11.2/32 

  • Thanks for that. Also just managed to watch the SPv3 ATC video and that explains why this wasnt working. Makes sense now.

Sign In or Register to comment.