Inter-AS between IOS-XR

Hello all,

How to configure inter-as vpnv4 between IOS-XR?

IOS-XR

lets say they are connected with gi0/0/0/0 and router 1 have 1.1.1.1/24 where router 2 have gi0/0/0/0 address 1.1.1.2/24

BGP should look like this:

R1 ASBR for site 200

router bgp 200

mpls activate
interface gi0/0/0/0

address-family vpnv4

neighbor 1.1.1.2
remote-as 100
address-family vpnv4
route-policy PASS in
route-policy PASS out
exit

route-policy PASS

 pass

exit

 

 

--------------------------

R2 ASBR for site 100

router bgp 100

mpls activate

interface gi0/0/0/0

address-family vpnv4

neighbor 1.1.1.1

remote-as 200

address-family vpnv4
route-policy PASS in

route-policy PASS out

exit

route-policy PASS

 pass

exit

---------------------

I can't verify this at the moment will this config work or do i need to add any other command my tough this will be similar to IOS:

ON IOS I would make the config as followed:

R1

router bgp 100
no bgp defaul ipv4-unicast
neighbor 1.1.1.2 remote-as 200

address-family vpnv4
neighbor 1.1.1.2 activate

int gi0/0
ip add 1.1.1.1 255.255.255.0
mpls mbgp forwarding

 

 

R2

router bgp 200

no bgp defaul ipv4-unicast

neighbor 1.1.1.1 remote-as 100

address-family vpnv4

neighbor 1.1.1.1 activate

int gi0/0

ip add 1.1.1.2 255.255.255.0

mpls mbgp forwarding

-----------------------

And what about the send-label option on IOS the config should look like this:

R1

router bgp 100
 no bgp defaul ipv4-unicast
 neighbor 1.1.1.2 remote-as 200

address-family ipv4
 neighbor 1.1.1.2 activate
 neighbor 1.1.1.2 send-label

int gi0/0
 ip add 1.1.1.1 255.255.255.0
 mpls mbgp forwarding

 

 

R2

router bgp 200

no bgp defaul ipv4-unicast

neighbor 1.1.1.1 remote-as 100

address-family ipv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-label

int gi0/0

ip add 1.1.1.2 255.255.255.0

mpls mbgp forwarding

 

R1 ASBR for site 100

router bgp 100
 address-family ipv4 unicast
 allocate-label all


neighbor 1.1.1.2

 remote-as 200

address-family ipv4 unicast

  route-policy PASS in

  route-policy PASS out
address-family ipv4 labeled-unicast

  route-policy PASS in

  route-policy PASS out

 exit

route-policy PASS

 pass

exit

 

router bgp 200

 address-family ipv4 unicast

 allocate-label all


neighbor 1.1.1.1
 remote-as 100
address-family ipv4 unicast
  route-policy PASS in

  route-policy PASS out
address-family ipv4 labeled-unicast
  route-policy PASS in
  route-policy PASS out
 exit

route-policy PASS
 pass
exit

 

Did I miss any config your replies are much appreciated

Comments

  • Check the Advanced Technologies Class.  This topic is covered in detail there.  Otherwise there is this document: http://www.cisco.com/en/US/docs/routers/xr12000/software/xr12k_r3.9/lxvpn/configuration/guide/vc39v3.html#wp1085732

     

    Brian McGahan, CCIE #8593 (R&S/SP/Security)

    [email protected]

     

    Internetwork Expert, Inc.

    http://www.INE.com

     

    From: [email protected] [mailto:[email protected]] On Behalf Of a.elanazi
    Sent: Saturday, November 19, 2011 7:55 AM
    To: Brian McGahan
    Subject: [CCIE SP] Inter-AS between IOS-XR

     

    Hello all,

    How to configure inter-as vpnv4 between IOS-XR?

    IOS-XR

    lets say they are connected with gi0/0/0/0 and router 1 have 1.1.1.1/24 where router 2 have gi0/0/0/0 address 1.1.1.2/24

    BGP should look like this:

    R1 ASBR for site 200

    router bgp 200

    mpls activate
    interface gi0/0/0/0

    address-family vpnv4

    neighbor 1.1.1.2
    remote-as 100
    address-family vpnv4
    route-policy PASS in
    route-policy PASS out
    exit

    route-policy PASS
     pass
    exit

     

     

    --------------------------

    R2 ASBR for site 100

    router bgp 100

    mpls activate
    interface gi0/0/0/0

    address-family vpnv4

    neighbor 1.1.1.1
    remote-as 200
    address-family vpnv4
    route-policy PASS in
    route-policy PASS out
    exit

    route-policy PASS
     pass
    exit

    ---------------------

    I can't verify this at the moment will this config work or do i need to add any other command my tough this will be similar to IOS:

    ON IOS I would make the config as followed:

    R1

    router bgp 100
    no bgp defaul ipv4-unicast
    neighbor 1.1.1.2 remote-as 200

    address-family vpnv4
    neighbor 1.1.1.2 activate

    int gi0/0
    ip add 1.1.1.1 255.255.255.0
    mpls mbgp forwarding

     

     

    R2

    router bgp 200
    no bgp defaul ipv4-unicast
    neighbor 1.1.1.1 remote-as 100

    address-family vpnv4
    neighbor 1.1.1.1 activate

    int gi0/0
    ip add 1.1.1.2 255.255.255.0
    mpls mbgp forwarding

    -----------------------

    And what about the send-label option on IOS the config should look like this:

    R1

    router bgp 100
     no bgp defaul ipv4-unicast
     neighbor 1.1.1.2 remote-as 200

    address-family ipv4
     neighbor 1.1.1.2 activate
     neighbor 1.1.1.2 send-label

    int gi0/0
     ip add 1.1.1.1 255.255.255.0
     mpls mbgp forwarding

     

     

    R2

    router bgp 200
    no bgp defaul ipv4-unicast
    neighbor 1.1.1.1 remote-as 100

    address-family ipv4
    neighbor 1.1.1.1 activate
    neighbor 1.1.1.1 send-label

    int gi0/0
    ip add 1.1.1.2 255.255.255.0
    mpls mbgp forwarding

     

    R1 ASBR for site 100

    router bgp 100
     address-family ipv4 unicast
     allocate-label all

    neighbor 1.1.1.2
     remote-as 200
    address-family ipv4 unicast
      route-policy PASS in
      route-policy PASS out
    address-family ipv4 labeled-unicast
      route-policy PASS in
      route-policy PASS out
     exit

    route-policy PASS
     pass
    exit

     

    router bgp 200
     address-family ipv4 unicast
     allocate-label all

    neighbor 1.1.1.1
     remote-as 100
    address-family ipv4 unicast
      route-policy PASS in
      route-policy PASS out
    address-family ipv4 labeled-unicast
      route-policy PASS in
      route-policy PASS out
     exit

    route-policy PASS
     pass
    exit

     

    Did I miss any config your replies are much appreciated




    INE - The Industry Leader in CCIE Preparation
    http://www.INE.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Hi,

    A couple of sidenotes to your configuration:

    1. The command mpls activate interface GigabitEthernet0/0/0/0 is only required for Inter-AS (option B and C) and Carrier Supporting Carrier (CSC) configurations with confederations.
    2. IOS-XR does not automatically learn directly connected host routes, you'll need to configure a static host route to ensure MPLS forwarding to the neighboring AS.
    3. The neighbor send-label command under the IPv4 AFI is required to exchange labels between AS-es. If you have configured a route-map to manipulate attributes or filter routes you'll need to explicitly configure set mpls-label in the route-map statement to ensure proper label exchange.
  • Hello All,

    This template worked for me INter-AS Type B

     

    router bgp <ASN>

     address-family vpnv4 unicast

      retain route-target all

     !

     neighbor <ASBR_REMOTE_IP>

      remote-as <ASBR_REMOTE_ASN>

      update-source <ASBR_LOCAL_INTERFACE>

      !

      address-family vpnv4 unicast

       route-policy <ROUTE_POLICY> in

       route-policy <ROUTE_POLICY> out

       next-hop-self

      !

     !

    router static

     address-family ipv4 unicast

      <ASBR_REMOTE_IP>/32 <ASBR_LOCAL_INTERFACE>

     !

    !

    Best regards

    Cassio Gomes

     

  • Hi,

    The ios xr don't have route-map command, instead  route-policy is used, and you cannot set
    " set mpls-label " under route-policy. To allocate label for routes you need set " allocate-label all " command under IPv4 AFI, like this:

     

    router bgp 64812
     bgp router-id 10.250.2.16
      interface TenGigE0/1/0/2.1016
     !
     bgp log neighbor changes detail
     address-family ipv4 unicast
      maximum-paths ebgp 2
      redistribute ospf 1 route-policy rp_ospf-to-bgp
      allocate-label all
     !
     neighbor 10.250.128.105
      remote-as 65001
      description --- 10G CsC BGP peers ---
      address-family ipv4 labeled-unicast
       route-policy rp-from_10G in
       route-policy rp-to_10G out

Sign In or Register to comment.