Auto RP with sparse mode

Multicast topology is configured with only sparse mode. Auto-rp listener feature and static rp for any group are not configured any where.

R5 is FR hub router configured with 

 

#ip pim send-rp-announce Loopback0 scope 10

#ip pim send-rp-discovery Loopback0 scope 10

 

 

In this multicast environment, Is it possibe for auto-rp to work without an issue? please give your comments.

 

Regards,

 

Comments

  • Hi dcancerian,

    When HUB is RP and MA, no issue at all. See this example:
    FR Configuration of HUB
    interface Serial1/0
     ip address 192.168.0.2 255.255.255.0
     ip pim sparse-mode
     encapsulation frame-relay
     ip ospf priority 100
     serial restart-delay 0
     frame-relay map ip 192.168.0.4 204 broadcast
     frame-relay map ip 192.168.0.5 205 broadcast
     frame-relay map ip 192.168.0.6 206 broadcast
     no frame-relay inverse-arp
    end
    !
    ip pim send-rp-announce Loopback0 scope 20
    ip pim send-rp-discovery Loopback0 scope 20
    !
    SPOKE

    R4#ping 229.1.1.1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 229.1.1.1, timeout is 2 seconds:

    Reply to request 0 from 192.168.1.1, 556 ms
    Reply to request 0 from 192.168.1.1, 696 ms
    Reply to request 0 from 192.168.1.1, 560 ms
    Reply to request 0 from 192.168.1.1, 560 ms
    Reply to request 0 from 192.168.1.1, 556 ms

    R4#show ip pim rp mapping
    PIM Group-to-RP Mappings

    Group(s) 224.0.0.0/4
      RP 2.2.2.2 (?), v2v1
        Info source: 2.2.2.2 (?), elected via Auto-RP
             Uptime: 00:13:08, expires: 00:02:43
    R6#ping 229.1.1.1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 229.1.1.1, timeout is 2 seconds:

    Reply to request 0 from 192.168.1.1, 400 ms
    Reply to request 0 from 192.168.1.1, 428 ms
    Reply to request 0 from 192.168.1.1, 404 ms
    Reply to request 0 from 192.168.1.1, 404 ms
    Reply to request 0 from 192.168.1.1, 404 ms
    R6#ping 230.1.1.1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 230.1.1.1, timeout is 2 seconds:

    Reply to request 0 from 192.168.0.5, 432 ms
    R6#ping 230.1.1.1

    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 230.1.1.1, timeout is 2 seconds:

    Reply to request 0 from 192.168.0.5, 240 ms

    But there are some restriction  of placing MA and RP behind SPOKE or HUB. 

     

    1. When we configure the ip pim autorp listener, Multicast control  group (224.0.1.39 and 224.0.1.40) operates on Dense mode, which is not campatible with nbma mode because nbma mode works only on sparse mode

    2. Most probable solutions are:

    - Remove auto-rp listener 

    -  Either move the Mapping Agent either to the HUB or behind the HUB or

     - Create the GRE tunnle between SPOKEs and configure static route or

     - Configure the Router located behind the HUB or HUB as a RP only for Multicast control group (224.0.1.39 and 224.0.1.40), apply all these to all routers.

    Better look this MA and RP placement mega thread over NBMA network:

    http://ieoc.com/forums/t/16226.aspx?PageIndex=1

    and look this Auto-RP over NBMA Design issue video by Brian,

    http://blog.ine.com/2011/08/18/ine-video-blog-auto-rp-over-nbma-design-issues/

     

     

    HAPPY STUDY

    [:D]

  • In this multicast environment, Is it possibe for auto-rp to work without an issue? please give your comments.

     

     


    If you have PIM router behind the WAN router, you need to enable Autorp listener on the WAN router, otherwise autorp message won't be relayed to the downstream router.

  • If you have PIM router behind the WAN router, you need to enable Autorp listener on the WAN router, otherwise autorp message won't be relayed to the downstream router.

    [/Yes that what it should be. We need auto-rp listener but in the scenario presented i was able to get rp mapping from the MA without auto-rp listener and with only sparse-mode i am not sure why it behaves like that i checked it several times with same result.

     

    Regards,]

     

     

  • If you have PIM router behind the WAN router, you need to enable Autorp listener on the WAN router, otherwise autorp message won't be relayed to the downstream router

    I don't think, your answer is correct. 

    If it is HUB and Spoke as dcancerian has, it doesn't work with autorp listener. There is ip nbma mode command to work like splithorizon but it doesn't work on dense-mode. When you enable autorp listener router starts flodding Multicast control-plane(224.0.1.39 and 224.0.1.40)  traffic on dense-mode and nmba mode is desinged for sparse mode only.

    Any comments?

    HAPPY STUDY

    [:D]

  • Yes that what it should be. We need auto-rp listener but in the scenario presented i was able to get rp mapping from the MA without auto-rp listener and with only sparse-mode i am not sure why it behaves like that i checked it several times with same result

    Hi dcancerian,

    Can you post your config/show mroute count and show ip mroute output. Did you try ping from one SPOKE to another SPOKE when you have autorp listener on HUB? There is split-horizon rules on HUB, when Mpacket comes on one interface, HUB router doesn't send back through same interface, for this we need ip pim nbma command and it works only for sparse-mode. But when you enable autorp listener router starts flooding multicast control plane traffic on dense-mode (224.0.1.39 and 40).

    FYI my previous post contains some key information of placing RP and MA on NBMA desinged network.

    HAPPY STUDY

    [:D]

  • If it is HUB and Spoke as dcancerian has, it doesn't work with autorp listener. There is ip nbma mode command to work like splithorizon but it doesn't work on dense-mode. When you enable autorp listener router starts flodding Multicast control-plane(224.0.1.39 and 224.0.1.40)  traffic on dense-mode and nmba mode is desinged for sparse mode only.


    Oh, I thought the Hub is the MA?

  • [/Yes that what it should be. We need auto-rp listener but in the scenario presented i was able to get rp mapping from the MA without auto-rp listener and with only sparse-mode i am not sure why it behaves like that i checked it several times with same result.

     

     


    I remember someone in IEOC reported this behaviour of autorp as well, but couldn't remember who. Tried to search and found this thread instead:http://ieoc.com/forums/p/15062/129869.aspx
    As stated by Brian, maybe newer IOS is trying to fix autorp automatically without the use of autorp listener and sparse-dense mode. I tried to search on CCO but no luck so far. Maybe someone else can chip in to help.
    Thanks for sharing.

  • Alexander - This is a recent discussion about the fact that
    autorp-listener command is automatically enabled in new IOS versions.

    http://ieoc.com/forums/p/17195/149413.aspx#149413

    Andrius
  • Alexander - This is a recent discussion about the fact that

    autorp-listener command is automatically enabled in new IOS versions.



    http://ieoc.com/forums/p/17195/149413.aspx#149413



    Andrius

    This is true that recent IOS versions have autorp listerner feature enabled by default but why it does not work every time? Are there any conditions associated with it?

    Base scenario: INE WB vol1 topology, EIGRP running on all routers interfaces. NO AUTO-RP LISTERNER, NO SPARSE-DENSE MODE and NO STATIC RP MAPPING for any groups configured. Multicast is not enabled on R2. INE racks are used here.

    Case1: SW1 fa0/3 -- shutdown, R1 fa0/0 -- shutdown, R5 s0/0/0 -- shutdown, Enable ip pim sparse-mode on all interface connecting from SW3 to SW10. R5 is configured as # ip pim send-rp-discovery Loopback0 scope 10 interval 10 . SW2 and SW4 are configured as # ip pim send-rp-announce Loopback0 scope 10 interval 10 . In this case MA (R5) send discovery messages up to R4 and SW2 means only R4 and SW2 has RP mapping.

    Case2: All interface of R1 is shutdown, R4 s0/0/0 -- shutdown. Enabled ip pim sparse-mode on all interfaces connecting from SW3 to SW4, and SW1 and R3 connection interfaces, R3 and R5 connecting FR interfaces. R6 is configured as # ip pim send-rp-discovery Loopback0 scope 10 interval 10 . SW4, SW2 and R4 are configured as # ip pim send-rp-announce Loopback0 scope 10 interval 10 . In this case R6 is no receiving any rp-announse messages from SW2 and SW4 but receiving from R4. Now R6 is having R4 as RP which R6 is sending as discovery messages to R4,SW1->R3->R5 but not relayed up to SW2. Means R4,SW1,R3 and R5 has rp mappin. While SW3, SW2 and SW4 does have rp mapping.

    Can someone please explain why this is happening?

  • This is a recent discussion about the fact that

    autorp-listener command is automatically enabled in new IOS versions.

    I did some test on this platoform/IOS: 7200 Software (C7200-ADVENTERPRISEK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2) but autorp listener is not enabled by default. 

    I have this topology R1(MA)-R2-R3(RP):

     

    R2#ping 225.1.1.1 re 10

     

    Type escape sequence to abort.

    Sending 10, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

    ..........

    R2#conf t

    Enter configuration commands, one per line.  End with CNTL/Z.

    R2(config)#ip pim autorp listener

    R2(config)#^Z

    R2#

    *Nov 11 00:08:11.107: %SYS-5-CONFIG_I: Configured from console by console

    R2#show ip pim ne

    PIM Neighbor Table

    Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

          P - Proxy Capable, S - State Refresh Capable, G - GenID Capable

    Neighbor          Interface                Uptime/Expires    Ver   DR

    Address                                                            Prio/Mode

    12.12.12.1        FastEthernet1/0          00:16:29/00:01:28 v2    1 / S P G

    23.23.23.3        FastEthernet1/1          00:13:17/00:01:17 v2    1 / DR S P G

    R2#ping 225.1.1.1 re 10

     

    Type escape sequence to abort.

    Sending 10, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

    ........

    *Nov 11 00:08:51.467: Auto-RP(0): Received RP-discovery packet of length 48, from 1.1.1.1, RP_cnt 1, ht 181

    *Nov 11 00:08:51.467: (0): pim_add_prm:: 224.0.0.0/240.0.0.0, rp=3.3.3.3, repl = 1, ver =3, is_neg =0, bidir = 0, crp = 0

    *Nov 11 00:08:51.471: Auto-RP(0): Added with

    *Nov 11 00:08:51.471:  prm_rp->bidir_mode = 0 vs bidir = 0 (224.0.0.0/4, RP:3.3.3.3), PIMv2 v1

    *Nov 11 00:08:52.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

    Reply to request 8 from 3.3.3.3, 44 ms

    Reply to request 8 from 3.3.3.3, 260 ms

    Reply to request 9 from 3.3.3.3, 12 ms

    Reply to request 9 from 3.3.3.3, 580 ms

    Reply to request 9 from 3.3.3.3, 200 ms

    Anyone can tell me in which IOS autorp listener is enabled by default?


    HAPPY STUDY

    [:D]

     

  • I'm yet to test on the 7200 platform but on the 3725 Version 12.4(15)T10, autorp is enabled by default. You can tell by using this commands:




    show run | i auto-rp listener  (This is to see if the configs have the "ip pim autorp listener" configured)





    AND





    sh ip pim autorp (This specifies if autorp is enabled by default).







    Hope this helps!


    Olushile 





    -----Original Message-----

    From: nnn <[email protected]>

    To: olushile <[email protected]>

    Sent: Thu, Nov 10, 2011 8:33 am

    Subject: Re: [CCIE R&S] Auto RP with sparse mode















    imageAndrius2:

    This is a recent discussion about the fact that


    autorp-listener command is automatically enabled in new IOS versions.






    I did some test on this platoform/IOS: 7200 Software (C7200-ADVENTERPRISEK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2) but autorp listener is not enabled by default. 


    I have this topology R1(MA)-R2-R3(RP):


     


    R2#ping 225.1.1.1 re 10


     


    Type escape sequence to abort.


    Sending 10, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:


    ..........


    R2#conf t


    Enter configuration commands, one per line.  End with CNTL/Z.


    R2(config)#ip pim autorp listener


    R2(config)#^Z


    R2#


    *Nov 11 00:08:11.107: %SYS-5-CONFIG_I: Configured from console by console


    R2#show ip pim ne


    PIM Neighbor Table


    Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,


          P - Proxy Capable, S - State Refresh Capable, G - GenID Capable


    Neighbor          Interface                Uptime/Expires    Ver   DR


    Address                                                            Prio/Mode


    12.12.12.1        FastEthernet1/0          00:16:29/00:01:28 v2    1 / S P G


    23.23.23.3        FastEthernet1/1          00:13:17/00:01:17 v2    1 / DR S P G


    R2#ping 225.1.1.1 re 10


     


    Type escape sequence to abort.


    Sending 10, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:


    ........


    *Nov 11 00:08:51.467: Auto-RP(0): Received RP-discovery packet of length 48, from 1.1.1.1, RP_cnt 1, ht 181


    *Nov 11 00:08:51.467: (0): pim_add_prm:: 224.0.0.0/240.0.0.0, rp=3.3.3.3, repl = 1, ver =3, is_neg =0, bidir = 0, crp = 0


    *Nov 11 00:08:51.471: Auto-RP(0): Added with


    *Nov 11 00:08:51.471:  prm_rp->bidir_mode = 0 vs bidir = 0 (224.0.0.0/4, RP:3.3.3.3), PIMv2 v1


    *Nov 11 00:08:52.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up


    Reply to request 8 from 3.3.3.3, 44 ms


    Reply to request 8 from 3.3.3.3, 260 ms


    Reply to request 9 from 3.3.3.3, 12 ms


    Reply to request 9 from 3.3.3.3, 580 ms


    Reply to request 9 from 3.3.3.3, 200 ms


    Anyone can tell me in which IOS autorp listener is enabled by default?





    HAPPY STUDY


    Big Smile


     






    --

    View this message online at: http://ieoc.com/forums/p/17374/151262.aspx#151262

    --

    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com





    Subscription information may be found at:


    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    <!>





  • Hi Andrius,

       You got that discussion missunderstood. It does not say auto-rp listener is turned on by default, it says: auto-rp listener, you need to enabled it manually and allows you to forward auto-rp multicast group feeds in dense mode, even though all your interfaces are running in sparse-mode. However, once you enable multicast routing and PIM on at least one interface, the router starts listening on the 224.0.1.40 group, which is the auto-rp MA group, so it can learn the Rp mapings from MA advertisments but will NOT forward it further unless auto-rp listener is turned on, or running sparse-dense mode.

    Good luck with your studies!

    Alexander - This is a recent discussion about the fact that
    autorp-listener command is automatically enabled in new IOS versions.

    http://ieoc.com/forums/p/17195/149413.aspx#149413

    Andrius
  • Hi nnn/all,

       With current IOS versions, there is NO auto-rp listener enabled by default, some of use just did not correctly understand other forum conversations.

    Good luck with your studies!

  • With current IOS versions, there is NO auto-rp listener enabled by default, some of use just did not correctly understand other forum conversations.

    That is the result on all my test! some how missinformation is flooding...

    HAPPY STUDY

    [:D]

  • Case1: SW1 fa0/3 -- shutdown, R1 fa0/0 -- shutdown, R5 s0/0/0 -- shutdown, Enable ip pim sparse-mode on all interface connecting from SW3 to SW10. R5 is configured as # ip pim send-rp-discovery Loopback0 scope 10 interval 10 . SW2 and SW4 are configured as # ip pim send-rp-announce Loopback0 scope 10 interval 10 . In this case MA (R5) send discovery messages up to R4 and SW2 means only R4 and SW2 has RP mapping.

    Case2: All interface of R1 is shutdown, R4 s0/0/0 -- shutdown. Enabled ip pim sparse-mode on all interfaces connecting from SW3 to SW4, and SW1 and R3 connection interfaces, R3 and R5 connecting FR interfaces. R6 is configured as # ip pim send-rp-discovery Loopback0 scope 10 interval 10 . SW4, SW2 and R4 are configured as # ip pim send-rp-announce Loopback0 scope 10 interval 10 . In this case R6 is no receiving any rp-announse messages from SW2 and SW4 but receiving from R4. Now R6 is having R4 as RP which R6 is sending as discovery messages to R4,SW1->R3->R5 but not relayed up to SW2. Means R4,SW1,R3 and R5 has rp mappin. While SW3, SW2 and SW4 does have rp mapping.

    Hi cristian

    As per your explaination Case1 test is perfectly ok but what about case 2 where SW1 is not only listerning RP info (224.0.1.40) multicast from R6 but also forwarded it to R3. And R4 forward it to R5. I got your point but not sure why this is happening.

    Regards,

  • Hi,

       I do not have a full vision of configs on scenario 2; to see that it functions as in case 1, take 3 routers, R1----link to-----R2-----link to-----R3; configure multicast routing and  pim sparse mode on all interfaces, configure R1 as MA and RP using auto-rp; you should see that R2 learns the RP mappings, but R3 does not.

    Good luck with your studies!

Sign In or Register to comment.