NTP Broadcast Authentication - Don't work

Hi,  I can successfully do NTP broadcast, but about 10 min after I configure command "NTP Authenticate" on S2, it don't work.  Does anybody know what the right configuration should be? Thanks.  Again, i know NTP authenticate is missing in the below configurartion but about 10 minutes after configuring it, it loses synchronization.

S2

interface Vlan58
 ntp broadcast client
 ntp broadcast key 1

ntp authentication-key 1 md5 cisco
ntp trusted-key 1

R5

int FastEthernet0/0/1
ntp broadcast 155.1.58.255
ntp broadcast

ntp authentication-key 1 md5 cisco
ntp authenticate
ntp trusted-key 1
ntp source Loopback0
ntp master 5

Thanks in advance

Comments

  • willpower,

    Have you tried using "ntp server a.b.c.d"?

    I know this isn't needed without authentication, but you might see if it makes authentication work...

  • i figured out what i did wrong.  I forgot the ntp broadcast key 1 on the server side.  you can't use ntp server x.x.x.x or it will start polling the server for time instead of receiving it as a broadcast.  you'll get a ~x.x.x.x when you show ntp status.  so relieved i got this.  i've had probelms with this since about a year ago.  i've never got it to work and i've litterally spent 5 hours on this single configuration (cumulative).  ntp always looks so easy to configure, but i always had difficulty with the multicast and the broadcast.  stil haven't got the multicast to work successfully...

  • Hi,

    You also don't need the "ntp authenticate" on the server side (R5), cause client authenticates time source, server does not authenticate clients. As for multicast, i remember it worked for me when i tested it.

    Good luck with your studies!

Sign In or Register to comment.