subinterfaces native vlan confusion

Greets, i've spent great amount of time trying to figure out if its me missing something or maybe my dynamips Nic cards buggy with 802.1q tagging.

So Im following Brian's vidoe and implementing simple router on the stick with subinterfaces and multiple vlans + switch with dot1q trunk with matching vlan...

Lets say I have  :

 

R1  ----->   SW1---------->R3 (vlan 10) ip 10.0.0.5

                  ^------------->R5 (vlan 20) ip 20.0.0.5

 

R1 has subs configured .10 and .20

i setup native vlan on R1 sub .10 to be native vlan 10 encap dot1q, and .20 to vlan 20(no native)

after i match native vlan 10 with SW1 trunk port (so trunk dot1q becomes native vlan 10) and add ports R3 and R5 to vlan10/20 as access ports respectfully.

I dont know what command on SW1 : "vlan dot1q native tag" does, so i tried on or off (doesnt make difference)...

Brian enabled it in the video, and im confused if i should also use it, ive seen examples where it worked without that...

 

Anyway in video Brian able to ping interfaces with this minimum configuration, but in my case i cant ping anything...

I have 2 different Nic's in my dynamips box - one Dlink and 2 Adaptec ANA's620 - ive read somewhere it could be related to 802.1q not being supported or bugs or hardware issues...

Also i think it could be related to some bugs/stupid Nic issues/allien conspiracy/dunno, because when I use R5 to route through different switch SW5(they connected through Dlink interface on dynamips) i can ping fine both .10 and .20...

 

here is relevant files if some1 knows :

 

----------

SW1

----------

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
system mtu routing 1500
!
!
!
!
!        
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
!
!
!
!
!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 10
 switchport mode trunk
!
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 20
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
 shutdown
!
interface FastEthernet0/18
 shutdown
!
interface FastEthernet0/19
 shutdown
!
interface FastEthernet0/20
 shutdown
!
interface FastEthernet0/21
 shutdown
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!        
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!        
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!        
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
 no ip address
!
ip http server
ip http secure-server
!
!
!
logging esm config
!
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

 

 

 

 

-----------------------------

SW3

-----------------------------

Current configuration : 3948 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW3
!
!
ip subnet-zero
!
no ip domain-lookup
!
port-channel load-balance dst-mac
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
vlan dot1q tag native
 --More--
09:09:10: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/5 (not half duplex), with R5 FastEthernet0/1 (half duplex).
!        
!
interface Port-channel1
 switchport mode dynamic desirable
!
interface FastEthernet0/1
 switchport mode dynamic desirable
!
interface FastEthernet0/2
 switchport mode dynamic desirable
!
interface FastEthernet0/3
 switchport access vlan 20
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/4
 switchport mode dynamic desirable
!
interface FastEthernet0/5
 switchport access vlan 20
 switchport mode dynamic desirable
!
interface FastEthernet0/6
 switchport mode dynamic desirable
!
interface FastEthernet0/7
 switchport mode dynamic desirable
!
interface FastEthernet0/8
 switchport mode dynamic desirable
!
interface FastEthernet0/9
 switchport mode dynamic desirable
!
interface FastEthernet0/10
 switchport mode dynamic desirable
!
interface FastEthernet0/11
 switchport mode dynamic desirable
!
interface FastEthernet0/12
 switchport mode dynamic desirable
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/16
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/17
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/18
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/19
 switchport mode dynamic desirable
 shutdown
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
!
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
!
interface FastEthernet0/22
 switchport mode dynamic desirable
!
interface FastEthernet0/23
 switchport mode dynamic desirable
!
interface FastEthernet0/24
 switchport mode dynamic desirable
!
interface FastEthernet0/25
 switchport mode dynamic desirable
!        
interface FastEthernet0/26
 switchport mode dynamic desirable
!
interface FastEthernet0/27
 switchport mode dynamic desirable
!
interface FastEthernet0/28
 switchport mode dynamic desirable
!
interface FastEthernet0/29
 switchport mode dynamic desirable
!
interface FastEthernet0/30
 switchport mode dynamic desirable
!
interface FastEthernet0/31
 switchport mode dynamic desirable
!
interface FastEthernet0/32
 switchport mode dynamic desirable
!
interface FastEthernet0/33
 switchport mode dynamic desirable
!
interface FastEthernet0/34
 switchport mode dynamic desirable
!
interface FastEthernet0/35
 switchport mode dynamic desirable
!
interface FastEthernet0/36
 switchport mode dynamic desirable
!
interface FastEthernet0/37
 switchport mode dynamic desirable
!
interface FastEthernet0/38
 switchport mode dynamic desirable
!
interface FastEthernet0/39
 switchport mode dynamic desirable
!
interface FastEthernet0/40
 switchport mode dynamic desirable
!
interface FastEthernet0/41
 switchport mode dynamic desirable
!
interface FastEthernet0/42
 switchport mode dynamic desirable
!
interface FastEthernet0/43
 switchport mode dynamic desirable
!
interface FastEthernet0/44
 switchport mode dynamic desirable
!
interface FastEthernet0/45
 switchport mode dynamic desirable
!
interface FastEthernet0/46
 switchport mode dynamic desirable
!
interface FastEthernet0/47
 switchport mode dynamic desirable
!
interface FastEthernet0/48
 switchport mode dynamic desirable
!        
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
!
ip classless
ip http server
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 login
line vty 5 15
 login
!
!
end  

 

 

-----------------

R1

-----------------

Current configuration : 1193 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 speed 100
 full-duplex
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10 native
 ip address 10.0.0.1 255.255.255.0
 no ip route-cache
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 20.0.0.1 255.255.255.0
 no ip route-cache
!
interface Serial0/0
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000

!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!        
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!

!    
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

 

-----------

R3

-----------

Current configuration : 1083 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.0.5 255.255.255.0
 shutdown
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 20.0.0.3 255.255.255.0
 speed 100
 full-duplex
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 13.0.0.1
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

 

 

----------

R5

----------

Building configuration...

Current configuration : 1556 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 20.0.0.5 255.255.255.0
 no ip route-cache
 speed 100
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache
 shutdown
 clock rate 2000000
 frame-relay lmi-type ansi
!        
interface FastEthernet0/1
 ip address 20.0.0.7 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 no ip route-cache
 shutdown
 clock rate 2000000
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
 no ip route-cache
!
ip default-gateway 20.0.0.1
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
 --More--
*Mar  1 02:03:24.215: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1 (not full duplex), with SW3 FastEthernet0/5 (full duplex).
!        
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

 

Comments

  • i remeber every word of it - i just simply dont understand how would it affect connectivity, where would i use it/ where would i not/ and how to get this damn thing to work/seems like im lost and unable to point finger on REAL reason why my ping not coming through...

     

    can some1 give me config that works !!! so i can test it and see if its not bug in my NIC's firware, at least i could separate chasing bugs from lack of knowledge of the concept, because right now im extremely suspicious as i match exact Brian topology from videos (this and QinQ) and i get nothing on pings !!!!

     

     

  • You should not tag the native VLAN if you are using ecanp dot1q native on router but you said that you had tried with it both on and off. I see that you have messages from CDP warning about half duplex. This could be a reason for pings not going throug. I usually hardcode all links to 100/full when running Dynamips, it seems to perform best this way.

    Do you see anything in your ARP cache? I would try to debug ARP and debug ICMP to see how far packets are traveling.

  • Hi,

       Did you create the VLANs on all involved switches? Let us know from switches: show vlan brief, show interfaces trunk, show spanning-tree vlan x, show interfaces fa0/x switchport (instead of x  use only interfaces/vlans active in thye topology)

    Good luck with your studies!

  •  

    its so weird i get this issues - im seeing Brian in his videos not declaring native vlan tags and only using subinterfaces and "encap dotq1 vlan 10/20" commands and get firm pings... maybe it is time for me to look into real lab - not dynamips :((

     

    anyway here is arp debug and icmp and i see this when trying to ping between routers :

    things like this :

     when pinging routers : 
    on router side :

    *Mar 1 00:47:06.283: IP ARP: creating incomplete entry for IP address: 20.0.0.1 interface FastEthernet0/1
    *Mar 1 00:47:06.283: IP ARP: sent req src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 0000.0000.0000 FastEthernet0/1.
    *Mar 1 00:47:08.283: IP ARP: sent req src 20.0.0.6 c202.08ce.0001,

     

    on switch side :

    00:51:39: IP ARP: rcvd req src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 Vlan10
    SW3#
    00:51:41: IP ARP: rcvd req src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 Vlan10
    SW3#
    00:51:43: IP ARP: rcvd req src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 Vlan10

     

    on recieving router i get  :

    *Mar 1 00:53:17.839: IP ARP req filtered src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 0000.0000.0000 wrong cable, interface FastEthernet0/0.10

  • on recieving router i get  :

    *Mar 1 00:53:17.839: IP ARP req filtered src 20.0.0.6 c202.08ce.0001, dst 20.0.0.1 0000.0000.0000 wrong cable, interface FastEthernet0/0.10

     

    Your R1's F0/0.10 is configured as follows:
    interface FastEthernet0/0.10
     encapsulation dot1Q 10 native
     ip address 10.0.0.1 255.255.255.0
     no ip route-cache

    And you are pinging from 20.0.0.6 to 20.0.0.1. It's desirable that R1 filtered the ARP request for this case.
    Message "IP ARP req filtered src [ip-address] [mac-address] dst [ip-address] [mac-address] wrong cable, interface-id" means that ARP request's source IP address is not in the same subnet with the receiving interface.
    Ref: http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a00807347ab.shtml#ping

    You may want to check your VLAN assignment again and use "show spann vlan" and or "sh mac add add" to verify the L2 connectivity.

    HTH

  • ARP is complaining that it is received on wrong interface. Did you mess up the VLAN assignments?

  • I belive vlans setup properly, however is it possible my Adaptec Nic's used in dynamips  only forwarding NATIVE "untagged" traffic and unable to pass "tagged" different 802.1q Vlan traffic ?

    Could that be the case here ??? If so then i need new NICs, or im missing something obvious in configuration?

     
     thank you for your help again !!!
     

    Heres all my configs :

     

    http://pastebin.com/vUwzR1D3

  • Create and access-list matching the traffic and then debug ip packet through that ACL and paste here

  • I belive vlans setup properly, however is it possible my Adaptec Nic's used in dynamips  only forwarding NATIVE "untagged" traffic and unable to pass "tagged" different 802.1q Vlan traffic ?

    I don't hav exp with Dynamips with breakout switch. But you should be able to verify the spanning tree to make sure there is no break in L2 connectivity. And also make sure the physical cabling is accurate.

    The symptom that I see is that R1's F0/0.10 (VLAN 10) received arp request from IP 20.0.0.6, which belongs to VLAN 20. There are few possibilites that could happen:
    1. 20.0.0.6 interface is assigned with VLAN 10
    2. VLAN 10 and VLAN 20 is accidentally bridged

  •  

    I'm not sure what should i place in access-list, can you please create it so i can paste it in my config...

  • I belive vlans setup properly, however is it possible my Adaptec Nic's used in dynamips  only forwarding NATIVE "untagged" traffic and unable to pass "tagged" different 802.1q Vlan traffic ?

    I don't hav exp with Dynamips with breakout switch. But you should be able to verify the spanning tree to make sure there is no break in L2 connectivity. And also make sure the physical cabling is accurate.

    The symptom that I see is that R1's F0/0.10 (VLAN 10) received arp request from IP 20.0.0.6, which belongs to VLAN 20. There are few possibilites that could happen:
    1. 20.0.0.6 interface is assigned with VLAN 10
    2. VLAN 10 and VLAN 20 is accidentally bridged

     

    I'm not using breakout switch - im using 3 nic solution (Adaptec 64044LV, 62044 and Dlink 570 - all 3 not sure if supporting Dot1q under linux)... 

    spanning tree shows FWD port states and no incosistant or blocked ports...physical cabling is fine as i can see cdp neihbors...

    20.0.0.6 assigned to vlan 20

    how could vlan10 and vlan20 be "accidently" bridged ? meaning on configuration or on hardware level ?

    Thanks

     

  • how could vlan10 and vlan20 be "accidently" bridged ? meaning on configuration or on hardware level ?

    Not sure, could you give us the physical topology of your setup?
    Do you notice that you have two interfaces on R5 that are configured with IP addresses from the same subnet?

    interface FastEthernet0/0
    ip address 20.0.0.5 255.255.255.0
    no ip route-cache
    speed 100
    full-duplex
    !
    interface FastEthernet0/1
    ip address 20.0.0.7 255.255.255.0
    no ip route-cache
    duplex auto
    speed auto

  • its basic router on the stick :

    R1 ----> SW1 ----> R3 and R5

    theres matching dot1q trunk native 10 between Sw1 and subinterface fa0/0.10 on R1

    then theres 2 vlans on Sw1 - vlan 10 for R3 and vlan 20 for R5

    ping from native vlan goes through, i suspect because its not tagged and my Nic cards probably dont support either higher then 1500 MTU or 802.1q tagging... not sure yet.
     well so ping from native vlan goes through but vlan 20 pings get nowhere, debug claims there is some weird L2-to-L3 issue

    heres requested information :
     ============================================================================
     R1#show cdp
     R1#show cdp nei
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0.10 178 S I WS-C3560- Fas 0/1
     -------------------------------------------------------------------------------
     R3#show cdp neig
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0 129 S I WS-C3560- Fas 0/3
     ----------------------------------------------------------------------------
     R5#show cdp nei
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0 179 S I WS-C3560- Fas 0/5
     -----------------------------------------------------------------------------
     SW1#show cdp neighbors
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
     D - Remote, C - CVTA, M - Two-port Mac Relay

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW2 Fas 0/14 145 R S I WS-C3560- Fas 0/14
     SW2 Fas 0/13 145 R S I WS-C3560- Fas 0/13
     R3 Fas 0/3 148 R S I 3725 Fas 0/0
     R1 Fas 0/1 150 R S I 3725 Fas 0/0
     R5 Fas 0/5 125 R S I 3725 Fas 0/0
     ------------------------------------------------------------------------------
     R1#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 unassigned YES manual up up
     FastEthernet0/0.10 10.0.0.1 YES manual up up
     FastEthernet0/0.20 20.0.0.1 YES manual up up
     Serial0/0 unassigned YES NVRAM administratively down down
     FastEthernet0/1 unassigned YES NVRAM administratively down down
     Serial0/1 unassigned YES NVRAM administratively down down
     ----------------------------------------------------------------------------------
     R3#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 10.0.0.2 YES manual up up
     FastEthernet0/1 23.0.0.3 YES NVRAM administratively down down
     Serial1/0 unassigned YES NVRAM administratively down down
     Serial1/1 unassigned YES NVRAM administratively down down
     Serial1/2 unassigned YES NVRAM administratively down down
     Serial1/3 unassigned YES NVRAM administratively down down
     R3#
     -----------------------------------------------------------------------------------
     R5#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 20.0.0.2 YES manual up up
     Serial0/0 unassigned YES NVRAM administratively down down
     FastEthernet0/1 unassigned YES NVRAM administratively down down
     Serial0/1 unassigned YES NVRAM administratively down down
     FastEthernet1/0 unassigned YES unset up down
     FastEthernet1/1 unassigned YES unset up up
     FastEthernet1/2 unassigned YES unset up down
     FastEthernet1/3 unassigned YES unset up down
     FastEthernet1/4 unassigned YES unset up down
     FastEthernet1/5 unassigned YES unset up down
     FastEthernet1/6 unassigned YES unset up down

  • its basic router on the stick :

    R1 ----> SW1 ----> R3 and R5

    theres matching dot1q trunk native 10 between Sw1 and subinterface fa0/0.10 on R1

    then theres 2 vlans on Sw1 - vlan 10 for R3 and vlan 20 for R5

    ping from native vlan goes through, i suspect because its not tagged and my Nic cards probably dont support either higher then 1500 MTU or 802.1q tagging... not sure yet.
     well so ping from native vlan goes through but vlan 20 pings get nowhere, debug claims there is some weird L2-to-L3 issue

    heres requested information :
     ============================================================================
     R1#show cdp
     R1#show cdp nei
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0.10 178 S I WS-C3560- Fas 0/1
     -------------------------------------------------------------------------------
     R3#show cdp neig
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0 129 S I WS-C3560- Fas 0/3
     ----------------------------------------------------------------------------
     R5#show cdp nei
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW1 Fas 0/0 179 S I WS-C3560- Fas 0/5
     -----------------------------------------------------------------------------
     SW1#show cdp neighbors
     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
     S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
     D - Remote, C - CVTA, M - Two-port Mac Relay

    Device ID Local Intrfce Holdtme Capability Platform Port ID
     SW2 Fas 0/14 145 R S I WS-C3560- Fas 0/14
     SW2 Fas 0/13 145 R S I WS-C3560- Fas 0/13
     R3 Fas 0/3 148 R S I 3725 Fas 0/0
     R1 Fas 0/1 150 R S I 3725 Fas 0/0
     R5 Fas 0/5 125 R S I 3725 Fas 0/0
     ------------------------------------------------------------------------------
     R1#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 unassigned YES manual up up
     FastEthernet0/0.10 10.0.0.1 YES manual up up
     FastEthernet0/0.20 20.0.0.1 YES manual up up
     Serial0/0 unassigned YES NVRAM administratively down down
     FastEthernet0/1 unassigned YES NVRAM administratively down down
     Serial0/1 unassigned YES NVRAM administratively down down
     ----------------------------------------------------------------------------------
     R3#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 10.0.0.2 YES manual up up
     FastEthernet0/1 23.0.0.3 YES NVRAM administratively down down
     Serial1/0 unassigned YES NVRAM administratively down down
     Serial1/1 unassigned YES NVRAM administratively down down
     Serial1/2 unassigned YES NVRAM administratively down down
     Serial1/3 unassigned YES NVRAM administratively down down
     R3#
     -----------------------------------------------------------------------------------
     R5#show ip int bri
     Interface IP-Address OK? Method Status Protocol
     FastEthernet0/0 20.0.0.2 YES manual up up
     Serial0/0 unassigned YES NVRAM administratively down down
     FastEthernet0/1 unassigned YES NVRAM administratively down down
     Serial0/1 unassigned YES NVRAM administratively down down
     FastEthernet1/0 unassigned YES unset up down
     FastEthernet1/1 unassigned YES unset up up
     FastEthernet1/2 unassigned YES unset up down
     FastEthernet1/3 unassigned YES unset up down
     FastEthernet1/4 unassigned YES unset up down
     FastEthernet1/5 unassigned YES unset up down
     FastEthernet1/6 unassigned YES unset up down

  • I had the same problem and found out its the NIC card that doesn't support it. I had to stop using the NIC card and bought usb-ethernet adapters for my lab. These wires really go for cheap and were highly helpful for me to study for my lab exam.


    Hope this helps,




    Olushile 





    -----Original Message-----

    From: unsobill <[email protected]>

    To: olushile <[email protected]>

    Sent: Thu, Nov 3, 2011 7:47 pm

    Subject: Re: [CCIE R&S] subinterfaces native vlan confusion













    its basic router on the stick :



    R1 ----> SW1 ----> R3 and R5



    theres matching dot1q trunk native 10 between Sw1 and subinterface fa0/0.10 on R1



    then theres 2 vlans on Sw1 - vlan 10 for R3 and vlan 20 for R5



    ping from native vlan goes through, i suspect because its not tagged and my Nic cards probably dont support either higher then 1500 MTU or 802.1q tagging... not sure yet.

     well so ping from native vlan goes through but vlan 20 pings get nowhere, debug claims there is some weird L2-to-L3 issue



    heres requested information :

     ============================================================================

     R1#show cdp

     R1#show cdp nei

     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

     S - Switch, H - Host, I - IGMP, r - Repeater



    Device ID Local Intrfce Holdtme Capability Platform Port ID

     SW1 Fas 0/0.10 178 S I WS-C3560- Fas 0/1

     -------------------------------------------------------------------------------

     R3#show cdp neig

     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

     S - Switch, H - Host, I - IGMP, r - Repeater



    Device ID Local Intrfce Holdtme Capability Platform Port ID

     SW1 Fas 0/0 129 S I WS-C3560- Fas 0/3

     ----------------------------------------------------------------------------

     R5#show cdp nei

     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

     S - Switch, H - Host, I - IGMP, r - Repeater



    Device ID Local Intrfce Holdtme Capability Platform Port ID

     SW1 Fas 0/0 179 S I WS-C3560- Fas 0/5

     -----------------------------------------------------------------------------

     SW1#show cdp neighbors

     Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

     S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

     D - Remote, C - CVTA, M - Two-port Mac Relay



    Device ID Local Intrfce Holdtme Capability Platform Port ID

     SW2 Fas 0/14 145 R S I WS-C3560- Fas 0/14

     SW2 Fas 0/13 145 R S I WS-C3560- Fas 0/13

     R3 Fas 0/3 148 R S I 3725 Fas 0/0

     R1 Fas 0/1 150 R S I 3725 Fas 0/0

     R5 Fas 0/5 125 R S I 3725 Fas 0/0

     ------------------------------------------------------------------------------

     R1#show ip int bri

     Interface IP-Address OK? Method Status Protocol

     FastEthernet0/0 unassigned YES manual up up

     FastEthernet0/0.10 10.0.0.1 YES manual up up

     FastEthernet0/0.20 20.0.0.1 YES manual up up

     Serial0/0 unassigned YES NVRAM administratively down down

     FastEthernet0/1 unassigned YES NVRAM administratively down down

     Serial0/1 unassigned YES NVRAM administratively down down

     ----------------------------------------------------------------------------------

     R3#show ip int bri

     Interface IP-Address OK? Method Status Protocol

     FastEthernet0/0 10.0.0.2 YES manual up up

     FastEthernet0/1 23.0.0.3 YES NVRAM administratively down down

     Serial1/0 unassigned YES NVRAM administratively down down

     Serial1/1 unassigned YES NVRAM administratively down down

     Serial1/2 unassigned YES NVRAM administratively down down

     Serial1/3 unassigned YES NVRAM administratively down down

     R3#

     -----------------------------------------------------------------------------------

     R5#show ip int bri

     Interface IP-Address OK? Method Status Protocol

     FastEthernet0/0 20.0.0.2 YES manual up up

     Serial0/0 unassigned YES NVRAM administratively down down

     FastEthernet0/1 unassigned YES NVRAM administratively down down

     Serial0/1 unassigned YES NVRAM administratively down down

     FastEthernet1/0 unassigned YES unset up down

     FastEthernet1/1 unassigned YES unset up up

     FastEthernet1/2 unassigned YES unset up down

     FastEthernet1/3 unassigned YES unset up down

     FastEthernet1/4 unassigned YES unset up down

     FastEthernet1/5 unassigned YES unset up down

     FastEthernet1/6 unassigned YES unset up down






    --

    View this message online at: http://ieoc.com/forums/p/17293/150122.aspx#150122

    --

    INE - The Industry Leader in CCIE Preparation


    http://www.INE.com





    Subscription information may be found at:


    http://www.ieoc.com/forums/ForumSubscriptions.aspx



    <!>





  • As Daniel said,

                      This is correct, ARP is complaning and it reply is being recevied on a different subinterface, I am facing the same problem and trying to rectify it. As soon as I get done it. I will post the solution.

     

    Ta

Sign In or Register to comment.