Task 1.8 - Different Take

Wow, this would be a bad task interpretation on my part! My solution to the final bullet of the subject task:

macro name VPORTS
mls qos trust cos
switchport priority extend cos 0
switchport voice vlan 7
switchport access vlan 17


Then I did 'int range fa0/7-8' and 'macro apply VPORTS'

If you think about it, this exactly answers the task requirement. The switchports *are* configured at the same time using a macro named VPORTS.

Anybody else take this angle?

Comments

  • yep. Also the SG didn't specify
    "switchport priority extend cos 0"
    which is one of the task requirements
  • Yeah this answer confused me. I already kind of suck on CatQOS, so that's no difficult thing. From the 3560 config guide:
    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12244se/scg/swqos.htm#wp1021252

    "By using the mls qos trust cos interface configuration command, you configure the switch port to which the telephone is connected to trust the CoS labels of all traffic received on that port."

    "In some situations, you can prevent a PC connected to the Cisco IP Phone from taking advantage of a high-priority data queue. You can use the switchport priority extend cos interface configuration command to configure the telephone through the switch CLI to override the priority of the traffic received from the PC."

    Extending cos 0 seems like the winning play here. Either way I'll be printing that entire section out and reading it at work today, provided the systems guys and developers can avoid blowing up the network for an afternoon.
  •  Originally Posted By: mwitte
    yep. Also the SG didn't specify
    "switchport priority extend cos 0"
    which is one of the task requirements


    This is the default setting. That is why it is not showing up on the config.
  •  Originally Posted By: edwlui
     Originally Posted By: mwitte
    yep. Also the SG didn't specify
    "switchport priority extend cos 0"
    which is one of the task requirements


    This is the default setting. That is why it is not showing up on the config.


    I don't think that is the default setting. I have seen it in configs before. I agree they left out extend cos 0. Which is why I came to the forum - to see if you guys agreed.
  • I applied this command and it is not showing up on my config. According to the DocCD. It is the default setting:

    http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12244se/cr1/cli3.htm#wp1948613
  • Rack1SW1(config)#define interface-range VPORTS G1/0/8 - 11
    Rack1SW1(config)#interface range macro VPORTS
    Rack1SW1(config-if-range)#SW ACC VLA 17
    Rack1SW1(config-if-range)#SW VOICE VL 7
    Rack1SW1(config-if-range)#SW PRI EXTEND COS
    Rack1SW1(config-if-range)#MLS QOS TRUST COS
    Rack1SW1(config-if-range)#END
    Rack1SW1#
    Rack1SW1#
    Rack1SW1#
  • Rack1SW1(config-if-range)#SWitchport priority extend cos 0
    Rack1SW1(config-if-range)#mls qos trust cos
    Rack1SW1(config-if-range)#no shut
    Rack1SW1(config-if-range)#end
    Rack1SW1#
    Rack1SW1#
    Rack1SW1#
    Rack1SW1#

    SH RUN INT G1/0/7
    interface GigabitEthernet1/0/7
    switchport access vlan 17
    switchport voice vlan 17
    mls qos trust cos
    spanning-tree portfast
    end

    Rack1SW1#sh mls qos int G1/0/7
    GigabitEthernet1/0/7
    trust state: trust cos
    trust mode: trust cos
    trust enabled flag: ena
    COS override: dis
    default COS: 0
    DSCP Mutation Map: Default DSCP Mutation Map
    Trust device: none
    qos mode: port-based

    Rack1SW1#

    AS YOU CAN SEE ABOVE BY ADDING THE LINE SW PRI EXTENDE COS 0 DOSE NOT SHOW IN THE CONFIG AS IT IS NOT NEEDED COZ ITS THE DEFAULT

    SHAKS
  • Rack1SW1(config-if-range)#SWitchport priority extend cos 0
    Rack1SW1(config-if-range)#mls qos trust cos
    Rack1SW1(config-if-range)#no shut
    Rack1SW1(config-if-range)#end
    Rack1SW1#
    Rack1SW1#
    Rack1SW1#
    Rack1SW1#

    SH RUN INT G1/0/7
    interface GigabitEthernet1/0/7
    switchport access vlan 17
    switchport voice vlan 17
    mls qos trust cos
    spanning-tree portfast
    end

    Rack1SW1#sh mls qos int G1/0/7
    GigabitEthernet1/0/7
    trust state: trust cos
    trust mode: trust cos
    trust enabled flag: ena
    COS override: dis
    default COS: 0
    DSCP Mutation Map: Default DSCP Mutation Map
    Trust device: none
    qos mode: port-based

    Rack1SW1#

    AS YOU CAN SEE ABOVE BY ADDING THE LINE SW PRI EXTENDE COS 0 DOSE NOT SHOW IN THE CONFIG AS IT IS NOT NEEDED COZ ITS THE DEFAULT

    SHAKS
  • I am just wondering when we should use one of the two approaches, either create the macro via define interface or macro command. The only difference on the output is that when you use the macro command, there is an additional input, that is the "macro description" name. Any thoughts?
  • In this case, you need to use define macro command, due it is necessary to use it again.
Sign In or Register to comment.