Dialer Interface back up traffic problem

Hi All,

I have configured two Dialer interfaces in two seperate routers to test dial-back up connectivity. I have two routers at Remote site that each has its own Dialer back up Interface and I am running PPP encapsultation with one router in HUB site. There are OSPF running between the router in HUB site and two routers at remote site. There is another router in the remote site that I use T1 connectivity to connect to another router at the HUB which I use T1 circuit as the primary and these two Dialer back up as the back up.

The problem is that when two Dialer interfaces are up "I can bring them up with sending interesting traffic over the link with Pinging from CE router at the remote site to HUB router over PSTN. I am also using VRF in CEs to have multiple routing tables". The traffic will be sent over just one link. when two Dialer interfaces are up, OSPF neighbors are established and FULL adjacency are established. Both CE routers show that Dialer interfaces on each of them are up. The only way that I know there is only traffic in one interface is that when I am running ping sourcing from VRF on CE router at remote site to VRF on the HUB on One Dialer interface, Ping is successful but as soon as I start the ping from the second CE router at the remote site sourcing from VEF at the remote site to VRF at HUB site, The first ping stopped working and just the second Ping continues working although OSPF neighbors are FULL/Adjacent and both Dialer Interfaces are physically up. Could any one pleae advice what can be the reason that Ping is successful on just one Dialer interface at any given time. I tried to change the mode on Asynchronous Interface to Dedicated but that did not help. Ihave cleared OSPF process but OSPF is just fine. The problem is that ping is sucessful just on one Interface at a time. I appreciate your advice.

Thank you

 

 

Comments

  • Hi Ellie,

    Could you share the config with us?

  • Maybe if you use more than one physical interface for the dialer, you need to use ppp multilink.

    But the config or a snippet would be nice!

     

    Regards!

  • Hi Ellie,

    You can configure either "OSPF demand circuit" or configure your Dialer interface to be always UP.

    http://ieoc.com/forums/t/16669.aspx

    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481b.shtml

    Hi All,

    I have configured two Dialer interfaces in two seperate routers to test dial-back up connectivity. I have two routers at Remote site that each has its own Dialer back up Interface and I am running PPP encapsultation with one router in HUB site. There are OSPF running between the router in HUB site and two routers at remote site. There is another router in the remote site that I use T1 connectivity to connect to another router at the HUB which I use T1 circuit as the primary and these two Dialer back up as the back up.

    The problem is that when two Dialer interfaces are up "I can bring them up with sending interesting traffic over the link with Pinging from CE router at the remote site to HUB router over PSTN. I am also using VRF in CEs to have multiple routing tables". The traffic will be sent over just one link. when two Dialer interfaces are up, OSPF neighbors are established and FULL adjacency are established. Both CE routers show that Dialer interfaces on each of them are up. The only way that I know there is only traffic in one interface is that when I am running ping sourcing from VRF on CE router at remote site to VRF on the HUB on One Dialer interface, Ping is successful but as soon as I start the ping from the second CE router at the remote site sourcing from VEF at the remote site to VRF at HUB site, The first ping stopped working and just the second Ping continues working although OSPF neighbors are FULL/Adjacent and both Dialer Interfaces are physically up. Could any one pleae advice what can be the reason that Ping is successful on just one Dialer interface at any given time. I tried to change the mode on Asynchronous Interface to Dedicated but that did not help. Ihave cleared OSPF process but OSPF is just fine. The problem is that ping is sucessful just on one Interface at a time. I appreciate your advice.

    Thank you

     

     

     

  • Thank you all for your responses. I appreciate your help. I am attaching the configuration. as a reminder: The Dialer Interfaces are up and running and OSPF adjacencies are also up. the problem is that at any give time. the traffic can pass through one interface. the way that I understand that is because when I start ping from Remoter site to another HUB, as soon as the second dial-up comes up, that ping stops working on the first dialer.

    As far as applying dialer-profile on the serial interface, it is already applied on serial on HUB side. At the remote site, I don't have serial Interface so I can not apply Dialer-profile on Serial Interface at the remote sites. I read through OSPF on demand circuits but I am not sure if that can help problems as OSPF neighbor ship is always up at all times. I have tried "Dialer mode persistance" and that could not solve the problem.

    @Alexander: configuration is attached.

    //Hub site CE2 router//

    CE2_LB#show run
    Building configuration...

    Current configuration : 6407 bytes
    !
    ! Last configuration change at 00:28:45 UTC Wed Sep 28 2011 by test
    ! NVRAM config last updated at 00:28:46 UTC Wed Sep 28 2011 by test
    ! NVRAM config last updated at 00:28:46 UTC Wed Sep 28 2011 by test
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CE2_LB
    !
    boot-start-marker
    boot system flash:c3900-universalk9_npe-mz.SPA.152-1.T.bin
    boot-end-marker
    !
    !
    card type t1 0 0
    card type t1 0 1
    no logging buffered
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    !
    !
    !
    !
    !
    aaa session-id common
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 T1 0/0/0
    !
    modem country v12 usa
    ipv6 spd queue min-threshold 62
    ipv6 spd queue max-threshold 63
    no ipv6 cef
    !
    !
    !
    ip vrf pos
     rd 1:1
    !
    ip vrf test2
     rd 2:2
    !
    !
    !
    ip domain name yourdomain.com
    ip cef
    multilink bundle-name authenticated
    !
    isdn switch-type primary-ni
    !
    modemcap entry Cisco-WIC:FD=&FV1:AA=S0=0:MSC=V0&S0=0+GCI=B5;
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-2926791094
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2926791094
            quit
    license udi pid C3900-SPE100/K9 sn FOC151242QE
    license boot module c3900 technology-package uck9
    hw-module pvdm 0/0
    !
    !
    !
    username test password 0 test
    username test1 password 0 test1
    !
    !
    controller T1 0/0/0
     cablelength long 0db
     pri-group timeslots 1-24
    !
    controller T1 0/0/1
     cablelength long 0db
     pri-group timeslots 1-24
    !
    controller T1 0/1/0
     cablelength long 0db
     pri-group timeslots 1-24
    !
    controller T1 0/1/1
     cablelength long 0db
     pri-group timeslots 1-24
    !
    !
    !
    !
    !
    interface Loopback100
     ip vrf forwarding pos
     no ip address
     ip ospf network point-to-point
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     no ip address
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/0.1
     encapsulation dot1Q 1 native
     ip vrf forwarding pos
     ip address 10.2.1.2 255.255.255.0
    !
    interface GigabitEthernet0/0.2
     encapsulation dot1Q 2
     ip vrf forwarding test2
     ip address 10.3.1.2 255.255.255.0
    !
    interface GigabitEthernet0/1
     ip address 1.1.1.1 255.255.255.252
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0/0:23
     description ISDN PRI ZI-27 9727285334 - 5356
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer-group 1
     isdn switch-type primary-ni
     isdn incoming-voice modem
     ppp authentication chap
     no cdp enable
    !
    interface Serial0/0/1:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     no cdp enable
    !
    interface Serial0/1/0:23
     description ISDN PRI ZI-28 972-728-7332 - 7354
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer-group 1
     isdn switch-type primary-ni
     isdn incoming-voice modem
     ppp authentication chap
     no cdp enable
    !
    interface Serial0/1/1:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     no cdp enable
    !
    interface Dialer1
     ip vrf forwarding pos
     ip address 172.16.57.193 255.255.255.192
     encapsulation ppp
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     dialer pool 1
     dialer-group 1
     ppp authentication chap
     no ppp chap ignoreus
     no ppp chap wait
     no cdp enable
    !
    interface Group-Async1
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer in-band
     dialer pool-member 1
     dialer idle-timeout 86400
     no peer default ip address
     async mode dedicated
     no keepalive
     ppp authentication chap
     no ppp chap ignoreus
     group-range 0/387 0/422
     routing dynamic
     hold-queue 100 in
     hold-queue 100 out
    !
    router ospf 100 vrf pos
     capability vrf-lite
     network 10.0.0.0 0.255.255.255 area 0
     network 172.16.0.0 0.0.255.255 area 0
    !
    ip local pool Group-1 172.16.57.194 172.16.57.254
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip route 172.16.57.192 255.255.255.192 Null0
    !
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 101 deny   ospf any any
    access-list 101 permit ip any any
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
     privilege level 15
     logging synchronous
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line 0/387 0/422
     exec-timeout 0 0
     modem InOut
     modem autoconfigure discovery
     no exec
     transport preferred none
     transport input all
     transport output all
     autoselect during-login
     autoselect ppp
    line vty 0 4
     access-class 23 in
     privilege level 15
     transport input telnet ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end
    ..................................................................................................

    // CE3 Remote router//
    CE3_LB_1921#show run
    Building configuration...

    Current configuration : 3724 bytes
    !
    ! Last configuration change at 00:26:51 UTC Wed Sep 28 2011 by test
    ! NVRAM config last updated at 00:04:57 UTC Wed Sep 28 2011 by test
    ! NVRAM config last updated at 00:04:57 UTC Wed Sep 28 2011 by test
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CE3_LB_1921
    !
    boot-start-marker
    boot system flash:c1900-universalk9-mz.SPA.151-4.M1.bin
    boot-end-marker
    !
    !
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    !
    !
    !
    !
    !
    aaa session-id common
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    ip vrf pos
     rd 1:1
    !
    !
    !
    multilink bundle-name authenticated
    !
    chat-script callout AT OK atdtT TIMEOUT 60 CONNECT c
    chat-script No-Answer send AT&F&S0=0
    modemcap entry modem:MSC=S0=8
    modemcap entry Cisco-WIC:FD=&FV1:AA=S0=0:MSC=V0&S0=0+GCI=B5;
    !
    !
    !
    !
    !
    !
    interface Loopback100
     ip vrf forwarding pos
     ip address 172.16.57.200 255.255.255.255
    !
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/0
     ip vrf forwarding pos
     ip address 10.2.22.1 255.255.255.0
     duplex auto
     speed auto
     no keepalive
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0/0
     no ip address
     encapsulation frame-relay IETF
     shutdown
     no fair-queue
    !
    interface Serial0/0/0.101 point-to-point
     ip vrf forwarding pos
     ip address 147.225.133.242 255.255.255.252
     frame-relay interface-dlci 101 IETF
    !
    interface Async1
     no ip address
     encapsulation slip
    !
    interface Async0/1/0
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer in-band
     dialer pool-member 2
     no peer default ip address
     no fair-queue
     no keepalive
     routing dynamic
    !
    interface Dialer1
     ip vrf forwarding pos
     ip unnumbered Loopback100
     no ip mfib cef input
     no ip mfib cef output
     encapsulation ppp
     dialer pool 2
     dialer string 18002406031
     dialer hold-queue 5
     dialer-group 1
     no peer default ip address
     ppp authentication chap
     ppp chap hostname test
     no ppp chap ignoreus
     ppp chap password 0 test
     no cdp enable
    !
    interface Group-Async1
     physical-layer async
     no ip address
     encapsulation slip
     routing dynamic
    !
    router ospf 100 vrf pos
     router-id 172.16.57.200
     capability vrf-lite
     no capability lls
     network 0.0.0.0 255.255.255.255 area 0
    !
    router bgp 11
     bgp router-id 147.225.133.242
     bgp log-neighbor-changes
     !
     address-family ipv4 vrf pos
      network 10.2.22.0 mask 255.255.255.0
      neighbor 147.225.133.241 remote-as 65000
      neighbor 147.225.133.241 activate
     exit-address-family
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route vrf pos 0.0.0.0 0.0.0.0 Dialer1 240
    !
    !
    ip prefix-list default_in seq 5 permit 0.0.0.0/0
    access-list 1 deny   172.17.3.225
    access-list 1 permit any
    access-list 101 deny   ospf any any
    access-list 101 permit ip any any
    access-list 102 permit ip host 10.2.1.3 any
    dialer-list 1 protocol ip list 101
    !
    route-map Advertise-Default-Only permit 10
     match ip address prefix-list Learned-Default-Prefix
    !
    route-map Advertise-Default-Only deny 20
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
     privilege level 15
     logging synchronous
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line 0/1/0
     modem InOut
     modem autoconfigure type Cisco-WIC
     transport input all
     transport output all
     stopbits 1
     speed 115200
     flowcontrol hardware
    line vty 0 4
     transport input all
    !
    scheduler allocate 20000 1000
    end
    ...............................................................................................

    CE4 remote router//
    All possible debugging has been turned off
    CE3_LB_1841#show run
    Building configuration...

    Current configuration : 2907 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CE3_LB_1841
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authentication ppp default local
    !
    !
    aaa session-id common
    dot11 syslog
    ip source-route
    !
    !
    !
    !
    ip cef
    ip vrf pos
     rd 1:1
    !
    multilink bundle-name authenticated
    !
    chat-script callout AT OK atdtT TIMEOUT 60 CONNECT c
    chat-script No-Answer send AT&F&S0=0
    modemcap entry modem:MSC=S0=8
    modemcap entry Cisco-WIC:FD=&FV1:AA=S0=0:MSC=V0&S0=0+GCI=B5;
    !
    !
    !
    !
    username test1 password 0 test1
    username test password 0 test
    username ce2_lb password 0 test1
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    interface Loopback100
     ip vrf forwarding pos
     ip address 172.16.57.201 255.255.255.255
    !
    interface FastEthernet0/0
     ip vrf forwarding pos
     ip address 10.2.23.1 255.255.255.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0/0
     no ip address
     encapsulation frame-relay IETF
     frame-relay lmi-type ansi
    !
    interface Serial0/0/0.101 point-to-point
     ip address 147.225.133.242 255.255.255.252
     frame-relay interface-dlci 101 IETF
    !
    interface Serial0/0/0.500 point-to-point
     ip address 157.130.147.2 255.255.255.252
     frame-relay interface-dlci 500 IETF
    !
    interface Async0/1/0
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer in-band
     dialer pool-member 2
     no peer default ip address
     no fair-queue
     routing dynamic
    !
    interface Dialer1
     ip vrf forwarding pos
     ip unnumbered Loopback100
     encapsulation ppp
     dialer pool 2
     dialer string 18002406031
     dialer hold-queue 5
     dialer-group 1
     no peer default ip address
     no cdp enable
     ppp authentication chap
     ppp chap hostname test1
     no ppp chap ignoreus
     ppp chap password 0 test1
    !
    interface Group-Async1
     physical-layer async
     no ip address
     encapsulation slip
     routing dynamic
    !
    router ospf 100 vrf pos
     router-id 172.16.57.201
     log-adjacency-changes
     capability vrf-lite
     no capability lls
     network 0.0.0.0 255.255.255.255 area 0
    !
    router bgp 11
     no synchronization
     bgp log-neighbor-changes
     network 10.2.22.0 mask 255.255.255.0
     neighbor 147.225.133.241 remote-as 65000
     no auto-summary
    !
    ip forward-protocol nd
    ip route vrf pos 0.0.0.0 0.0.0.0 Dialer1 240
    !
    no ip http server
    no ip http secure-server
    !
    !
    access-list 1 deny   172.17.3.225
    access-list 1 permit any
    access-list 101 deny   ospf any any
    access-list 101 permit ip any any
    access-list 102 permit ip host 10.2.1.3 any
    dialer-list 1 protocol ip list 101
    !
    !
    control-plane
    !
    !
    line con 0
     privilege level 15
     logging synchronous
    line aux 0
    line 0/1/0
     modem InOut
     modem autoconfigure type Cisco-WIC
     transport input all
     transport output all
     stopbits 1
     speed 115200
     flowcontrol hardware
    line vty 0 4
    !
    scheduler allocate 20000 1000
    end

  • Hi Ricardo,

    Ellie's using the dialer interfaces for backup purpose.
    It will defeat the purpose if we configure it to be always up.
    He will be asked to pay for the bill. [:D]

    And as he mentioned in his post, there is nothing wrong with OSPF, but something wrong with the dialer interfaces connectivity. Only one can do ping the Hub while both are up.

    I think without getting more information about the configuration, we could not help much.
    I am interested to see what is the result of "show dialer int dialer X" and "show int dialer X" on both spoke routers and hub router when the dialers are up, to see if the dialer interface is bound to the physical interface and PPP IPCP is OPEN.

    I have weird exp with ISDN + Dialer. And most of the times, debug ppp negotiation, show int dialer X, debug isdn q921, debug isdn q931 or debug ppp auth will provide valuable information.

    Thank you for sharing

  • Thank you all for your Participation and answers. I did try to send the config couple of days ago but it failed and My post did not get posted here. I had both serial interface and Dialer Interface configured on HUB side. What I ended up doing was that I had to delete Dialer Interface from HUB side and I just left Serial interface at HUB side with Dialer Profile assigned to it. Basically, after deleting Dialer Interface which is Logical Interface and just leave Frame-relay serial interface at the hub side, Every thing worked file and I was able to have two PINGs simultaneously running from one site to another site over both of Dial up connection. Obviously, I did not change any thing on the remote sites as they did not have serial interface and just had Dialer Interface. I deleted the following Dialer interface from HUB site and just left Serial0/1/0:23 at the hub site.

    interface Serial0/1/0:23
     description ISDN PRI ZI-28 972-728-7332 - 7354
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer-group 1
     isdn switch-type primary-ni
     isdn incoming-voice modem
     ppp authentication chap
     no cdp enable
    !
    interface Serial0/1/1:23
     no ip address
     encapsulation hdlc
     isdn switch-type primary-ni
     no cdp enable
    !
    interface Dialer1
     ip vrf forwarding pos
     ip address 172.16.57.193 255.255.255.192
     encapsulation ppp
     ip ospf network point-to-multipoint
     ip ospf hello-interval 10
     dialer pool 1
     dialer-group 1
     ppp authentication chap
     no ppp chap ignoreus
     no ppp chap wait
     no cdp enable
    !

     

  • Hi Ellie,

    It looks like that you don't have "dialer pool-member 1" configured under "int s0/1/0:23" which binds "int di1" to it.

    It is strange when you mentioned that you remove "int di1" and it works after that?
    Does it mean that you assign IP address directly to the physical interface after removing "int Dialer 1"?

     

  • Hi Alexander,

    There are two PRI interfaces being used at HUB side so there is no interface to assign IP address to. I also deleted Dialer interface and that is when it started working. I have Interface asynch-group interface using "ip un numbered loopback" to recieve IP address from Loop back IP address range. there is no asynch defined on HUB side either. there are two PRI interfaces connecting from HUB side to PSTN. There are two DS0 interfaces connecting from remote sites to PSTN. I don't have asynch interface or Dialer interface defined on HUB side. I have just two PRI interfaces that just port 23 is up. there is no IP address assigned to that. I have pasted the configuration for Goup.async1

    interface Group-Async1
     ip vrf forwarding pos
     no ip address
     encapsulation ppp
     dialer in-band
     dialer pool-member 1
     dialer idle-timeout 86400
     no peer default ip address
     async mode dedicated
     no keepalive
     ppp authentication chap
     no ppp chap ignoreus
     group-range 0/387 0/422
     routing dynamic
     hold-queue 100 in
     hold-queue 100 out

     

Sign In or Register to comment.