unable to connect 2 LAN network

hi all i have 2 2900 series routers both are connected via DBVs Router/device

R1>Dbvs<R2

R1 to DbVs Connectiion

R1: 192.168.45.10 netmask 255.255.255.0

DbVs 192.168.45.101 255.255.255.0

R2 to DbVs connection

R2: 192.168.12.10 netmask 255.255.255.0

DBVS: 192.168.12.101 netmask 255.255.255.0

I have configured default routes on both my 2900 series routers However the can ping each other but Both router have also LANs

R1 LAN interface has ip address 192.168.3.254

R2 LAN interface has ip address 192.168.2.254

I m unable to ping my LANs from both routers. one problem may he DBVS dont have router inform for My LAN and I cannot configure/make some modification to DBVs device because i dont have acces to it

is there any way for configuration so that i may be able to connect my LANs to each other without doing anything to DBVS

Comments

  • Let me see if I understood correctly. You have this DBV router (which I don't have idea of what it is, I'll assume is a router) between R1 and R2.

    R1 and R2 have default routes pointing to DBV. R1 and R2 can ping each other but you can't ping LANs beyond R1 and R2.

     

    Probably this device doesn't have routes to LANs connected to R1 and R2. You are able to reach R1 and R2 interfaces because they are directly connected to the DBV.

    If you can't access this device then you can establish a GRE tunnel between R1 and R2:

    1) add a more specific /32 route on both R1 and R2 to reach each other (this will prevent recursive routing)

    2) configure a GRE tunnel between the two

    3) either add static routes on both R1 and R2 pointing out the tunnel interface to reach the LANs or configure a routing protocol to redistribute connected networks.

  • Hi Zaman,


    Based in my understanding and reenforce Soul's response I could conclude the configuration below, please ignore the config of the DBVs-Router-Device (which I don't know exactly it is, maybe you could tell us ;-) )

    R1:

    interface Loopback0

     ip address 192.168.3.254 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 192.168.45.101 255.255.255.0

    !

    ip route 0.0.0.0 0.0.0.0 192.168.45.10 name DBVs-Router-Device

    !

    end

    --------

    DBVs-Router-Device:

    interface FastEthernet0/0

     ip address 192.168.45.10 255.255.255.0

    !

    interface FastEthernet0/1

     ip address 192.168.12.10 255.255.255.0

    !

    ip route 192.168.2.0 255.255.255.0 192.168.12.101 name TO_R1

    ip route 192.168.3.0 255.255.255.0 192.168.45.101 name TO_R2

    !

    end

    -------

    R2:

    !

    interface Loopback0

     ip address 192.168.2.254 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 192.168.12.101 255.255.255.0

    !

    ip route 0.0.0.0 0.0.0.0 192.168.12.10 name DBVs-Router-Device

    !

    end

    ---------

    Connectivity Test!!!

    R2#ping 192.168.3.254  --> R1's LAN (loopback0) IP address

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.3.254, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/32 ms

    R2#trace 192.168.3.254

    Type escape sequence to abort.

    Tracing the route to 192.168.3.254

      1 192.168.12.10 12 msec 4 msec 4 msec

      2 192.168.45.101 16 msec *  8 msec

    R2#

    ---------

    R1#ping 192.168.2.254 --> R2's LAN (Loopback0) IP address

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.2.254, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms

    R1#trace 192.168.2.254

    Type escape sequence to abort.

    Tracing the route to 192.168.2.254

      1 192.168.45.10 4 msec 8 msec 4 msec

      2 192.168.12.101 12 msec *  12 msec

    R1#

    ---------------


    OPION2 w/ GRE Tunnels and not touching DBV Device

    R1:

    interface Loopback0

     ip address 192.168.3.254 255.255.255.0

    !

    interface FastEthernet0/0

     ip address 192.168.45.101 255.255.255.0

    !

    interface Tunnel12

     ip address 12.12.12.1 255.255.255.0

     tunnel source 192.168.45.101

     tunnel destination 192.168.12.101

    !

    ip route 0.0.0.0 0.0.0.0 192.168.45.10 name DBVs-Router-Device

    ip route 192.168.2.0 255.255.255.0 Tunnel12

    !

    end

    -------

    DBVs-Router-Device:

    interface FastEthernet0/0

     ip address 192.168.45.10 255.255.255.0

    !

    interface FastEthernet0/1

     ip address 192.168.12.10 255.255.255.0

    !

    -------

    R2:

    interface FastEthernet0/0

     ip address 192.168.12.101 255.255.255.0

    !

    interface Loopback0

     ip address 192.168.2.254 255.255.255.0

    !

    interface Tunnel12

     ip address 12.12.12.2 255.255.255.0

     tunnel source 192.168.12.101

     tunnel destination 192.168.45.101

    !

    ip route 0.0.0.0 0.0.0.0 192.168.12.10 name DBVs-Router-Device

    ip route 192.168.3.0 255.255.255.0 Tunnel12

    !

    end

    ----------

    Connectivity Test

    R2(config)#do ping 192.168.3.254  --> R1's LAN (loopback0) IP address

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.3.254, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/72 ms

    R2(config)#do trace 192.168.3.254

    Type escape sequence to abort.

    Tracing the route to 192.168.3.254

      1 12.12.12.1 20 msec *  8 msec

    R2(config)#

    R1(config)#do ping 192.168.2.254 --> R2's LAN (Loopback0) IP address

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 192.168.2.254, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms

    R1(config)#do trace 192.168.2.254

    Type escape sequence to abort.

    Tracing the route to 192.168.2.254

      1 12.12.12.2 60 msec *  8 msec

    R1(config)#

    hi all i have 2 2900 series routers both are connected via DBVs Router/device

    R1>Dbvs<R2

    R1 to DbVs Connectiion

    R1: 192.168.45.10 netmask 255.255.255.0

    DbVs 192.168.45.101 255.255.255.0

    R2 to DbVs connection

    R2: 192.168.12.10 netmask 255.255.255.0

    DBVS: 192.168.12.101 netmask 255.255.255.0

    I have configured default routes on both my 2900 series routers However the can ping each other but Both router have also LANs

    R1 LAN interface has ip address 192.168.3.254

    R2 LAN interface has ip address 192.168.2.254

    I m unable to ping my LANs from both routers. one problem may he DBVS dont have router inform for My LAN and I cannot configure/make some modification to DBVs device because i dont have acces to it

    is there any way for configuration so that i may be able to connect my LANs to each other without doing anything to DBVS

     

Sign In or Register to comment.