Error on SW1

HI,

Anyone has encountered the below errors:

Rack1SW1#
*Mar  1 00:57:42.411: %SYS-2-MALLOCFAIL: Memory allocation of 268 bytes failed from 0x60531204, alignment 32
Pool: I/O  Free: 32  Cause: Not enough free memory
Alternate Pool: None  Free: 0  Cause: No Alternate pool
 -Process= "Spanning Tree", ipl= 0, pid= 248,  -Traceback= 0x614269D4 0x60013344 0x60019180 0x60019860 0x6053120C 0x6053180C 0x60532584 0x6254CD6C 0x6254D738 0x62550CE0

I wonder if the above error would cause any problem to the full lab.

Can anyone advise me on this?

Comments

  • Yes,

    I've seen that happen. If you use Dynamips these issues can come now and then but how often have you seen this message? You probably just need to restart the "switch". Bad thing is you might loose your config.

    Since it is a memory issue have you made sure that you have enough memory to run the full topology?

  • I seen this message quite often. How to ensure that I have enough memory to run the full topology? Currently I have 4GB ram running Windows 7.

     

  • 4 GB is enough. Are you running 32 bits or 64 bits operating system? Windows has some issues with how much memory can be allocated to one process so running two hypervisors instead of one usually helps with these kind of issues. There are also other tweaks you can use as ghost IOS and sparse mem feature.

  • I am running on 64 bit OS. Below is the .Net file that I am currently using. I have already created 2 hypervisors instances but I am not familiar on how to tweak ghost IOS and sparse mem feature.

    Would you be able to advise?

     

    Thanks.

    autostart=false
    [localhost:7200]

    workingdir = D:INE_Labworking

    [[3725]]
     #
     # Specify 3725 IOS image on Mac OS X here:
     image = D:INE_LabImagesc3725-advipservicesk9-mz.124-15.T6.bin
     #
     ram = 128
     disk0 = 16
     disk1 = 0
     # Choose an idlepc value from the below
     idlepc = 0x62b1c780
     mmap = true
     ghostios = true

     

    [localhost:7201]
     udp = 11000

    workingdir = D:INE_Labworking

    [[3725]]
     #
     # Specify 3725 IOS image on Mac OS X here:
     image = D:INE_LabImagesc3725-advipservicesk9-mz.124-15.T6.bin
     #
     ram = 128
     disk0 = 16
     disk1 = 0
     # Choose an idlepc value from the below
     idlepc = 0x62b1c780
     mmap = true
     ghostios = true

     

     

     

  • Hello Kevinwai.

     

    I would recommend you to run the dynamips in the Linux Ubuntu Distribution. Linux is efficiently manage the memory  requirement of dynamips and run fast  as compared to the 

     

     

    Windows operating system. Running the dynamips in the linux distriution would resolve such issue.

     

    Here are the tutorial for the instalation.

     

    http://www.blindhog.net/cisco-dynamips-and-dynagen-install-on-linux/

    http://dynagen.org/tutorial.htm

    Happy Studying

  • Thanks for advice.

    However, i encountered error when trying to start dynamips process in ubuntu. It says can't create tcp or socket.

    Have anyone encountered this b4?

  • Maybe you don't have privileges to create socket. Try running it as root or on another port. You can list active ports with nestat command.

  • Kevinwai.

    It is seems to be permission problem. Run the dynamips command as sudo user.

    Hope this would resolve the issue.

    Happy Studying

Sign In or Register to comment.