Cisco 1721 ADSL Configuration for ATT DSL (No Internet Connection)

Hello,

  I am asking for assistance in my configuration. Hoping someone could help me with my configuration. Currently I have a Cisco 1721 with a ADSL WIC trying to get it to work with ATT DSL. Currently, I  have ATT DSL -> Cisco 1721 (ADSL WIC) -> PC (crossover cable). Below is my configuration and all my interfaces shows UP but I am still unable to connect to the Internet. I think the problem is with my ATM0 is NOT pulling an IP address from ATT, but I am not sure how to correct this. Any assistance is greatly appreciated.

Configuration:

============

Cisco1721#sho run                
Building configuration...                        

Current configuration : 1442 bytes
!
! No configuration change since last restart
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco1721
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool HUYHO.ORG
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.254
   domain-name HUYHO.ORG
   dns-server 68.94.156.1 68.94.157.1
!
ip cef
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/35
  encapsulation aal5snap

interface FastEthernet0
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 speed auto
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxx
 ppp chap password 0 xxxxx
 ppp pap sent-username xxxx password 0 xxxx
 ppp ipcp dns request accept
 ppp ipcp address accept
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 1 permit 0.0.0.0 255.255.255.0
access-list 2 permit 192.168.1.0 0.0.0.255
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end


=================

Cisco1721#sho ip int brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
ATM0                       unassigned      YES NVRAM  up                    up

Dialer1                    unassigned      YES NVRAM  up                    up

FastEthernet0              192.168.1.254   YES NVRAM  up                    up

Serial0                    unassigned      YES NVRAM  administratively down dow
=====================

 

Thank you

Michael

Sign In or Register to comment.