IP SLA Monitor issue

 

 

Dear all,

Could see that IP SLA Monitor is not activating redundant link/ route. Pls check the below config, let me know if any mistake/ miss:

R1(config)#do sh run | s ip sla monit
ip sla monitor 1
 type echo protocol ipIcmpEcho 157.126.144.65
 timeout 1000
 threshold 2
 frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
 type echo protocol ipIcmpEcho 157.126.144.66
 timeout 1000
 threshold 2
 frequency 3
ip sla monitor schedule 2 life forever start-time now
R1(config)#
R1(config)#do sh run | s track      
track 123 rtr 1 reachability
track 456 rtr 2 reachability
ip route 10.10.24.0 255.255.255.0 157.126.144.65 track 123
ip route 10.10.24.0 255.255.255.0 157.126.144.66 track 456

----------------------------------------------------------------------

R2#sh run | s ip sla monito
ip sla monitor 1
 type echo protocol ipIcmpEcho 157.126.144.65
 timeout 1000
 threshold 2
 frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
 type echo protocol ipIcmpEcho 157.126.144.66
 timeout 1000
 threshold 2
 frequency 3
ip sla monitor schedule 2 life forever start-time now
R2#
R2#sh run | s track       
track 123 rtr 1 reachability
track 456 rtr 2 reachability
ip route 10.10.24.0 255.255.255.0 157.126.144.65 track 123
ip route 10.10.24.0 255.255.255.0 157.126.144.66 track 456

-------------------------------------------------------------------------

Comments

  • You don't have any AD assigned to the secondary route which would imply that both routes are active all the time?

    Can you do show ip route 10.10.24.0?

    If you want a route to be secondary you should use ip route 10.10.24.0 255.255.255.0 157.126.144.66 254 track 456.

    Or is there no route at all when primary goes away?

  • I want load balancing (per destination based, using IP CEF,default) to happen on both the links so not given any AD.

    Well I have found the issue that I gave wrong destination IP 157.126.144.65 and 157.126.144.66. Actually these are my next hop IPs.

    But here comes another question. " type echo protocol ipIcmpEcho" command needs destination-ip-address but I want entire subnet to be tracked, Is it possible or there is another way out.

    Thnx

     

  • Hello ashse,

     

    you didn't define the primary or secondary link on your static route config, put higher AD on secondary link and you don't need object tracking on secondary link because when primary link start to work, it automatically install on routing table because of better AD.

     

    See here:

    R1#show running-config | section ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.2 source-ipaddr 192.168.0.1
     timeout 200
     frequency 5
    track 1 rtr 1

    ip route 2.2.2.2 255.255.255.255 192.168.0.2 track 1
    ip route 2.2.2.2 255.255.255.255 192.168.1.2 11

    !

    R1#show running-config interface fastEthernet 0/0
    Building configuration...

    Current configuration : 124 bytes
    !
    interface FastEthernet0/0
     description "Primary Link"
     ip address 192.168.0.1 255.255.255.0
     duplex auto
     speed auto
    end

    !

    R1#show running-config interface s1/0
    Building configuration...

    Current configuration : 119 bytes
    !
    interface Serial1/0
     description "Secondary Link"
     ip address 192.168.1.1 255.255.255.0
     serial restart-delay 0
    end

    !

    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    C       1.1.1.1 is directly connected, Loopback0
         2.0.0.0/32 is subnetted, 1 subnets
    S       2.2.2.2 [1/0] via 192.168.0.2 now via priamry link
    C    192.168.0.0/24 is directly connected, FastEthernet0/0
    C    192.168.1.0/24 is directly connected, Serial1/0
    R1#
    *Mar  1 00:06:51.227: %TRACKING-5-STATE: 1 rtr 1 state Up->Down (I shutdown the primary link on R2 to test)
    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    C       1.1.1.1 is directly connected, Loopback0
         2.0.0.0/32 is subnetted, 1 subnets
    S       2.2.2.2 [11/0] via 192.168.1.2 now via secondary link
    C    192.168.0.0/24 is directly connected, FastEthernet0/0
    C    192.168.1.0/24 is directly connected, Serial1/0

    R1#
    *Mar  1 00:07:36.227: %TRACKING-5-STATE: 1 rtr 1 state Down->Up ( I typed no shutdown command on R2 on primary interface)
    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    C       1.1.1.1 is directly connected, Loopback0
         2.0.0.0/32 is subnetted, 1 subnets
    S       2.2.2.2 [1/0] via 192.168.0.2 primary link is automatically installed because of better AD
    C    192.168.0.0/24 is directly connected, FastEthernet0/0
    C    192.168.1.0/24 is directly connected, Serial1/0
    [:D]

     

  • if you can ping the interface the entire subnet is connected to then yes. But lets say you have a subnet 192.168.0.0/24 is reachable via R1 if want to see you can reach R1 then fine you can do that, but if  R1 divides the network into /26 networks and assigns it to 4 different interfaces, then in the later case you have to ping the address on each interface individually to track their reachability.

     

     

    I hope i made some sense

  • ashse,
    I am not sure but ip sla accepted the subnet address as well:

    ip sla monitor 3

    type echo protocol ipIcmpEcho 192.168.2.0 source-ipaddr 192.168.1.1

    timeout 200

    frequency 5

    But one question, is there any benefit of tracking whole subnet because if one hode failed from that subnet, it might affect your entire routing!!!![:@]

     

     

  • Set up:

     

    Host |----R1------------------------------R3----  |Host

    Host |                                                         |Host

    Host |-----R2------------------------------R4----|Host

    Need:

    Load balancing and redundancy on R1 and R2

    for load balancing- two static routes (wo AD) pointing to two physical IPs (R3 and R4 resp.)

    for redundancy- IP SLA

    Result:

    Load balancing happening

    How ever load balancing fails with IP SLA

     

    We can avoid giving subnet address and can echo LAN interface of R3 and R4 but Host behind R1 and R2 fails to ping LAN IPs of R3 and R4 after tracking

    Any advice would be much appreciated

    Thnx

  • just check you rib or  any kind of acl in use. if you can ping with simple static route in place ip sla should work. it is same just with a tracker installed :D 

  • nnn,

    I changed the configs as below, but its still not working. Pls chk and advice:

    R1(config)#do sh run | s ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 10.10.24.1
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 1 life forever start-time now

    R1(config)#do sh run | s track
    track 123 rtr 1 reachability

    R1(config)#do sh run | s ip route
    ip route 10.10.24.0 255.255.255.0 157.126.144.65 track 123
    ip route 10.10.24.0 255.255.255.0 157.126.144.66 11

    -----------------------------------------------------------------------------

    R2(config)#do sh run | s ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 10.10.24.2
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 1 life forever start-time now

    R2(config)#do sh run | i track
    track 123 rtr 1 reachability

    R2(config)#do sh run | i ip route
    ip route 10.10.24.0 255.255.255.0 157.126.144.66 track 123
    ip route 10.10.24.0 255.255.255.0 157.126.144.65 11
    ------------------------------------------------------------------------------

     

  • There is no ACL, and its all static routes. On R1 and R2 two static routes as mentioned above.

  • you did mistake on link selection.

    You are configuring primary link to 65 on R1 and 66 to R2, is this your intention?

    That means ur packets are going through 65 and returning back from 66, if one link down, packet couldn't come back!!!

    Can you change it?

     

  • yes, for R1 .65 is primary and .66 is backup and vice versa for R2

  • ashse,

     

    I tried, working fine to me.

    See here:

    R1#show running-config | section ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.2 source-ipaddr 192.168.0.1
     timeout 200
     frequency 5
    ip sla monitor schedule 1 life forever start-time now

    !

    R1#show run
    R1#show running-config | in ip route
    ip route 2.2.2.2 255.255.255.255 192.168.0.2 track 1
    ip route 2.2.2.2 255.255.255.255 192.168.1.2 11
    R1#
    !

    R2#show running-config | section ip sla
    R2#show running-config | section ip sla
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.1.1 source-ipaddr 192.168.1.2
     timeout 200
     frequency 5
    ip sla monitor schedule 2 life forever start-time now
    !

    R2#show running-config | in ip route
    ip route 1.1.1.1 255.255.255.255 192.168.1.1 track 2
    ip route 1.1.1.1 255.255.255.255 192.168.0.1 11

    R2#traceroute 1.1.1.1 so 2.2.2.2

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

      1 192.168.1.1 84 msec *  40 msec
    !

    R2#
    *Mar  1 03:06:09.063: %TRACKING-5-STATE: 2 rtr 2 state Up->Down

    !

    R2#traceroute 1.1.1.1 so 2.2.2.2

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

      1 192.168.0.1 52 msec *  52 msec

    R1#traceroute 2.2.2.2 so 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 2.2.2.2

      1 192.168.0.2 56 msec

    [:D]

     

  • Hi ashse,

       I see your problem but i don't understand your topology (it needs to work, i need your complete topology and config to see the cause). If you need to track a subnet, don't ICMP echo to the subnet address, this is not the way. Use "track x ip route a.a.a.a/b reachability" to track if a subnet exists in the routing table. However for your case, as you are using static routes with tracking to populate routing table, it will not help.

    Good luck with your studies!

  • nnn,

    is it possible you can check my configs over Team viewer and discuss over skype.

    My skype id ashlga, Ashish Sehgal, Bangalore, India

  • Hi Cristian,

    Many thanks for your kind attention. I am ready to send you topology and complete configs. Kindly share your mail id etc to send you the same.

    Thanks again,

     

  • nnn,

    Static routes as given by you will not help me to achieve load balancing. Can you please try using two ip sla monitor (1 and 2) and two static routes with separate track values.

  • Hello ashse,

     

    Here is final configuration and verification:

    R1#show running-config interface fastEthernet 1/0
    Building configuration...

    Current configuration : 152 bytes
    !
    interface FastEthernet1/0
     description "Primary Link"
     ip address 192.168.0.1 255.255.255.0
     ip load-sharing per-packet
     duplex auto
     speed auto
    end
    !

    R1#show running-config interface serial 0/0
    Building configuration...

    Current configuration : 147 bytes
    !
    interface Serial0/0
     description "Secondary Link"
     ip address 192.168.1.1 255.255.255.0
     ip load-sharing per-packet
     serial restart-delay 0
    end

    LO0 1.1.1.1

    R2#show running-config interface fastEthernet 1/0
    Building configuration...

    Current configuration : 152 bytes
    !
    interface FastEthernet1/0
     description "Primary Link"
     ip address 192.168.0.2 255.255.255.0
     ip load-sharing per-packet
     duplex auto
     speed auto
    end
    !

    R2#show running-config interface fastEthernet 1/0
    Building configuration...

    Current configuration : 152 bytes
    !
    interface FastEthernet1/0
     description "Primary Link"
     ip address 192.168.0.2 255.255.255.0
     ip load-sharing per-packet
     duplex auto
     speed auto
    end

    LO0: 2.2.2.2

    R1 SLA configuration:

    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.2 source-ipaddr 192.168.0.1
     timeout 200
     frequency 5
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.1.2 source-ipaddr 192.168.1.1
     timeout 200
     frequency 5
    ip sla monitor schedule 2 life forever start-time now

    track 1 rtr 1

    track 2 rtr 2

     

    R2 SLA Configuration:

    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.1 source-ipaddr 192.168.0.2
     timeout 200
     frequency 5
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.1.1 source-ipaddr 192.168.1.2
     timeout 200
     frequency 5
    ip sla monitor schedule 2 life forever start-time now
    !

    track 1 rtr 1

    track 2 rtr 2

    !

    R1#show ip sla monitor statistics
    Round trip time (RTT)   Index 1
            Latest RTT: 32 ms
    Latest operation start time: *00:18:57.667 UTC Fri Mar 1 2002
    Latest operation return code: OK
    Number of successes: 106
    Number of failures: 4
    Operation time to live: Forever

    Round trip time (RTT)   Index 2
            Latest RTT: 76 ms
    Latest operation start time: *00:18:58.803 UTC Fri Mar 1 2002
    Latest operation return code: OK
    Number of successes: 100
    Number of failures: 0
    Operation time to live: Forever

    R2#show ip sla monitor statistics
    Round trip time (RTT)   Index 1
            Latest RTT: 36 ms
    Latest operation start time: *00:17:56.387 UTC Fri Mar 1 2002
    Latest operation return code: OK
    Number of successes: 72
    Number of failures: 1
    Operation time to live: Forever

    Round trip time (RTT)   Index 2
            Latest RTT: 44 ms
    Latest operation start time: *00:17:57.851 UTC Fri Mar 1 2002
    Latest operation return code: OK
    Number of successes: 73
    Number of failures: 0
    Operation time to live: Forever

    Static Route with object tracking

    R1#show running-config | in ip route
    ip route 2.2.2.2 255.255.255.255 192.168.0.2 track 1
    ip route 2.2.2.2 255.255.255.255 192.168.1.2 track 2
    !

    R2#show running-config | in ip route
    ip route 1.1.1.1 255.255.255.255 192.168.0.1 track 1
    ip route 1.1.1.1 255.255.255.255 192.168.1.1 track 2

    !

    Routing is load balancing

    R2#traceroute 1.1.1.1 source 2.2.2.2

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

      1 192.168.1.1 44 msec
        192.168.0.1 68 msec *

    R1#traceroute 2.2.2.2 so 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 2.2.2.2

      1 192.168.0.2 24 msec
        192.168.1.2 96 msec

    When SLA timeout

    *Mar  1 00:21:43.951: %TRACKING-5-STATE: 1 rtr 1 state Up->Down
    R1#
    R1#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    C       1.1.1.1 is directly connected, Loopback0
         2.0.0.0/32 is subnetted, 1 subnets
    S       2.2.2.2 [1/0] via 192.168.1.2
    C    192.168.0.0/24 is directly connected, FastEthernet1/0
    C    192.168.1.0/24 is directly connected, Serial0/0

    R1#traceroute 2.2.2.2 so 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 2.2.2.2

      1 192.168.1.2 52 msec *  60 msec
    !

    R2#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    S       1.1.1.1 [1/0] via 192.168.1.1
         2.0.0.0/32 is subnetted, 1 subnets
    C       2.2.2.2 is directly connected, Loopback0
    C    192.168.1.0/24 is directly connected, Serial0/0
    !

    R2#traceroute 1.1.1.1 source 2.2.2.2

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

      1 192.168.1.1 60 msec *  28 msec

    When link is up

    R1#
    *Mar  1 00:28:13.951: %TRACKING-5-STATE: 1 rtr 1 state Down->Up
    R1#traceroute 2.2.2.2 so 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 2.2.2.2

      1 192.168.1.2 60 msec
        192.168.0.2 56 msec

    Still if you any queries, let me know.

    HAPPY STUDY FRIENDS

    [:D]

  • I think nnn solution answers your query; if not feel free to post here what i've requested, it will reach me anyways.

    Good luck with your studies!

  • nnn,

    Is there any specific reason for configuring "ip load-sharing per-packet" on interfaces. Dont you think, we should let CEF to perform 'per-destination based load sharing".

    In between I am checking to find discrepencies in my configuration w.r.t yours.

    Many Thanks for your contribution

  • frndz, pls find the configs:

    R1#sh run int e0/0
    Building configuration...

    Current configuration : 78 bytes
    !
    interface Ethernet0/0
     ip address 10.1.12.1 255.255.255.0
     half-duplex
    end

    R1#sh run int e0/1
    Building configuration...

    Current configuration : 103 bytes
    !
    interface Ethernet0/1
     ip address 192.168.0.1 255.255.255.0
     half-duplex
    end

    R1#sh run | s ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.3 source-ipaddr 192.168.0.1
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.0.4 source-ipaddr 192.168.0.1
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 2 life forever start-time now
    R1#
    R1#sh run | s track
    track 1 rtr 1 reachability
    track 2 rtr 2 reachability
    ip route 20.1.34.0 255.255.255.0 192.168.0.3 track 1
    ip route 20.1.34.0 255.255.255.0 192.168.0.4 track 2

    ---------------------------------------------------------------------------------

    R2#sh run int e0/0
    Building configuration...

    Current configuration : 78 bytes
    !
    interface Ethernet0/0
     ip address 10.1.12.2 255.255.255.0
     half-duplex
    end

    R2#sh run int e0/1
    Building configuration...

    Current configuration : 80 bytes
    !
    interface Ethernet0/1
     ip address 192.168.0.2 255.255.255.0
     half-duplex
    end

    R2#sh run | s ip sla
    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.4 source-ipaddr 192.168.0.2
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.0.3 source-ipaddr 192.168.0.2
     timeout 1000
     threshold 2
     frequency 3
    ip sla monitor schedule 2 life forever start-time now
    R2#sh run | s track
    track 1 rtr 1 reachability
    track 2 rtr 2 reachability
    ip route 20.1.34.0 255.255.255.0 192.168.0.4 track 1
    ip route 20.1.34.0 255.255.255.0 192.168.0.3 track 2

    -------------------------------------------------------------------------------

    R3 n R4 opposite peers:

    R3#sh run int e0/0
    Building configuration...

    Current configuration : 78 bytes
    !
    interface Ethernet0/0
     ip address 20.1.34.1 255.255.255.0
     half-duplex
    end

    R3#sh run int e0/1
    Building configuration...

    Current configuration : 80 bytes
    !
    interface Ethernet0/1
     ip address 192.168.0.3 255.255.255.0
     half-duplex
    end

    R3#sh run | i ip route
    ip route 10.1.12.0 255.255.255.0 192.168.0.1
    ip route 10.1.12.0 255.255.255.0 192.168.0.2

    -----------------------------------------------------------------

    R4#sh run int e0/0
    Building configuration...

    Current configuration : 78 bytes
    !
    interface Ethernet0/0
     ip address 20.1.34.2 255.255.255.0
     half-duplex
    end

    R4#sh run int e0/1
    Building configuration...

    Current configuration : 90 bytes
    !
    interface Ethernet0/1
     ip address 192.168.0.4 255.255.255.0
     half-duplex
    end

    R4#sh run | i ip route
    ip route 10.1.12.0 255.255.255.0 192.168.0.2
    ip route 10.1.12.0 255.255.255.0 192.168.0.1

    =======================================

    Issue:

    Auto-failover not happening when R3-e0/1 or R4-e0/1 shuts down

    ========================================

     

  • ashse,

     


    Per-destination is default CEF load-sharing method.  if you are running on per-packet and want to switch to per-destination use

    int <intname>

    ip load-sharing per-destination

    [:D]

  • What is the SLA status when you shut those interfaces down? Do the tracked routes still show up in configuration?

    Good luck with your studies!

  • Hello ashse,

     

    I tried to simulate your topology, it's working fine in my side. I tried to paste the GNS topology as well but it went to moderator to confirm. I managed routing using static and RIP. But don't know you are maintaining your routinn. I have one-one end host on each side that's why I configured per-packet load-balancing.

    Here is the configuration and verification

    R2#

    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.4 source-ipaddr 192.168.0.2
     timeout 200
     frequency 5
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.0.5 source-ipaddr 192.168.0.2
     timeout 200
     frequency 5
    ip sla monitor schedule 2 life forever start-time now

    track 1 rtr 1

    track 2 rtr 2

    R3#

    ip sla monitor 1
     type echo protocol ipIcmpEcho 192.168.0.4 source-ipaddr 192.168.0.3
     timeout 200
     frequency 5
    ip sla monitor schedule 1 life forever start-time now
    ip sla monitor 2
     type echo protocol ipIcmpEcho 192.168.0.5 source-ipaddr 192.168.0.3
     timeout 200
     frequency 5
    ip sla monitor schedule 2 life forever start-time now
    !
    track 1 rtr 1

    track 2 rtr 2

     

    R1#traceroute 6.6.6.6
    Type escape sequence to abort.
    Tracing the route to 6.6.6.6

      1 192.168.123.2 60 msec
        192.168.123.3 76 msec
        192.168.123.2 24 msec
      2 192.168.0.5 64 msec 36 msec
        192.168.0.4 24 msec
      3 192.168.45.6 92 msec *  132 msec
    !
    R6#traceroute 1.1.1.1

    Type escape sequence to abort.
    Tracing the route to 1.1.1.1

      1 192.168.45.4 48 msec
        192.168.45.5 40 msec
        192.168.45.4 16 msec
      2 192.168.0.3 28 msec 56 msec
        192.168.0.2 60 msec
      3 192.168.123.1 76 msec *  96 msec

    R3#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    C    192.168.123.0/24 is directly connected, FastEthernet0/0
         1.0.0.0/32 is subnetted, 1 subnets
    S       1.1.1.1 [1/0] via 192.168.123.1
    R    192.168.45.0/24 [120/1] via 192.168.0.5, 00:01:08, FastEthernet1/0
                         [120/1] via 192.168.0.4, 00:00:07, FastEthernet1/0
    C    192.168.0.0/24 is directly connected, FastEthernet1/0


    R5(config-if)#shutdown
    R5(config-if)#
    *Mar  1 00:31:13.135: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
    *Mar  1 00:31:14.135: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down


    R3(config-track)#
    *Mar  1 00:31:02.991: %TRACKING-5-STATE: 2 rtr 2 state Up->Down
    !
    R3(config-track)#do show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    C    192.168.123.0/24 is directly connected, FastEthernet0/0
         1.0.0.0/32 is subnetted, 1 subnets
    S       1.1.1.1 [1/0] via 192.168.123.1
    R    192.168.45.0/24 [120/1] via 192.168.0.4, 00:00:19, FastEthernet1/0
         6.0.0.0/32 is subnetted, 1 subnets
    S       6.6.6.6 [1/0] via 192.168.0.4
    C    192.168.0.0/24 is directly connected, FastEthernet1/0

    R2(config)#
    *Mar  1 00:31:15.555: %TRACKING-5-STATE: 2 rtr 2 state Up->Down

    R2(config)#do show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    C    192.168.123.0/24 is directly connected, FastEthernet0/0
         1.0.0.0/32 is subnetted, 1 subnets
    S       1.1.1.1 [1/0] via 192.168.123.1
    R    192.168.45.0/24 [120/1] via 192.168.0.4, 00:00:10, FastEthernet1/0
         6.0.0.0/32 is subnetted, 1 subnets
    S       6.6.6.6 [1/0] via 192.168.0.4
    C    192.168.0.0/24 is directly connected, FastEthernet1/0

    !
    R1#traceroute 6.6.6.6
    Type escape sequence to abort.
    Tracing the route to 6.6.6.6
      1 192.168.123.3 56 msec
        192.168.123.2 48 msec
        192.168.123.3 40 msec
      2 192.168.0.4 56 msec 44 msec 52 msec
      3 192.168.45.6 40 msec *  88 msec

    HAPPY STUDY.

    [:D]

  • nnn,

    Many thnaks for your advice. I could see that you configured RIP for IP routing, could you pls try to execute the same lab using static routes. Pls check the below static route entries:

    R3

    ip route 192.168.45.0 255.255.255.0 192.168.123.4 track 1

    ip route 192.168.45.0 255.255.255.0 192.168.123.5 track 2


    R2

    ip route 192.168.45.0 255.255.255.0 192.168.123.4 track 1

    ip route 192.168.45.0 255.255.255.0 192.168.123.5 track 2

  • nnn,

    I could successfully run IP SLA using RIP and OSPF, but the same fails on static routing.  I beleive timeout and threshold values are responsible to some extent.

    Would appreciate if you can have a look at them:


    R2#sh run | s ip sla

    ip sla monitor 1

     type echo protocol ipIcmpEcho 192.168.0.4 source-ipaddr 192.168.0.2

     timeout 1000

     threshold 2

     frequency 3

    ip sla monitor schedule 1 life forever start-time now

    ip sla monitor 2

     type echo protocol ipIcmpEcho 192.168.0.5 source-ipaddr 192.168.0.2

     timeout 1000

     threshold 2

     frequency 3

    ip sla monitor schedule 2 life forever start-time now

     


    R2#sh run | s track 

    track 1 rtr 1

    track 2 rtr 2

    ip route 192.168.45.0 255.255.255.0 192.168.0.4 track 1

    ip route 192.168.45.0 255.255.255.0 192.168.0.5 track 2

     

  • Ashse,

       I've asked you before; when your tracking object 1 is down, does the static route remain in the routing table?

    Good luck with your studies!

  • Cristian,

    Last time when I checked it was no more. But am surprised to see it now. pls check. I beleive it should not be


    R2#sh ip route 192.168.45.0

    Routing entry for 192.168.45.0/24

      Known via "static", distance 1, metric 0

      Routing Descriptor Blocks:

        192.168.0.5

          Route metric is 0, traffic share count is 1

      * 192.168.0.4

          Route metric is 0, traffic share count is 1

  • What is your SLA status for both objects? Can you post it here?

    Good luck with your studies!

  • Ashse,

     

    Can you post the output of:

    show ip sla monitor statistics
    show ip sla monitor collection-statistics

    and show ip route (when your one link fails)

     

    [:D]

    Cristian,

    Last time when I checked it was no more. But am surprised to see it now. pls check. I beleive it should not be

     

    R2#sh ip route 192.168.45.0

    Routing entry for 192.168.45.0/24

      Known via "static", distance 1, metric 0

      Routing Descriptor Blocks:

        192.168.0.5

          Route metric is 0, traffic share count is 1

      * 192.168.0.4

          Route metric is 0, traffic share count is 1

     

     

  • nnn, here we go..


    R2#show ip sla monitor statistics

    Round trip time (RTT)   Index 1

            Latest RTT: 15 ms

    Latest operation start time: *00:16:27.003 UTC Fri Mar 1 2002

    Latest operation return code: Over threshold

    Number of successes: 0

    Number of failures: 194

    Operation time to live: Forever

     

    Round trip time (RTT)   Index 2

            Latest RTT: 44 ms

    Latest operation start time: *00:16:28.467 UTC Fri Mar 1 2002

    Latest operation return code: Over threshold

    Number of successes: 0

    Number of failures: 194

    Operation time to live: Forever

     

     

    R2#show ip sla monitor collection-statistics

    Entry number: 1

    Start Time Index: *00:10:02.003 UTC Fri Mar 1 2002

    Number of successful operations: 0

    Number of operations over threshold: 200

    Number of failed operations due to a Disconnect: 0

    Number of failed operations due to a Timeout: 1

    Number of failed operations due to a Busy: 0

    Number of failed operations due to a No Connection: 0

    Number of failed operations due to an Internal Error: 0

    Number of failed operations due to a Sequence Error: 0

    Number of failed operations due to a Verify Error: 0

    RTT Values:

    RTTAvg: 28      RTTMin: 8       RTTMax: 79

    NumOfRTT: 200   RTTSum: 5715    RTTSum2: 190075

     

     

    Entry number: 2

    Start Time Index: *00:10:03.471 UTC Fri Mar 1 2002

    Number of successful operations: 0

    Number of operations over threshold: 200

    Number of failed operations due to a Disconnect: 0

    Number of failed operations due to a Timeout: 1

    Number of failed operations due to a Busy: 0

    Number of failed operations due to a No Connection: 0

    Number of failed operations due to an Internal Error: 0

    Number of failed operations due to a Sequence Error: 0

    Number of failed operations due to a Verify Error: 0

    RTT Values:

    RTTAvg: 32      RTTMin: 12      RTTMax: 80

    NumOfRTT: 201   RTTSum: 6627    RTTSum2: 244257

     

    When R4-int e0/1- shut


    R4(config)#int e0/1

    R4(config-if)#shut

     


    R2#sh ip route 192.168.45.0

    Routing entry for 192.168.45.0/24

      Known via "static", distance 1, metric 0

      Routing Descriptor Blocks:

      * 192.168.0.5

          Route metric is 0, traffic share count is 1

     

    I realise "reachability" is an important keyword in the track command. Due to which both the routes were missing.


    track 1 rtr 1 reachability

    track 2 rtr 2 reachability

     

    Feel free if you need any other output

     

Sign In or Register to comment.