config 6PE on Dynamips

Hi bros, i wanna ask you question about testing 6PE on Dynamips

The fact is i have tested alot but can not make it worked, there are 2 stuff
- on PE, the next-hop = :FFFF[ipv4 of neighbor] is inaccessible. I got that, i have made the label distributed but i not worked

- on PE, the debug BGP update display "no valid path..."

the v4 and v6 CEF is enabled, the MB-BGP is activated well with "send-label" and redistribute...

i even mimic a template config in case of if something might be wrong ? But it still the same problem !

 

>> then i think it's Dynamips might be the cause, but i got in Blog of Ivan someone said they successfully tested on Dynamips !

Is there anyone here make it worked, and can you tell me what router and IOS you haved used, 'cuz someone in CLN also said the issue might be fixed with Router 7200 ?

Comments

  • Hi Fuego,

    I have 6PE working fine on Dynamips using 3725s with c3725-adventerprisek9-mz.124-15.T14.bin

    Here is a fairly detailed example of how I put it together http://noshut.blogspot.com/2011/05/ipv6-over-mpls-6pe.html

    Unless its a particular IOS version perhaps something is missing from your config?

  • Adam, if that's your blog, then i absolutely started testing this 6PE based on your post :))

    First i used different IGP between CE-PE, i made peering MP-BGP between 2 PE instead of PE-P-PE with route-reflector,... some small diference. But finally i mimiced them all. I stuck in next-hop inaccessible no matter what

    I have used this IOS c3725-adventerprisek9-mz.124-15.T8.bin

    Ok thanks, i ask for verification, and your answer is perfect :)

  • Hi Feugo,

    Yep that's my blog (nice to know that there are some readers! [;)])- I did double check it again just before I posted in this foum just case I did something wrong and to confirm the platform and IOS version.  Originally I was missing "ipv6 unicast-routing on the RR which needed that purely to enable the ipv6 unicast address family even though there was no IPv6 addressing or IPv6 IGP in use on that node.

    Cheers,

    Adam

  • I tried, working fine!!!

    R1#ping FEC0:78::8

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to FEC0:78::8, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 48/109/152 ms
    R1#show ipv6 int brief
    FastEthernet0/0            [up/up]
        FE80::4
        FEC0:45::4
    FastEthernet0/1            [administratively down/down]
    Loopback0                  [up/up]
        FE80::C000:1FFF:FE90:0
        FEC0::4

    !

    R5#show ipv6 interface brief
    FastEthernet0/0            [up/up]
        FE80::8
        FEC0:78::8
    FastEthernet0/1            [administratively down/down]
    Loopback0                  [up/up]
        FE80::C004:1FFF:FEC4:0
        FEC0::8
    R5#ping FEC0:45::4

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to FEC0:45::4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 76/135/208 ms

     

  • just make it work, thanks all bros, some note if you mind (actually i did not make it 100% similar to you Adam)

    i began config loopback of PE with /24 and advertise to OSPF in MPLS core
    i don't remember which difference with my last failure, but this time no more inaccessible, miracle >.<

    but i can not ping ! Though prefix updated as >* (valid, best)
    the popular case as P router have in LFIB the PE's loopback as /32 route
    i try "ip ospf network point-to-point" on PE loopback, the LFIB update as /24, make sense
    But this time it back the issue "inaccessible"

    I reconfig the loopback into /32 and it work very well 

    One more times, thanks all bros 

Sign In or Register to comment.