New to Voice track Module 01:Option 66, phone MAC addresses, CUCM Startup configs

Had my first VORACK session doing Deep Dive Vol I Module 01:

1. The CUCM Startup config obviously has different mac addresses from the actual rack; in my case VORACK4.

In Module 01, I wanted to verify that the phones actually register to the CUCM although the module is focused on infrastructure (DHCP etc). Were you supposed to

A. Turn on auto-registration

B. Edit phone in CUCM->Devices

C. Prepare a CSV file and upload in "Bulk Administration"

2. Phones on BR1, BR2 getting DHCP from CUCM registered perfectly. Phones on Corp HQ kept going through the DHCP cycle. When I tested with CUCM as DHCP server it worked fine. When sw1 was the DHCP server (address range, default router, Option 150, Option 66 all looked corrected) I saw attempted connections to CUCM Pub on ports 69,2000. But the phone wouldn't register and restarted the DHCP cycle. Same thing when I used r1 as the DHCP server - then my rack timed out [:'(]

3. I turned on auto-registration, deleted all the pre-existing phones: in the end I was only able to see BR1, BR2 phones in CUCM but CorpHQ registration failed.

4. Also, Mark in the solution video mentions Option 66; but this was not in my Final Configs

5. Final Configs also did not include the AutoQoS service policy under interface f0/2: is this the behaviour of AutoQoS: the service-policy appears in the running config but not in the saved config? int fa0/2 does have the 'auto qos voip cisco-phone' configured under it, though.

Comments

  • Mustang;

         This is probably a stupid question, but have you verified that DHCP option 150 is pointing to the correct TFTP servers (sub/pub)?

         I do not know what video you are referring to, but option 66 is not needed for any phone registration that I know of.  For my labs, I have (2) global DHCP options, which are domain-name completion and 150 (TFTP server address).

         On your final config question, autoqos generates a lot of other code for you, including the service policies.  When I am doing my labs at home, I use the range command on the switch and apply it to all interfaces.

  • Re: switch DHCP issues

    I'm pretty sure I got the tftp server settings correct; I cut-n-paste from the Final config; I just could not get the phone to register; it went into DHCP freak-out.

    (i.e., requesting and receiving DHCP information, then within one minute request again, repeat ad infinitum) When I set R1 as ip helper, and made PUB the tftp server, the phones registered successfully.

    OTH, the PSTN phone (same switch, different subnet assignment - vlan 13) registered successfully to the pstn router (CME 4.1) as the DHCP binding remained stable (lease 1 day).

    I'll need to redo this task - fortunately Graded issued a token refund that session because I was having VPN-less connectivity issues.

     

    Re: Graded VORACK

    [OT] - do you folks ever get the "Authentication Expired" message using VPN-less access, even though telnet is working fine?

     

    Re: option 66: I was looking at the solution video; the task mentions that the DHCP server may be given out by domain name in the future and that the configuration must take this into account. The solution video suggested option 66 as a way to deliver the domain name of the tftp server; however the final config did not include it.

     

     

  • Mustang;

         If I read what you are saying correctly, you took the HQ voice vlan, changed the ip helper to R1 and it worked?  Did you create a scope for the HQ phones on R1?  If that is the case, this looks to me as if it is pointing to the DHCP server that was the original ip helper.  Were you pointing to the PUB for DHCP on the vlan?

         Also, in reference to your option 66 solution, I would use caution there, because many PC's use 60/66 for PXE boot environments for boot time imaging.  While I know that our phones SHOULD be in a seperate VLAN, may server administrators use server global options for these settings, along with DNS servers, domain name completion suffixes, etc..  Just my $0.02.  :-)

  • You should also install an app that would allow you to track kids phone. This is a necessary measure!

Sign In or Register to comment.