Sending Extended communities in IOS XR

Hi Guys

When we create a vpnv4 peering between 2 ebgp peers in IOS, we use the following command

address-family vpnv4

neighor *.*.*.* send-community exended

 

However, i am not certain how we do that in IOS XR. I realise that by default IOS XR does NOT send extended communities to ebgp peers so how do we do it? The only way i can see it if we enable the peer under the ipv4 family where the following command is present and then simply enable the peer under vpnv4 address family.

Is the config below correct if i wish to send extended communities to an ebgp peer? Is there another way of doing it?

router bgp 1
 neighbor 10.1.1.2
  address-family ipv4 unicast
   send-extended-community-ebgp

 address-family vpnv4 unicast

Comments

  • If you want to send extended communities for AF/SAFI IPv4 unicast, the configuration is correct.

    You don't need to do it for AF/SAFI vpnv4 unicast, i.e., to configure the BGP Core of a MPLS L3VPN.


    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.7/mpls/configuration/guide/gc37v3.html#wp1167223

     

    Cheers, Gustavo 

  • Hi

    I am trying to send extended communities under vpnv4 ebgp peering session. My understanding is that ibgp vpnv4 automatically send extended comms but ebgp vpnv4 dont so if the above config is correct, then it doesnt make sense to me.

    If you are going for inter AS option C, then you will also need to have a peering session under ipv4 which isnt required under IOS. Can someone please shed some light on this? I am def missing something here.

     

    Faraz

  • Hi,

     

    For ebgp inter-as vpn, you should enable this capability for address-family vpnv4:


    router bgp 1
     neighbor 10.1.1.2

     address-family vpnv4 unicast

       send-extended-community-ebgp

  • Sorry.

    Just noticed that this command is not supported on AF VPNv4.

    You are saying that this capability is not negotiated between eBGP neighbors under AF VPNv4?

    Thanks

  • I just tried VPNv4 option B and extended communities are exchanged. I was under the impression that you would need to allow it first but apparantly not. It appears that if you enable a peer under vpnv4 peering session, then ext-communities are exchanged automatically. If anyone thinks otherwise, please do put your point forward.

     

    I am pasting basic config between 2 routers.

     

    Below router 1 is redistributing connected loopback interfaces (4.4.4.4/32 & 5.5.5.5/32)

    Router 1

    router bgp 1

     address-family vpnv4 unicast
     !
     neighbor x.x.x.x
      remote-as 2
      ebgp-multihop 2
      update-source Loopback0
      address-family vpnv4 unicast
       route-policy ALLOW in
       route-policy ext-com out
      !
     !
     vrf vpn
      rd 1:1
      address-family ipv4 unicast
       redistribute connected

     

    Router 2

    router bgp 2
     address-family ipv4 unicast
     !
     address-family vpnv4 unicast
     !
     neighbor x.x.x.x
      remote-as 1
      ebgp-multihop 2
      update-source Loopback0
      address-family vpnv4 unicast
       route-policy ALLOW in
       route-policy ALLOW out
      !
     !
     vrf vpn
      rd 1:1
      address-family ipv4 unicast
       redistribute connected

     

     

    Output from R2

    RP/0/RSP0/CPU0:ASR9K-P02#sh bgp vpnv4 unicast vrf vpn 4.4.4.4
    Fri Jul  8 16:56:03.638 BST
    BGP routing table entry for 4.4.4.4/32, Route Distinguisher: 1:1
    Versions:
      Process           bRIB/RIB  SendTblVer
      Speaker                  8           8
        Local Label: 16061
    Last Modified: Jul  8 16:41:00.162 for 00:15:03
    Paths: (1 available, best #1)
      Not advertised to any peer
      Path #1: Received by speaker 0
      Not advertised to any peer
      1
        x.x.x.x (metric 310) from x.x.x.x (3.3.3.3)
          Received Label 143986
          Origin incomplete, metric 0, localpref 100, valid, external, best, group-best, import-candidate, imported
          Received Path ID 0, Local Path ID 1, version 8
          Extended community: RT:1:1 RT:333:333 --> set by Router 1

     

     

Sign In or Register to comment.