task 2.10 BGP Aggregation

Hello

 

I suggest that there is mistake in the solution guide or in task definition

Task define that we should advertise aggregated internal network space to our peer, but we can't advertise 150.1.0.0/20 aggregate and advertise to anyone until this prefix is not seen in BGP table and it doesn't seen thare.

What is the correct solution for this task

insert Loopback network space into bgp

router bgp 100/200

network 150.1.x.0 mask 255.255.255.0

or

route-map CONNECTED->BGP permit 10
 match interface Loopback0

 

router bgp 100/200
 redistribute connected route-map CONNECTED->BGP

 

+ additionaly edit AGGREGATE prefix-list to

ip prefix-list  AGGREGATE seq 10 permit 150.1.0.0/20 le 32

Please comments

Best regards

Comments

  • Hi there

     

    I agree, the SG not complete as Loopback range not in BGP table...thus agree with your two options, i"ve tested both but had to filter the more specific Lo0 prefix out towards the BB devices....see extract from my R6 device

     


    router bgp 100

     no synchronization

     bgp router-id 150.11.6.6

     bgp log-neighbor-changes

     aggregate-address 150.11.0.0 255.255.0.0

     aggregate-address 129.11.0.0 255.255.0.0

     redistribute connected route-map CON

     neighbor 54.11.1.254 remote-as 54

     neighbor 54.11.1.254 route-map LOOP out

     neighbor 129.11.46.4 remote-as 100

     neighbor 129.11.46.4 next-hop-self

     neighbor 129.11.46.4 route-map AGGR out

     no auto-summary

    access-list 21 permit 129.11.0.0

    access-list 21 permit 150.11.0.0

    access-list 21 permit 150.11.6.6

    access-list 60 permit 150.11.6.6

    route-map AGGR deny 10

     match ip address 21

    route-map AGGR permit 20

    route-map LOOP deny 10

     match ip address 60

    route-map LOOP permit 99

    route-map CON permit 10

     match interface Loopback0



    kr

    Josua

  • the SG not complete as Loopback range not in BGP table...thus agree with your two options, i"ve tested both but had to filter the more specific Lo0 prefix out towards the BB devices....see extract from my R6 device

    Thats true, SG has missed this part of the solution. We have to somehow advertise the 150.X.0.0/24 network into the BGP table in order to generate an aggregate.

  • the SG not complete as Loopback range not in BGP table...thus agree with your two options, i"ve tested both but had to filter the more specific Lo0 prefix out towards the BB devices....see extract from my R6 device

    Thats true, SG has missed this part of the solution. We have to somehow advertise the 150.X.0.0/24 network into the BGP table in order to generate an aggregate.

    Almost a year since this was first reported and no fix :(

Sign In or Register to comment.