Transcoder issue

Hai ,

 

I have registered my transcoder to cme but  when i try to check for music-on -hold its not using the transcoder .cme  uses g711 to stream the moh file its not transcoded

 

Even though i tried to use software CFB ,to l trancode g711 steam to g729 .Thats not happening for my phones which are using g729r8 codec

Here is my configuration. am i missing something or my concept is wrong somewhere .

How can i see transcoding sessions active for moh and conferencing ?

Your reply will be highly appreciated .

 

 

voice-card 0
 no dspfarm
 dsp services dspfarm
!
!
!
!
!

!
interface GigabitEthernet0/0
 ip address 10.1.1.101 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
 ntp disable
!
interface Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/1
 ip address 20.1.1.101 255.255.255.0
 duplex auto
 speed auto
!

!
ip forward-protocol nd
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!

!
control-plane
!
!
!
voice-port 0/3/0:15
!
!
!
sccp local Vlan10
sccp ccm 177.3.11.1 identifier 1 priority 1 version 6.0
sccp
!
sccp ccm group 1
 bind interface Vlan10
 associate ccm 1 priority 1
 associate profile 2 register transcoder
 associate profile 1 register HW_CFB
!
dspfarm profile 2 transcode 
 codec g729br8
 codec g729r8
 codec g729ar8
 codec g729abr8
 maximum sessions 4
 associate application SCCP
!
dspfarm profile 1 conference 
 codec g729r8
 codec g729br8
 codec g729ar8
 codec g729abr8
 maximum sessions 1
 conference-join custom-cptone JOIN-TONE
 conference-leave custom-cptone Leave-only
 associate application SCCP
 
!
!

!
!
telephony-service
 sdspfarm conference mute-on **1 mute-off **2
 sdspfarm units 5
 sdspfarm transcode sessions 4

 sdspfarm tag 1 HW_CFB

 sdspfarm tag 2 transcoder

 conference hardware
 no auto-reg-ephone
 load 7960-7940 P00308010200
 load 7961 SCCP41.8-4-2S
 max-ephones 2
 max-dn 50
 ip source-address 177.3.11.1 port 2000
 system message Ha Ha Ha Ha Ha
 cnf-file location flash:
 cnf-file perphone
 time-zone 20
 time-format 24
 date-format yy-dd-mm
 dialplan-pattern 1 21313... extension-length 4


 max-conferences 8 gain -6
 call-forward pattern .T
 moh music-on-hold.au
 multicast moh 239.1.1.4 port 16384
 web admin system name admin password cisco
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern .T
 secondary-dialtone 9
 login timeout 60 clear 23:00
  create cnf-files version-stamp 7960 Jun 15 2011 07:15:13
!
!
ephone-template  1
 softkeys hold  Newcall Join Resume Select
 softkeys idle  Newcall Redial Dnd Join RmLstC ConfList Login HLog Cfwdall
 softkeys seized  Callback Cfwdall Redial Endcall Meetme Gpickup HLog
 softkeys connected  ConfList Confrn Endcall Park Select Trnsfer Join Hold
!
!
ephone-dn  1  dual-line
 number 3001
 label John_3001
 description 442321313001
 name John
 allow watch
 night-service bell
!
!
ephone-dn  2  octo-line
 number 3002
 label Tom_3002
 description 442321313002
 name Tom
 allow watch
!
!

!
!
ephone-dn  20  octo-line
 number C1
 name adhoc
 conference ad-hoc
!
!
ephone-dn  21  octo-line
 number 3600
 conference meetme
!
!
ephone  1
 conference add-mode creator
 conference admin
 device-security-mode none
 mac-address 0027.0D3D.EF7E
 ephone-template 1
 after-hours exempt
 username "Johnchambers" password cisco
 blf-speed-dial 1 3002 label "3002"
 blf-speed-dial 6 3002 label "Tom"
 paging-dn 15
 codec g729r8
 type 7961
 keep-conference local-only
 button  1:1 2c10,11 3:13
 pin 12345
!
!
!
ephone  2
 conference drop-mode creator
 conference add-mode creator
 device-security-mode none
 mac-address 000E.D710.90A9
 ephone-template 1
 after-hours exempt
 username "Tomcruise" password cisco
 blf-speed-dial 4 3001 label "SDJOHN"
 paging-dn 16
 codec g729r8
 type 7960
 keep-conference drop-last local-only
 button  1:2 2c10,11 3:14
 pin 12345
 night-service bell
!        
!

 

Thanks and Regards,

 Luckey

Comments

  • Any suggestions from any one

  • I'm a bit confused here. Are phones at this branch site registered to CUCM, and you are simply trying to stream MMoH from the CME router?

    Or are these phones at this branch site registered to the local CME router, and you are just trying to stream MMoH from it?

    Either way, transcoders don't transcode Multicast MoH, they will only transcode Unicast MoH. 



    Kind Regards,

    Mark Snow, CCIE #14073
    (Voice, Security)
    Instructor
    Internetwork Expert, Inc.
    INE Online Community
    INE Blog
    LinkedIn
    Toll Free: 877-224-8987
    Outside US: +1 775 826 4344

    - docendo discitur





    On Jun 15, 2011, at 2:13, adam.luckey222 <[email protected]> wrote:

    Hai ,

     

    I have registered my transcoder to cme but  when i try to check for music-on -hold its not using the transcoder .cme  uses g711 to stream the moh file its not transcoded

     

    Even though i tried to use software CFB ,to l trancode g711 steam to g729 .Thats not happening for my phones which are using g729r8 codec

    Here is my configuration. am i missing something or my concept is wrong somewhere .

    How can i see transcoding sessions active for moh and conferencing ?

    Your reply will be highly appreciated .

     

     

    voice-card 0
     no dspfarm
     dsp services dspfarm
    !
    !
    !
    !
    !

    !
    interface GigabitEthernet0/0
     ip address 10.1.1.101 255.255.255.0
     ip pim sparse-dense-mode
     duplex auto
     speed auto
     ntp disable
    !
    interface Service-Engine0/0
     no ip address
     shutdown
    !
    interface GigabitEthernet0/1
     ip address 20.1.1.101 255.255.255.0
     duplex auto
     speed auto
    !

    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    !

    !
    control-plane
    !
    !
    !
    voice-port 0/3/0:15
    !
    !
    !
    sccp local Vlan10
    sccp ccm 177.3.11.1 identifier 1 priority 1 version 6.0
    sccp
    !
    sccp ccm group 1
     bind interface Vlan10
     associate ccm 1 priority 1
     associate profile 2 register transcoder
     associate profile 1 register HW_CFB
    !
    dspfarm profile 2 transcode 
     codec g729br8
     codec g729r8
     codec g729ar8
     codec g729abr8
     maximum sessions 4
     associate application SCCP
    !
    dspfarm profile 1 conference 
     codec g729r8
     codec g729br8
     codec g729ar8
     codec g729abr8
     maximum sessions 1
     conference-join custom-cptone JOIN-TONE
     conference-leave custom-cptone Leave-only
     associate application SCCP
     
    !
    !

    !
    !
    telephony-service
     sdspfarm conference mute-on **1 mute-off **2
     sdspfarm units 5
     sdspfarm transcode sessions 4

     sdspfarm tag 1 HW_CFB

     sdspfarm tag 2 transcoder

     conference hardware
     no auto-reg-ephone
     load 7960-7940 P00308010200
     load 7961 SCCP41.8-4-2S
     max-ephones 2
     max-dn 50
     ip source-address 177.3.11.1 port 2000
     system message Ha Ha Ha Ha Ha
     cnf-file location flash:
     cnf-file perphone
     time-zone 20
     time-format 24
     date-format yy-dd-mm
     dialplan-pattern 1 21313... extension-length 4


     max-conferences 8 gain -6
     call-forward pattern .T
     moh music-on-hold.au
     multicast moh 239.1.1.4 port 16384
     web admin system name admin password cisco
     dn-webedit
     time-webedit
     transfer-system full-consult
     transfer-pattern .T
     secondary-dialtone 9
     login timeout 60 clear 23:00
      create cnf-files version-stamp 7960 Jun 15 2011 07:15:13
    !
    !
    ephone-template  1
     softkeys hold  Newcall Join Resume Select
     softkeys idle  Newcall Redial Dnd Join RmLstC ConfList Login HLog Cfwdall
     softkeys seized  Callback Cfwdall Redial Endcall Meetme Gpickup HLog
     softkeys connected  ConfList Confrn Endcall Park Select Trnsfer Join Hold
    !
    !
    ephone-dn  1  dual-line
     number 3001
     label John_3001
     description 442321313001
     name John
     allow watch
     night-service bell
    !
    !
    ephone-dn  2  octo-line
     number 3002
     label Tom_3002
     description 442321313002
     name Tom
     allow watch
    !
    !

    !
    !
    ephone-dn  20  octo-line
     number C1
     name adhoc
     conference ad-hoc
    !
    !
    ephone-dn  21  octo-line
     number 3600
     conference meetme
    !
    !
    ephone  1
     conference add-mode creator
     conference admin
     device-security-mode none
     mac-address 0027.0D3D.EF7E
     ephone-template 1
     after-hours exempt
     username "Johnchambers" password cisco
     blf-speed-dial 1 3002 label "3002"
     blf-speed-dial 6 3002 label "Tom"
     paging-dn 15
     codec g729r8
     type 7961
     keep-conference local-only
     button  1:1 2c10,11 3:13
     pin 12345
    !
    !
    !
    ephone  2
     conference drop-mode creator
     conference add-mode creator
     device-security-mode none
     mac-address 000E.D710.90A9
     ephone-template 1
     after-hours exempt
     username "Tomcruise" password cisco
     blf-speed-dial 4 3001 label "SDJOHN"
     paging-dn 16
     codec g729r8
     type 7960
     keep-conference drop-last local-only
     button  1:2 2c10,11 3:14
     pin 12345
     night-service bell
    !        
    !

     

    Thanks and Regards,

     Luckey




    INE - The Industry Leader in CCIE Preparation

    http://www.INE.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx


  • CME#sh run     

    Building
    configuration...

     

     

    Current configuration
    : 10198 bytes

    !

    ! Last configuration
    change at 07:07:52 UTC Fri Jun 17 2011

    ! NVRAM config last
    updated at 07:01:19 UTC Fri Jun 17 2011

    !

    version 12.4

    service timestamps
    debug datetime msec

    service timestamps
    log datetime msec

    no service
    password-encryption

    !

    hostname CME

    !

    boot-start-marker

    boot-end-marker

    !

    card type e1 0 3

    logging
    message-counter syslog

    !

    no aaa new-model

    network-clock-participate
    wic 3

    !

    dot11 syslog

    ip source-route

    !

    !

    ip cef

    ip dhcp
    excluded-address 177.3.11.1

    !

    ip dhcp pool voice

       network 177.3.11.0 255.255.255.0

       default-router 177.3.11.1

       option 150 ip 177.3.11.1

    !

    !

    no ip domain lookup

    ip domain name
    cisco.com

    no ipv6 cef

    !

    multilink bundle-name
    authenticated

    !

    !

    isdn switch-type
    primary-ni

    !

    !

    !

    voice service voip

     allow-connections h323 to h323

     allow-connections h323 to sip

     allow-connections sip to h323

     allow-connections sip to sip

     redirect ip2ip

     sip

      registrar server expires max 120 min 60

    !

    !

    !

    !

    !

    !

    !

    !

    !

    voice class
    custom-cptone Leave-only

     dualtone conference

      frequency 300 3600

      cadence continuous

    !

    !

    voice class
    custom-cptone JOIN-TONE

     dualtone conference

      frequency 300 3600

      cadence 50 50 100 100 150 150 continuous

    !

    !

    !

    !

    !

    !

    !

    voice register global

     mode cme

     source-address 177.3.11.1 port 5060

     max-dn 50

     max-pool 2

     load 7961 SIP41.8-4-2S

     load 7960-7940 P0S3-8-12-00

     authenticate register

     timezone 22

     time-format 24

     date-format YY-M-D

     dialplan-pattern 1 2131.... extension-length 4

     call-feature-uri cfwdall 3002

     tftp-path flash:

     create profile sync 000645404251521A

     ntp-server 10.1.1.50 mode directedbroadcast

    !

    voice register
    dn  1

     number 3003

     allow watch

     name AngelinaJolie

     label ANG3003

    !

    voice register
    dn  2

     number 3004

     allow watch

     name PamelaAnderson

     label Pam3004

    !

    voice register
    dn  13

     number 1000

     name intercome

     auto-answer

    !

    voice register
    dn  14

     number A222

     name intercom

     auto-answer

    !

    voice register
    pool  1

     id mac 001B.D432.DD92

     type 7961

     number 1 dn 1

     number 2 dn 13

     presence call-list

     username 3003 password 3003

     blf-speed-dial 1 3002 label "Tom"

    !

    voice register
    pool  2

     id mac 0013.C367.786A

     type 7960

     number 1 dn 2

     number 3 dn 14

     presence call-list

     username 3004 password 3004

     description 442321313004

     blf-speed-dial 1 3001 label "John"

    !

    !        

    !

    voice-card 0

     no dspfarm

     dsp services dspfarm

    !

    !

    !

    !

    !

    archive

     log config

      hidekeys

    !

    !

    !

    !

    !

    controller E1 0/3/0

     pri-group timeslots 1-4,16

    !

    !

    !

    !        

    !

    interface
    GigabitEthernet0/0

     ip address 10.1.1.101 255.255.255.0

     ip nbar protocol-discovery

     ip pim sparse-dense-mode

     duplex auto

     speed auto

     ntp disable

    !

    interface
    Service-Engine0/0

     no ip address

     shutdown

    !

    interface
    GigabitEthernet0/1

     ip address 20.1.1.101 255.255.255.0

     duplex auto

     speed auto

    !

    interface
    FastEthernet0/2/0

     switchport mode trunk

     switchport voice vlan 10

    !

    interface
    FastEthernet0/2/1

     switchport mode trunk

     switchport voice vlan 10

    !

    interface
    FastEthernet0/2/2

     switchport mode trunk

     switchport voice vlan 10

    !

    interface
    FastEthernet0/2/3

     switchport mode trunk

     switchport voice vlan 10

    !

    interface Serial0/1/0

     no ip address

     shutdown

     no fair-queue

     clock rate 2000000

    !

    interface
    Serial0/3/0:15

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn incoming-voice voice

     isdn outgoing display-ie

     no cdp enable

    !

    interface Vlan1

     no ip address

    !

    interface Vlan10

     ip address 177.3.11.1 255.255.255.0

    !

    router eigrp 100

     network 20.0.0.0

     network 177.3.0.0

     auto-summary

    !

    ip forward-protocol
    nd

    ip http server

    no ip http
    secure-server

    !

    !

    !

    !

    !

    !

    !        

    !

    !

    tftp-server
    flash:7940-7960-sccp.8-1-2/P00308010200.sbn alias P00308010200.sbn

    tftp-server
    flash:7940-7960-sccp.8-1-2/P00308010200.sb2 alias P00308010200.sb2

    tftp-server
    flash:7940-7960-sccp.8-1-2/P00308010200.loads alias P00308010200.loads

    tftp-server
    flash:7940-7960-sccp.8-1-2/P00308010200.bin alias P00308010200.bin

    tftp-server flash:7940-7960-sip.8-12/P003-8-12-00.sbn
    alias P003-8-12-00.sbn

    tftp-server
    flash:7940-7960-sip.8-12/P003-8-12-00.bin alias P003-8-12-00.bin

    tftp-server
    flash:7940-7960-sip.8-12/P0S3-8-12-00.sb2 alias P0S3-8-12-00.sb2

    tftp-server
    flash:7940-7960-sip.8-12/P0S3-8-12-00.loads alias P0S3-8-12-00.loads

    tftp-server
    flash:SIP41.8-5-3S.loads

    tftp-server
    flash:7941-7961-sip.8-4-2S/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn

    tftp-server
    flash:7941-7961-sip.8-4-2S/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn

    tftp-server
    flash:7941-7961-sip.8-4-2S/cvm41sip.8-4-1-23.sbn alias cvm41sip.8-4-1-23.sbn

    tftp-server
    flash:7941-7961-sip.8-4-2S/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn

    tftp-server
    flash:7941-7961-sip.8-4-2S/jar41sip.8-4-1-23.sbn alias jar41sip.8-4-1-23.sbn

    tftp-server
    flash:7941-7961-sip.8-4-2S/SIP41.8-4-2S.loads alias SIP41.8-4-2S.loads

    tftp-server
    flash:7941-7961-sip.8-4-2S/term41.default.loads alias term41.default.loads

    tftp-server
    flash:7941-7961-sip.8-4-2S/term61.default.loads alias term61.default.loads

    !

    control-plane

    !

    !

    !

    voice-port 0/3/0:15

    !

    <p class="MsoNormal" style="mar
Sign In or Register to comment.