EIGRP Distribute List Weirdness

I'm looking for a bit of help on an issue I can't figure out.  I'm working on EIGRP distribute list route filtering.  If I have R1 and R2 directly connected, and a loopback on R2 with an IP of 2.2.4.2/8, I can enter the following on R1 and it filters fine:

router eigrp 100
  distribute-list FILTERME in

ip access-list standard FILTERME
 deny   2.0.0.0
 permit any

The route table correctly shows the 2.0.0.0/8 network as filtered. 

However, if I specify the inbound interface, the filter stops working:

router eigrp 100
  distribute-list FILTERME in FastEthernet0/0

ip access-list standard FILTERME
 deny   2.0.0.0
 permit any


I'm using a 2800 with 12.4(15)T7.  What am I missing?

 

Will

Comments

  • What does show ip route 2.0.0.0 say?

  • Hi Edmund, thanks for the reply!  When I don't specify the inbound interface and the filter works, I get the expected:

    % Network not in table

    When I do specify the inbound interface (distribute-list FILTERME in fastEthernet 0/0), and it doesn't filter, here's what it returns:

    Routing entry for 2.0.0.0/8
      Known via "eigrp 100", distance 90, metric 156160, type internal
      Redistributing via eigrp 100
      Last update from 172.16.12.2 on FastEthernet0/0, 00:00:52 ago
      Routing Descriptor Blocks:
      * 172.16.12.2, from 172.16.12.2, 00:00:52 ago, via FastEthernet0/0
          Route metric is 156160, traffic share count is 1
          Total delay is 5100 microseconds, minimum bandwidth is 100000 Kbit
          Reliability 255/255, minimum MTU 1500 bytes
          Loading 1/255, Hops 1

     

     

  • Okay, I tried it on a different set of routers- it works as expected.  Must be a bug in IOS.  The version that worked was:

    12.4(24)T2

Sign In or Register to comment.