1.29 - bpdufilter default command not working

Hi,

Just a quick one. While doing exercise 1.29 I was unable to get portfast to disable as per solution because when spanning-tree detected the BPDUs on SW1 Fa0/1 it gave a SPT error and placed the port in an inconsistent state as follows -

%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet

%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/1 on VLAN0146. Inconsistent port type.

Rack1SW1#show spanning-tree interface fa0/1

Vlan                Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
VLAN0146            Desg BKN*19        128.3    P2p Edge *TYPE_Inc


Rack1SW1#show spanning-tree interface fa0/1 portfast
VLAN0146            enabled

I temporarily changed the port to a dot1q trunk and BPDU Filter default worked (for a range of VLANs).

Wondered if anyone knew where I was going wrong or experiened something similar?

BTW - Many thanks to all those people who post their findings on this forum - it is a great help to newbies like me and is greatly appreciated!

Cheers

Skipper

Comments

  • Hi Skipper,

    I am glad as well that we have this forum.
    I learned a lot from this forum.

    BTW, for your case, please check this CCO out:
    http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00801d11a0.shtml
    It's a good ref about the "type-inconsistent" error that you get.

    I suspect that you are using dot1q on R1's F0/0 while access port on SW1's F0/1, just like below case:

    Rack1SW1(config)#do sh run int f0/1
    Building configuration...
    Current configuration : 85 bytes
    !
    interface FastEthernet0/1
     switchport access vlan 146
     switchport mode access
    end

    Rack1R1#sh run int f0/0.1
    Building configuration...
    Current configuration : 103 bytes
    !
    interface FastEthernet0/0.1
     encapsulation dot1Q 1 native
     ip address 155.1.146.1 255.255.255.0
    end

    Rack1R1#ping 155.1.146.4
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 155.1.146.4, timeout is 2 seconds:
    .!!!!
    Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

    Rack1R1(config-subif)#bridge 1 protocol ieee
    Rack1R1(config-subif)#bridge 1 prio 200
    Rack1R1(config)#int f0/0.1
    Rack1R1(config-subif)#bridge-gr 1

    Rack1R1(config-subif)#do sh spann 1
     Bridge group 1 is executing the ieee compatible Spanning Tree protocol
      Bridge Identifier has priority 200, address 000a.b82c.a9a8
      Configured hello time 2, max age 20, forward delay 15
      We are the root of the spanning tree
      Topology change flag not set, detected flag not set
      Number of topology changes 7 last change occurred 00:01:23 ago
              from FastEthernet0/0
      Times:  hold 1, topology change 35, notification 2
              hello 2, max age 20, forward delay 15
      Timers: hello 1, topology change 0, notification 0, aging 300
     Port 15 (FastEthernet0/0.1) of Bridge group 1 is listening
       Port path cost 19, Port priority 128, Port Identifier 128.15.
       Designated root has priority 200, address 000a.b82c.a9a8
       Designated bridge has priority 200, address 000a.b82c.a9a8
       Designated port id is 128.15, designated path cost 0
       Timers: message age 0, forward delay 7, hold 0
       Number of transitions to forwarding state: 0
       BPDU: sent 5, received 1

    Rack1SW1(config)#
    06:17:54: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/1 VLAN146.
    06:17:54: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/1 on VLAN0146. Inconsistent port type.

     

  • Thanks Alexander!

    Best Regards,

    Skipper

Sign In or Register to comment.