QOS

Hi All,

I would like to provision my users with 1MB bandwidth for internet use. I have one Cisco 2800 router, with 2 built-in Giga ports and one in module. Following is the configuration which i have done on router.

!
int gig0/0
description ** OutSide Interface **
ip address X.X.X.X 255.255.255.0
ip nat outside
no shut
!
int gig0/1
description ** InsideInterface **
ip address 192.168.1.1 255.255.255.0
ip nat inside
no shut
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
ip nat inside source list 10 interface FastEthernet0/0 overload
!
ip route 0.0.0.0 0.0.0.0 X.X.X.X
!
ip dhcp pool LAB_A
network 192.168.1.0 /24
default-router 192.168.1.1
dns-server 4.2.2.2
!
User only using net in this setup I want they should not get more than 1 MB bandwidth becasue I have more 40MB Internet connection.

Thanks

Comments

  • Hi dell123,

    you can do the following...policing or shaping. Shaping is preferred here.

    You have a 40Mbit Internet connection (right?) and you want the users to have 1Mbit/sec.

     

    Policing does measure how many traffic is flowing into or out of an interface. When the limit (1Mbit) is reached you can define violate options. Problem here is that the traffic is interrupted hard. So if you have 1Mbit transferred within 50msec then 950msec long you will not have any traffic for the users flow to the internet. This is quite problematic here, as some applications will have very choppy connections.

    Shaping is better here, because shaping buffers the traffic and slows it down. Of course some packets surely will be dropped, but for example tcp applications will have the possibility to reduce the speed of their transmissions by reducing the window size and performing relaible connections.

    If you need further information check those two points out at the cisco documentation or just tell me then I can tell you how to do so.

     

    Regards!

  • Hi Markus,

    I realize this is thread necro of the worst sort, but I'm confused by your answer.

    I was fairly certain that Tc = Bc/CIR, so in no case would you ever see a scenario like you're describing.  IIRC, on slow links with large Bc you coudl screw yourself up by having a 250ms Tc, but on 100m or 1000m links, isn't the Tc in the single or double digit ms range?  Quickly labbing it up on a 100m int, using 100000 bps as the policer rate, and all other values set to defaults, I get a Bc of 3125 bytes, which would give me a Tc of around 32ms if I'm doing my math correctly, no?

    Second, how *do* most people handle shaping/policing on larger pipes?  I was under the impression that shaping on pipes larger than 10 or 20 mbps was actually counterproductive in many cases, but I have a hard time finding much solid info on it other than generic statements like "use shaping on slower links, policing on faster ones."  I believe this was even the case in the "end to end" QoS book.  If I'm way off base here, I'd love to know it, and if someone could provide a link to some info that would be even more appreciated.

    Thanks!

Sign In or Register to comment.