SRST MMOH doesn't work

 

I am trying to configure mmoh for remote h323 site H323GW,  from the local file.

I did:

1.  Add REG_MOH, it will use G711 to all other region.

2.  Create a DP_MOH with REG_MOH.

3. Put MOH_3 (sub) in DP_MOH and enable multicast(239.1.1.1, 16384), max hop to 1.

4.  Enable multicast for audio file.

5.  Create a MRG, put MOH_3 in, and put MRG in MRGL.

6.  On H323GW, I have:

ccm-manager music-on-hold

call-manager-fallback

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384 route IP_OF_LOOPBACK0 IP_OF_VOICE_VLAN.

 

Call from one HQ phone to one phone at remote site, after connected, put the phone at remote site on hold, I can noly hear tone on hold, not music on hold.

 

Do I miss anything?

Thanks 

 

Comments

  • Do you have pim-sparse-dense on interfaces?

     

    From: [email protected] [mailto:[email protected]] On Behalf Of Peng
    Sent: Tuesday, March 22, 2011 11:14 PM
    To: Brad Ferguson
    Subject: [CCIE Voice General] SRST MMOH doesn't work

     

     

    I am trying to configure mmoh for remote h323 site H323GW,  from the local file.

    I did:

    1.  Add REG_MOH, it will use G711 to all other region.

    2.  Create a DP_MOH with REG_MOH.

    3. Put MOH_3 (sub) in DP_MOH and enable multicast(239.1.1.1, 16384), max hop to 1.

    4.  Enable multicast for audio file.

    5.  Create a MRG, put MOH_3 in, and put MRG in MRGL.

    6.  On H323GW, I have:

    ccm-manager music-on-hold

    call-manager-fallback

    moh music-on-hold.au

    multicast moh 239.1.1.1 port 16384 route IP_OF_LOOPBACK0 IP_OF_VOICE_VLAN.

     

    Call from one HQ phone to one phone at remote site, after connected, put the phone at remote site on hold, I can noly hear tone on hold, not music on hold.

     

    Do I miss anything?

    Thanks 

     




    Internetwork Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx







  • Hi,

     

    “Tone hold” is usally an indication of a wrongful configuration.....

     

    Verify that you have enable the audio source for MOH, Set the MAX hop to
    something reasonable (1 is probably not enough select 3 or 4), Enable the MRG
    for MOH. (There is a check box on the mrg)

     

    Also; at the HQ, You need to enable ip-multicast routing, and ip pim dense
    mode. (For the music to reach the HQ phone)

    Your router config seems correct. If you press hold on the HQ phone, you
    should be able to get the MOH. (Provided max hop is ok)



     


    From: bferguson

    Sent: Wednesday, March 23, 2011 5:35 AM


    Subject: RE: [CCIE Voice General] SRST MMOH doesn't
    work

     


    Do you have
    pim-sparse-dense on interfaces?

     

    From: [email protected] [mailto:[email protected]]
    On Behalf Of Peng
    Sent: Tuesday, March 22, 2011 11:14
    PM
    To: Brad Ferguson
    Subject: [CCIE Voice General] SRST MMOH
    doesn't work

     

     

    I am trying to configure mmoh for remote h323 site H323GW,  from the
    local file.

    I did:

    1.  Add REG_MOH, it will use G711 to all other region.

    2.  Create a DP_MOH with REG_MOH.

    3. Put MOH_3 (sub) in DP_MOH and enable multicast(239.1.1.1, 16384), max hop
    to 1.

    4.  Enable multicast for audio file.

    5.  Create a MRG, put MOH_3 in, and put MRG in MRGL.

    6.  On H323GW, I have:

    ccm-manager music-on-hold

    call-manager-fallback

    moh music-on-hold.au

    multicast moh 239.1.1.1 port 16384 route IP_OF_LOOPBACK0
    IP_OF_VOICE_VLAN.

     

    Call from one HQ phone to one phone at remote site, after connected, put the
    phone at remote site on hold, I can noly hear tone on hold, not music on
    hold.

     

    Do I miss anything?

    Thanks

     




    Internetwork Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription
    information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx





    Internetwork
    Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription information
    may be found
    at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • Lasse is correct. Tone on hold means that the server has a misconfiguration. Nothing to do with the infrastructure (and you shouldn't need multicast-routing turned on anywhere, including the router playing the audio file, nor does the hop count matter in CUCM).

    Best guess is that although you believe that you have the codec setup properly between the MoH Server and the phone told to receive the MMoH stream, you probably have a simple configuration error somewhere. Your definition of how you setup your Regions in steps 1-3 above seem great, but the CUCM server is telling you - by way of the tone-on-hold - that something, somewhere is wrong with itself. Dead air when you go to press Hold would be an indication of a properly setup CUCM server, but an infrastructure error - which you do not seem to have.

    HTH some.

  • Basically the gateway H323 should be:

     

    telephony-service (or call-manager-fallback)

     max-ephones nn

     max-dn NN


     moh music-on-hold.au      (location in  the flash)

     multicast moh 239.1.1.1 port
    16384 route 10.10.110.3 177.3.11.1  (local interfaces)

     


    ccm-manager music-on-hold   


     

     

    Checking:

    R#sh flash | i music
    32      496521 Feb 11 2011 13:57:24 music-on-hold.au

    debug ephone moh
    EPHONE music-on-hold debugging is enabled

    <!--[if gte mso 9]>

































































    <w:LsdException Locked="false" Priority="64" SemiHidden="false"
    UnhideWhenUsed="false" Name="Medium Shading 2 Accent

Sign In or Register to comment.