Task 2.7

Just took this mock lab yesterday...started at 5am my time and I think that I bombed it.  Anywho...I had some real trouble with this task, even though it is so straightforward.  I actually nailed the task, verbatim with the SG, and yet it didnt work.  I am relabbing the ML tonight though, and finally found out the issue.  When advertising the conditional frame route, I tagged it with the community of no-advertise so that it wouldnt be passed to neighbors, but would stay in R3's BGP table (I later took this out thinking it was the issue yesterday).  What I failed to notice was that R3 was keeping the tracked frame route in the table even after I shut down the interface b/c the route was propogating back to R3 via EIGRP.  I fixed it like so on R3 tonight (got to frustrated yesterday to deal with it anymore with the time pressure and all):

ip prefix-list SELF deny 164.5.23.0/24

ip prefix-list SELF permit 0.0.0.0/0 le 32

router eigrp 100

distribute-list  prefix SELF in

Before I put that in..this was showing up in R3's bgp table if the only thing I did was shut R3 FR int (probably could have used FREEK too).

*> 164.5.23.0/24    164.5.13.1         6535936         32768 i

Hope this helps someone else...let me know if my logic is off or not, but this is what I understood was happening here.

 

Jason

Comments

  • I had the same problem - I did this:

    - no FR net advertising with network statement. I used a redistribute connected with a route-map matching only the FR network interface

    - added "match route-type connected" in the non-exist map.

    when the FR interface goes down it will indeed reappear as a redistributed network in the BGP table, however it won't be connected and the non-exist map won't have a match.

     

    HTH

  • Hi,

     

    I have a different question. The question says that the goal is to prevent traffic sent to servers uses the R1-R3 FR Link. However, I have tried again the situation in my own LAB environment. When i advertised the FR network (23.0/24) into BGP, the conditional adevertisemnt worked, but in R1 perspective i still have the next-hop set to 23.3 (In normal operation), so i should use this path (R2-R3) but this prefix uses the next-hop as 164.1.23.3.

     

    This next hop is also in BGP with the original question and advertised from R3 to R1 with next hop 13.3 ...

     

    Finally te result is the prefix is not advertised but the data path is still R1-R3 :/

     

    I made this workaround .... Next hop self on R2 to neighbor R1

     

    Hope you can claryfy me

    Regards

     

Sign In or Register to comment.