IEWB-RS Volume 3 (Vol3 III) BGP 5.3 & 5.4 Lab 1

Currently stuck on Vol3 Lab 1 task 5.3 & 5.4 BGP Aggregation and Path Manipulation.

Task 5.3

Router 6 verifications seem good but router 3

RSRack26R6#sh ip bgp nei 54.26.2.254 adv | be Ne
   Network          Next Hop            Metric LocPrf Weight Path
*> 140.26.0.0       0.0.0.0                            32768 i

Total number of prefixes 1
RSRack26R6#

RSRack26R6#sh ip bgp | i Status|s>
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
s> 140.26.8.0/24    140.26.100.5                           0 200 400 i
RSRack26R6#

//////////// //////////////////////

RSRack26R3#sh ip bgp nei 204.12.26.254 adv | be N
   Network          Next Hop            Metric LocPrf Weight Path
*>i28.119.16.0/24   54.26.2.254              0    150      0 54 i
*>i28.119.17.0/24   54.26.2.254              0    150      0 54 i
*>i112.0.0.0        54.26.2.254              0    150      0 54 50 60 i
*>i113.0.0.0        54.26.2.254              0     50      0 54 50 60 i
*>i114.0.0.0        54.26.2.254              0    150      0 54 i
*>i115.0.0.0        54.26.2.254              0     50      0 54 i
*>i116.0.0.0        54.26.2.254              0    150      0 54 i
*>i117.0.0.0        54.26.2.254              0     50      0 54 i
*>i118.0.0.0        54.26.2.254              0    150      0 54 i
*>i119.0.0.0        54.26.2.254              0     50      0 54 i
*> 140.26.0.0       0.0.0.0                            32768 i   <<--- This show be the only route being advertised to BB3 network 204.12.26.254.

Total number of prefixes 11
RSRack26R3#sh ip bgp | i Status|s>
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
s> 140.26.8.0/24    140.26.100.5                           0 200 400 i
RSRack26R3#

//////////// //////////////// /////////////

RSRack26R5#sh ip bgp 140.1.0.0
% Network not in table

 

====== ============== ================ ===================

Task 5.3

+++++++++++++ +++++++++++

-- Not seeing any next hops for 204.12.26.254 network. The local preference was set but there is no BGP next hops of 204.12.26.254.

 RSRack26R6#sh ip bgp
BGP table version is 14, local router ID is 150.26.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 28.119.16.0/24   54.26.2.254                   150      0 54 i
*> 28.119.17.0/24   54.26.2.254                   150      0 54 i
*> 112.0.0.0        54.26.2.254              0    150      0 54 50 60 i
*> 113.0.0.0        54.26.2.254              0     50      0 54 50 60 i
*> 114.0.0.0        54.26.2.254              0    150      0 54 i
*> 115.0.0.0        54.26.2.254              0     50      0 54 i
*> 116.0.0.0        54.26.2.254              0    150      0 54 i
*> 117.0.0.0        54.26.2.254              0     50      0 54 i
*> 118.0.0.0        54.26.2.254              0    150      0 54 i
*> 119.0.0.0        54.26.2.254              0     50      0 54 i
* i140.26.0.0       140.26.100.3             0    100      0 i
*>                  0.0.0.0                            32768 i
s> 140.26.8.0/24    140.26.100.5                           0 200 400 i
RSRack26R6#

//////////// /////////// ///////////// ///////


RSRack26R3#traceroute 116.0.0.1

Type escape sequence to abort.
Tracing the route to 116.0.0.1

  1 140.26.100.6 0 msec 0 msec 0 msec
  2 54.26.2.254 16 msec *  16 msec
RSRack26R3#trace 117.0.0.1 source fa0/0

Type escape sequence to abort.
Tracing the route to 117.0.0.1

  1 140.26.100.6 0 msec 4 msec 0 msec <<-- Should be going to 204.12.26.254
  2 54.26.2.254 100 msec *  12 msec
RSRack26R3#

 //////////////////////// /////////////// ////////////////////////

////////////////// //////////////////////// /////////////////

 

RSRack26R3#sh ip bgp sum | be N
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
140.26.100.5    4   200      70      74       14    0    0 01:07:22        1
140.26.100.6    4   100      79      71       14    0    0 01:07:08       11
204.12.26.254   4    54      70      75       14    0    0 01:07:07        0
RSRack26R3#

RSRack26R6#sh ip bgp sum | be N
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
54.26.2.254     4    54      73      71       14    0    0 01:06:45       10
140.26.100.3    4   100      70      78       14    0    0 01:06:47        1
140.26.100.5    4   200      74      80       14    0    0 01:10:32        1
RSRack26R6#

RS.26.26.BB1#sh ip bgp sum | be N
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
54.26.1.6       4   100       0       0        0    0    0 never    Active
54.26.2.6       4   100      71      73       12    0    0 01:06:26        1
54.26.3.6       4   100       0       0        0    0    0 never    Active
54.26.4.6       4   100       0       0        0    0    0 never    Idle
54.26.5.6       4   100       0       0        0    0    0 never    Idle
54.26.6.6       4   100       0       0        0    0    0 never    Idle
54.26.7.6       4   100       0       0        0    0    0 never    Idle
54.26.8.6       4   100       0       0        0    0    0 never    Idle
54.26.10.6      4   100       0       0        0    0    0 never    Active
54.26.10.100    4   100       0       0        0    0    0 never    Active
172.16.4.3      4    54      70      72       12    0    0 01:06:28        2
RS.26.26.BB1#

RS.26.26.BB3#    sh ip bgp sum | be N
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.4.1      4    54      72      70       12    0    0 01:06:02        9
204.12.26.1     4   100       0       0        0    0    0 never    Active
204.12.26.2     4   100       0       0        0    0    0 never    Active
204.12.26.3     4   100      74      69       12    0    0 01:06:01        0
204.12.26.4     4   100       0       0        0    0    0 never    Active
204.12.26.5     4   100       0       0        0    0    0 never    Active
204.12.26.6     4   100       0       0        0    0    0 never    Active
204.12.26.7     4   100       0       0        0    0    0 never    Active
204.12.26.8     4   100       0       0        0    0    0 never    Active
204.12.26.9     4   100       0       0        0    0    0 never    Active
204.12.26.10    4   100       0       0        0    0    0 never    Active
RS.26.26.BB3#

 

/////////////// ////////////////// /////////////// ////////////


RSRack26R3#sh run
Building configuration...

Current configuration : 1895 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RSRack26R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
interface Loopback0
 ip address 150.26.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 140.26.100.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 204.12.26.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay IETF
 shutdown
 frame-relay lmi-type cisco
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric-type 1 subnets route-map CONNECTED-OSPF
 network 140.26.100.3 0.0.0.0 area 2
 network 150.26.3.3 0.0.0.0 area 2
!
router bgp 100
 no synchronization
 bgp router-id 150.26.3.3
 bgp log-neighbor-changes
 aggregate-address 140.26.0.0 255.255.0.0 summary-only
 neighbor 140.26.100.5 remote-as 200
 neighbor 140.26.100.5 route-map DENY_AGGREGATE out
 neighbor 140.26.100.6 remote-as 100
 neighbor 204.12.26.254 remote-as 54
 no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list AGGREGATE seq 5 permit 140.26.0.0/16
!
route-map DENY_AGGREGATE deny 10
 match ip address prefix-list AGGREGATE
!
route-map DENY_AGGREGATE permit 10000
!
route-map CONNECTED-OSPF permit 10
 match interface FastEthernet0/1
!
!
!
control-plane
!        
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
         
RSRack26R3#          


RSRack26R6#sh run
Building configuration...

Current configuration : 2096 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RSRack26R6
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!        
!
interface Loopback0
 ip address 150.26.6.6 255.255.255.0
!
interface FastEthernet0/0
 ip address 140.26.100.6 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial0/0.1 point-to-point
 ip address 54.26.2.6 255.255.255.0
 frame-relay interface-dlci 100  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute connected metric-type 1 subnets route-map CONNECTED-OSPF
 network 140.26.100.6 0.0.0.0 area 2
 network 150.26.6.6 0.0.0.0 area 2
!
router bgp 100
 no synchronization
 bgp router-id 150.26.6.6
 bgp log-neighbor-changes
 aggregate-address 140.26.0.0 255.255.0.0 summary-only
 neighbor 54.26.2.254 remote-as 54
 neighbor 54.26.2.254 route-map LOCAL_PREF in
 neighbor 140.26.100.3 remote-as 100
 neighbor 140.26.100.5 remote-as 200
 neighbor 140.26.100.5 route-map DENY_AGGREGRATE out
 no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
ip access-list standard EVEN_FIRST_OCTET
 permit 0.0.0.0 254.255.255.255
!
!
ip prefix-list AGGREGATE seq 5 permit 140.26.0.0/16
!
route-map LOCAL_PREF permit 10
 match ip address EVEN_FIRST_OCTET
 set local-preference 150
!
route-map LOCAL_PREF permit 10000
 set local-preference 50
!
route-map DENY_AGGREGRATE deny 10
 match ip address prefix-list AGGREGATE
!
route-map DENY_AGGREGRATE permit 10000
!
route-map CONNECTED-OSPF permit 10
 match interface Serial0/0.1
!        
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end

RSRack26R6#


////////////////// /////////////// ////////////

 

 

RS.26.26.BB1#sh run
Building configuration...

Current configuration : 10575 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RS.26.26.BB1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!        
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
frame-relay switching
!
!
key chain EIGRP
 key 1
   key-string CISCO
!
!
!
!
!
!
!
!
!
!        
!
!
!
username ROUTER6 password 0 CISCO
!
!
!
!
bridge irb
!
!
!
interface Loopback112
 ip address 112.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:112::1/64
 ipv6 rip RIPng enable
!
interface Loopback113
 ip address 113.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:113::1/64
 ipv6 rip RIPng enable
!
interface Loopback114
 ip address 114.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:114::1/64
 ipv6 rip RIPng enable
!
interface Loopback115
 ip address 115.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:115::1/96
 ipv6 rip RIPng enable
!
interface Loopback116
 ip address 116.0.0.1 255.0.0.0
!
interface Loopback117
 ip address 117.0.0.1 255.0.0.0
!
interface Loopback118
 ip address 118.0.0.1 255.0.0.0
!
interface Loopback119
 ip address 119.0.0.1 255.0.0.0
!
interface Loopback51001
 ip address 51.0.0.1 255.255.0.0
!
interface Loopback51101
 ip address 51.1.0.1 255.255.0.0
!
interface Loopback51201
 ip address 51.2.0.1 255.255.0.0
!
interface Loopback51301
 ip address 51.3.0.1 255.255.0.0
!
interface Loopback51401
 ip address 51.4.0.1 255.255.0.0
!
interface Loopback51501
 ip address 51.5.0.1 255.255.0.0
!
interface Loopback51601
 ip address 51.6.0.1 255.255.0.0
!
interface Loopback51701
 ip address 51.7.0.1 255.255.0.0
!
interface Loopback200000
 ip address 200.0.0.1 255.255.255.0
!
interface Loopback200010
 ip address 200.0.1.1 255.255.255.0
!
interface Loopback200020
 ip address 200.0.2.1 255.255.255.0
!
interface Loopback200030
 ip address 200.0.3.1 255.255.255.0
!
interface Loopback2121801
 ip address 212.18.0.1 255.255.255.0
!
interface Loopback2121811
 ip address 212.18.1.1 255.255.255.0
!
interface Loopback2121821
 ip address 212.18.2.1 255.255.255.0
!
interface Loopback2121831
 ip address 212.18.3.1 255.255.255.0
!        
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description Connected to BB3
 ip address 172.16.4.1 255.255.255.0
 no fair-queue
 clock rate 64000
!
interface Serial1/0
 description Connected to R1
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/1 201
 frame-relay route 103 interface Serial1/2 301
 frame-relay route 104 interface Serial1/4 401
 frame-relay route 105 interface Serial1/5 501
 frame-relay route 113 interface Serial1/3 311
!
interface Serial1/1
 description Connected to R2
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial1/0 102
 frame-relay route 203 interface Serial1/2 302
 frame-relay route 204 interface Serial1/4 402
 frame-relay route 205 interface Serial1/5 502
 frame-relay route 213 interface Serial1/3 312
!
interface Serial1/2
 description Connected to R3 S1/0
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial1/0 103
 frame-relay route 302 interface Serial1/1 203
 frame-relay route 304 interface Serial1/4 403
 frame-relay route 305 interface Serial1/5 503
!
interface Serial1/3
 description Connected to R3 S1/1
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 311 interface Serial1/0 113
 frame-relay route 312 interface Serial1/1 213
 frame-relay route 314 interface Serial1/4 413
 frame-relay route 315 interface Serial1/5 513
!
interface Serial1/4
 description Connected to R4
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 401 interface Serial1/0 104
 frame-relay route 402 interface Serial1/1 204
 frame-relay route 403 interface Serial1/2 304
 frame-relay route 405 interface Serial1/5 504
 frame-relay route 413 interface Serial1/3 314
!
interface Serial1/5
 description Connected to R4
 no ip address
 encapsulation frame-relay
 no fair-queue
 clock rate 64000
 frame-relay interface-dlci 100
 frame-relay intf-type dce
 frame-relay route 501 interface Serial1/0 105
 frame-relay route 502 interface Serial1/1 205
 frame-relay route 503 interface Serial1/2 305
 frame-relay route 504 interface Serial1/4 405
 frame-relay route 513 interface Serial1/3 315
!
interface Serial1/6
 description Connected to R6
 no ip address
 encapsulation frame-relay
 clock rate 64000
 frame-relay intf-type dce
!
interface Serial1/6.51 point-to-point
 description PVC 51 to R6
 ip address 54.26.3.254 255.255.255.0
 frame-relay interface-dlci 51  
!
interface Serial1/6.100 point-to-point
 description PVC 100 to R6
 ip address 54.26.2.254 255.255.255.0
 ipv6 address 2001:54:26:2::254/64
 ipv6 address FE80::254 link-local
 frame-relay interface-dlci 100  
!
interface Serial1/6.101 point-to-point
 description PVC 101 to R6
 ip address 54.26.1.254 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 ipv6 address 2001:54:254:26::254/64
 ipv6 address FE80::254 link-local
 ipv6 rip RIPng enable
 frame-relay interface-dlci 101  
!
interface Serial1/6.201 point-to-point
 description PPP over PVC 201 to R6
 frame-relay interface-dlci 201 ppp Virtual-Template1
!
interface Serial1/6.301 point-to-point
 description PPP over PVC 301 to R6
 frame-relay interface-dlci 301 ppp Virtual-Template11
!
interface Serial1/6.401 point-to-point
 description Bridging over PVC 401 to R6
 frame-relay interface-dlci 401  
 bridge-group 1
!
interface Serial1/7
 no ip address
 shutdown
!
interface Virtual-Template1
 ip address 54.26.7.254 255.255.255.0
 ppp authentication chap
 ppp chap hostname BB1
!
interface Virtual-Template11
 ip address 54.26.8.254 255.255.255.0
 ppp authentication pap
 ppp pap sent-username BB1 password 0 CISCO
!
interface BVI1
 ip address 54.26.10.254 255.255.255.0
!
router eigrp 10
 network 54.0.0.0
 network 200.0.0.0 0.0.3.255
 distribute-list EIGRP out
 distribute-list prefix DENY_DEFAULT in
 no auto-summary
 no eigrp log-neighbor-changes
 no eigrp log-neighbor-warnings
!
router rip
 version 2
 network 54.0.0.0
 network 212.18.0.0
 network 212.18.1.0
 network 212.18.2.0
 network 212.18.3.0
 distribute-list RIP out
 no auto-summary
!
router bgp 54
 bgp log-neighbor-changes
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor 54.26.1.6 peer-group RACKS
 neighbor 54.26.2.6 peer-group RACKS
 neighbor 54.26.3.6 peer-group RACKS
 neighbor 54.26.4.6 peer-group RACKS
 neighbor 54.26.5.6 peer-group RACKS
 neighbor 54.26.6.6 peer-group RACKS
 neighbor 54.26.7.6 peer-group RACKS
 neighbor 54.26.8.6 peer-group RACKS
 neighbor 54.26.10.6 peer-group RACKS
 neighbor 54.26.10.100 peer-group RACKS
 neighbor 172.16.4.3 remote-as 54
 !
 address-family ipv4
  neighbor RACKS send-community
  neighbor RACKS route-map BGP_IN in
  neighbor RACKS route-map BGP_OUT out
  neighbor 54.26.1.6 activate
  neighbor 54.26.2.6 activate
  neighbor 54.26.3.6 activate
  neighbor 54.26.4.6 activate
  neighbor 54.26.5.6 activate
  neighbor 54.26.6.6 activate
  neighbor 54.26.7.6 activate
  neighbor 54.26.8.6 activate
  neighbor 54.26.10.6 activate
  neighbor 54.26.10.100 activate
  neighbor 172.16.4.3 activate
  neighbor 172.16.4.3 send-community
  neighbor 172.16.4.3 next-hop-self
  no auto-summary
  no synchronization
  network 112.0.0.0
  network 113.0.0.0
  network 114.0.0.0 route-map SET_COMMUNITY_54
  network 115.0.0.0 route-map SET_COMMUNITY_54
  network 116.0.0.0
  network 117.0.0.0
  network 118.0.0.0
  network 119.0.0.0
 exit-address-family
!        
ip forward-protocol nd
ip route 204.12.0.0 255.255.0.0 172.16.4.3
!
ip as-path access-list 1 permit ^$
!
no ip http server
no ip http secure-server
!
ip access-list standard EIGRP
 permit 200.0.0.0 0.0.3.255
ip access-list standard RIP
 permit 212.18.0.0 0.0.3.0
!
!
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list DENY_DEFAULT seq 5 deny 0.0.0.0/0
ip prefix-list DENY_DEFAULT seq 10 permit 0.0.0.0/0 le 32
ipv6 route 2001:204::/32 2001:172:16:4::3
ipv6 router rip RIPng
 distribute-list prefix-list RIPng out
!
!
!
ipv6 prefix-list RIPng seq 5 permit 2001:254:0:112::/64
ipv6 prefix-list RIPng seq 10 permit 2001:254:0:113::/64
ipv6 prefix-list RIPng seq 15 permit 2001:254:0:114::/64
ipv6 prefix-list RIPng seq 20 permit 2001:254:0:115::/96
route-map BGP_IN deny 10
 match ip address prefix-list DEFAULT
!
route-map BGP_IN permit 10000
!
route-map SET_COMMUNITY_54 permit 10
 set community 54
!
route-map BGP_OUT permit 10
 match ip address prefix-list BGP_PREPEND_1
 set as-path prepend 50 60
!
route-map BGP_OUT permit 10000
 match as-path 1
!        
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
!
!
!
!
!
!
banner exec ^C

+-------------------------------------------------------------------------------+
|                                                                               |
| Welcome to BB1.  The following commands are available for use at privilege 0  |
|                                                                               |
| ping                           show ip bgp                                    |
| telnet                         show ip bgp neighbors                          |
| traceroute                     show ip bgp summary                            |
| show ip route                  show ip interface brief                        |
| show ip protocols                                                             |
|                                                                               |
| The reference configuration for this device is available at:                  |
| http://www.internetworkexpert.com/downloads/bb1.txt                           |
|                                                                               |
+-------------------------------------------------------------------------------+
^C
!        
line con 0
 exec-timeout 5 0
 privilege level 15
line aux 0
 transport input all
line vty 0 4
 exec-timeout 5 0
 privilege level 15
 no login
!
ntp authentication-key 1 md5 072C087F6D26 7
ntp trusted-key 1
ntp master 4
!
end

RS.26.26.BB1#

 


RS.26.26.BB3#sh run
Building configuration...

Current configuration : 4021 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RS.26.26.BB3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!        
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
!
!
!
key chain CISCO
 key 1
   key-string CISCO
!
!
!
!
!
!
!
!
!
!
!        
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 28.119.16.1 255.255.255.0
 ipv6 address 2001:28:119:16::1/64
!
interface Loopback1
 ip address 28.119.17.1 255.255.255.0
 ipv6 address 2001:28:119:17::1/64
!
interface Loopback10
 ip address 30.0.0.1 255.255.0.0
 ipv6 address 2001:30::1/64
 ipv6 rip RIPng enable
!
interface Loopback11
 ip address 30.1.0.1 255.255.0.0
 ipv6 address 2001:30:1::1/64
 ipv6 rip RIPng enable
!
interface Loopback12
 ip address 30.2.0.1 255.255.0.0
 ipv6 address 2001:30:2::1/64
 ipv6 rip RIPng enable
!
interface Loopback13
 ip address 30.3.0.1 255.255.0.0
 ipv6 address 2001:30:3::1/64
 ipv6 rip RIPng enable
!
interface Loopback14
 ip address 31.0.0.1 255.255.0.0
 ipv6 address 2001:31::1/64
 ipv6 rip RIPng enable
!
interface Loopback15
 ip address 31.1.0.1 255.255.0.0
 ipv6 address 2001:31:1::1/64
 ipv6 rip RIPng enable
!
interface Loopback16
 ip address 31.2.0.1 255.255.0.0
 ipv6 address 2001:31:2::1/64
 ipv6 rip RIPng enable
!
interface Loopback17
 ip address 31.3.0.1 255.255.0.0
 ipv6 address 2001:31:3::1/64
 ipv6 rip RIPng enable
!
interface FastEthernet0/0
 description Connected to SW3 Fa0/24
 ip address 204.12.26.254 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:204:12:26::254/64
 ipv6 rip RIPng enable
!
interface Serial0/0
 description Connected to BB1
 ip address 172.16.4.3 255.255.255.0
!        
router rip
 version 2
 network 30.0.0.0
 network 31.0.0.0
 network 204.12.26.0
 distribute-list prefix RIP out
 distribute-list prefix DENY_DEFAULT in
 no auto-summary
!
router bgp 54
 bgp log-neighbor-changes
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor RACKS ebgp-multihop 255
 neighbor 2001:204:12:26::100 remote-as 100
 neighbor 172.16.4.1 remote-as 54
 neighbor 204.12.26.1 peer-group RACKS
 neighbor 204.12.26.2 peer-group RACKS
 neighbor 204.12.26.3 peer-group RACKS
 neighbor 204.12.26.4 peer-group RACKS
 neighbor 204.12.26.5 peer-group RACKS
 neighbor 204.12.26.6 peer-group RACKS
 neighbor 204.12.26.7 peer-group RACKS
 neighbor 204.12.26.8 peer-group RACKS
 neighbor 204.12.26.9 peer-group RACKS
 neighbor 204.12.26.10 peer-group RACKS
 !
 address-family ipv4
  neighbor RACKS send-community
  neighbor RACKS route-map BGP_IN in
  neighbor RACKS route-map BGP_OUT out
  no neighbor 2001:204:12:26::100 activate
  neighbor 172.16.4.1 activate
  neighbor 172.16.4.1 send-community
  neighbor 172.16.4.1 next-hop-self
  neighbor 204.12.26.1 activate
  neighbor 204.12.26.2 activate
  neighbor 204.12.26.3 activate
  neighbor 204.12.26.4 activate
  neighbor 204.12.26.5 activate
  neighbor 204.12.26.6 activate
  neighbor 204.12.26.7 activate
  neighbor 204.12.26.8 activate
  neighbor 204.12.26.9 activate
  neighbor 204.12.26.10 activate
  no auto-summary
  no synchronization
  network 28.119.16.0 mask 255.255.255.0
  network 28.119.17.0 mask 255.255.255.0
 exit-address-family
 !
 address-family ipv6
  neighbor 2001:204:12:26::100 activate
  network 2001:28:119:16::/64
  network 2001:28:119:17::/64
 exit-address-family
!
ip forward-protocol nd
ip route 54.0.0.0 255.0.0.0 172.16.4.1
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list DENY_DEFAULT seq 5 deny 0.0.0.0/0
ipv6 router rip RIPng
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!        
ntp authentication-key 1 md5 1531223F2705 7
!
end

RS.26.26.BB3#

 

 

Comments

  • I figured it out.

    For some reason when I applied the route-map to one BGP neighbor it seemed to apply it to all the neighbors. I had to remove the route-map from the the bgp neighbor 140.26.100.5 and then re-add it. Then it only applied to that neighbor, which fixed my BGP advertisement issue between R3 and BB3.

    ////////////////

    ip prefix-list AGGREGATE seq 5 permit 140.26.0.0/16  <<<----
    !
    route-map DENY_AGGREGATE deny 10 <<<----
     match ip address prefix-list AGGREGATE
    !
    route-map DENY_AGGREGATE permit 10000

    /////////////////

    RSRack26R3#sh ip bgp nei 204.12.26.254 adv
    BGP table version is 90, local router ID is 150.26.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network          Next Hop            Metric LocPrf Weight Path
    *>i28.119.16.0/24   54.26.2.254              0    150      0 54 i
    *>i28.119.17.0/24   54.26.2.254              0    150      0 54 i
    *>i112.0.0.0        54.26.2.254              0    150      0 54 50 60 i
    *>i113.0.0.0        54.26.2.254              0     50      0 54 50 60 i
    *>i114.0.0.0        54.26.2.254              0    150      0 54 i
    *>i115.0.0.0        54.26.2.254              0     50      0 54 i
    *>i116.0.0.0        54.26.2.254              0    150      0 54 i
    *>i117.0.0.0        54.26.2.254              0     50      0 54 i
    *>i118.0.0.0        54.26.2.254              0    150      0 54 i
    *>i119.0.0.0        54.26.2.254              0     50      0 54 i
    *> 140.26.0.0       0.0.0.0                            32768 i

    Total number of prefixes 11
    RSRack26R3#

    RSRack26R3(config)#router bgp 100                                      
    RSRack26R3(config-router)#no neighbor 140.26.100.5 route-map DENY_AGGREGATE out   <<<--- removing it
    RSRack26R3(config-router)#do clear ip bgp *                                     
    RSRack26R3(config-router)#neighbor 140.26.100.5 route-map DENY_AGGREGATE out  <<<--- re-adding it

    RSRack26R3#sh ip bgp
    BGP table version is 15, local router ID is 150.26.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

       Network          Next Hop            Metric LocPrf Weight Path
    *  28.119.16.0/24   204.12.26.254            0             0 54 i
    *>i                 54.26.2.254              0    150      0 54 i
    *  28.119.17.0/24   204.12.26.254            0             0 54 i
    *>i                 54.26.2.254              0    150      0 54 i
    *  112.0.0.0        204.12.26.254                          0 54 50 60 i
    *>i                 54.26.2.254              0    150      0 54 50 60 i
    *> 113.0.0.0        204.12.26.254                          0 54 50 60 i
    *  114.0.0.0        204.12.26.254                          0 54 i
    *>i                 54.26.2.254              0    150      0 54 i
    *> 115.0.0.0        204.12.26.254                          0 54 i
    *  116.0.0.0        204.12.26.254                          0 54 i
    *>i                 54.26.2.254              0    150      0 54 i
    *> 117.0.0.0        204.12.26.254                          0 54 i
    *  118.0.0.0        204.12.26.254                          0 54 i
    *>i                 54.26.2.254              0    150      0 54 i
    *> 119.0.0.0        204.12.26.254                          0 54 i
    *> 140.26.0.0       0.0.0.0                            32768 i
       Network          Next Hop            Metric LocPrf Weight Path
    * i                 140.26.100.6             0    100      0 i
    s> 140.26.8.0/24    140.26.100.5                           0 200 400 i
    RSRack26R3#traceroute 116.0.0.1

    Type escape sequence to abort.
    Tracing the route to 116.0.0.1

      1 140.26.100.6 4 msec 0 msec 4 msec
      2 54.26.2.254 16 msec *  12 msec
    RSRack26R3#traceroute 117.0.0.1

    Type escape sequence to abort.
    Tracing the route to 117.0.0.1

      1 204.12.26.254 0 msec 4 msec 4 msec
      2 172.16.4.1 13 msec *  12 msec
    RSRack26R3#

     

     

Sign In or Register to comment.