4.4 Having problem with virtual-access in R5

When i configure OSPF on R5 between R1 an R2 this is what i see.

 


interface Serial2/0:0.1 multipoint

 frame-relay interface-dlci 501 ppp Virtual-Template1

 frame-relay interface-dlci 502 ppp Virtual-Template1

end

 

R5#


R5#show ip ospf neighbor 

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

150.1.2.2         0   FULL/  -        00:01:46    128.1.125.2     Virtual-Access3

150.1.1.1         0   FULL/  -        00:01:38    128.1.125.1     Virtual-Access2

R5#

 


     128.1.0.0/16 is variably subnetted, 10 subnets, 2 masks

O IA    128.1.136.0/24 [110/2] via 128.1.125.1, 00:00:22, Virtual-Access3

C       128.1.5.0/24 is directly connected, GigabitEthernet0/2

O IA    128.1.27.0/24 [110/2] via 128.1.125.2, 00:00:22, Virtual-Access3

C       128.1.45.4/32 is directly connected, Serial2/7:0

C       128.1.45.0/24 is directly connected, Serial2/7:0

C       128.1.59.0/24 is directly connected, GigabitEthernet0/1

O IA    128.1.63.0/24 [110/1002] via 128.1.125.1, 00:00:22, Virtual-Access3

C       128.1.125.0/24 is directly connected, Virtual-Access2

                       is directly connected, Virtual-Access3

C       128.1.125.1/32 is directly connected, Virtual-Access2

C       128.1.125.2/32 is directly connected, Virtual-Access3

     150.1.0.0/24 is subnetted, 1 subnets

C       150.1.5.0 is directly connected, Loopback0

 


R5#ping 128.1.136.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 128.1.136.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

 

To reach network 128.1.136.0/24 it takes through VA3.

What i have to do is to delete "frame-relay interface-dlci 501 ppp Virtual-Template1" and copy it again on the interface

and this is the result


R5#show run int ser2/0:0.1

Building configuration...

 

Current configuration : 150 bytes

!

interface Serial2/0:0.1 multipoint

 frame-relay interface-dlci 501 ppp Virtual-Template1

 frame-relay interface-dlci 502 ppp Virtual-Template1

end

 

R5#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R5(config)#int ser2/0:0.1

R5(config-subif)#no  frame-relay interface-dlci 501 ppp Virtual-Template1

R5(config-subif)#frame-relay interface-dlci 501 ppp Virtual-Template1

 


     128.1.0.0/16 is variably subnetted, 10 subnets, 2 masks

O IA    128.1.136.0/24 [110/2] via 128.1.125.1, 00:00:40, Virtual-Access2

C       128.1.5.0/24 is directly connected, GigabitEthernet0/2

O IA    128.1.27.0/24 [110/2] via 128.1.125.2, 00:00:30, Virtual-Access2

C       128.1.45.4/32 is directly connected, Serial2/7:0

C       128.1.45.0/24 is directly connected, Serial2/7:0

C       128.1.59.0/24 is directly connected, GigabitEthernet0/1

O IA    128.1.63.0/24 [110/1002] via 128.1.125.1, 00:00:40, Virtual-Access2

C       128.1.125.0/24 is directly connected, Virtual-Access3

                       is directly connected, Virtual-Access2

C       128.1.125.1/32 is directly connected, Virtual-Access2

C       128.1.125.2/32 is directly connected, Virtual-Access3

     150.1.0.0/24 is subnetted, 1 subnets

C       150.1.5.0 is directly connected, Loopback0

R5#

 

Now is taking to VA2

 


R5#ping 128.1.136.3       

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 128.1.136.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

The problem i see is that on task 4.5 after i create the Virtual Links ti reach to network 128.1.27.0 changes to VA2

 

how can i fix this?

Comments

  • What is your OSPF network type on Virtual Template Interfaces? It should be P2MP


  • R1#show ip ospf neighbor 

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    150.1.5.5         0   FULL/  -           -        128.1.125.5     OSPF_VL6

    150.1.5.5         0   FULL/  -        00:01:59    128.1.125.5     Virtual-Access1

    R1#show ip ospf interface brief 

    Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

    Fa0/0.1      1     0.0.0.0         128.1.136.1/24     1     DR    0/0

    VL6          1     0.0.0.0         128.1.125.1/24     1     P2P   1/1

    Vt1          1     125             128.1.125.1/24     1     DOWN  0/0

    Vi1          1     125             128.1.125.1/24     1     P2MP  1/1

    Lo0          1     321             150.1.1.1/24       1     LOOP  0/0

    R1#

     


    R2#show ip ospf neighbor 

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    150.1.5.5         0   FULL/  -           -        128.1.125.5     OSPF_VL5

    150.1.5.5         0   FULL/  -        00:01:45    128.1.125.5     Virtual-Access1

    R2#show ip ospf interface brief 

    Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

    Tu0          1     0               128.1.72.2/24      1000  P2P   0/0

    VL5          1     0               128.1.125.2/24     1     P2P   1/1

    Fa0/0        1     12              128.1.27.2/24      1     DR    0/0

    Vt1          1     125             128.1.125.2/24     1     DOWN  0/0

    Vi1          1     125             128.1.125.2/24     1     P2MP  1/1

    Lo0          1     321             150.1.2.2/24       1     LOOP  0/0

    R2#


    R5#show ip ospf neighbor 

     

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    150.1.1.1         0   FULL/  -           -        128.1.125.1     OSPF_VL5

    150.1.2.2         0   FULL/  -           -        128.1.125.2     OSPF_VL4

    150.1.2.2         0   FULL/  -        00:01:44    128.1.125.2     Virtual-Access2

    150.1.1.1         0   FULL/  -        00:01:38    128.1.125.1     Virtual-Access1

    R5#show ip ospf interface brief 

    Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C

    VL5          1     0               128.1.125.5/24     1     P2P   1/1

    VL4          1     0               128.1.125.5/24     1     P2P   1/1

    Vi2          1     125             128.1.125.5/24     1     P2MP  1/1

    Vt1          1     125             128.1.125.5/24     1     DOWN  0/0

    Vi1          1     125             128.1.125.5/24     1     P2MP  1/1

    Lo0          1     765             150.1.5.5/24       1     LOOP  0/0

    R5#



  • R5#show run int virtual-template 1

    Building configuration...

     

    Current configuration : 110 bytes

    !

    interface Virtual-Template1

     ip address 128.1.125.5 255.255.255.0

     ip ospf network point-to-multipoint

    end

     

    R5#


    R2#show run int virtual-template 1

    Building configuration...

     

    Current configuration : 110 bytes

    !

    interface Virtual-Template1

     ip address 128.1.125.2 255.255.255.0

     ip ospf network point-to-multipoint

    end

     

    R2#

  • Couple things on virtual template interfaces:

    1) enable encapsulation ppp

    2) enable peer neighbor route

    This should fix your problem as route recursion will work properly.

  • That won't fix it. Even with /32 routes, OSPF will still use one virtual link to send packets, most of the time.

    Running OSPF over multipoint PPPoFR links is a recipe for disaster. There are workarounds, like using unnumbered, or simply running point-to-point subinterfaces making sure only one virtual interface is attached per subinterface.

    Other than that you will always get mixed results depending on your IOS.

  • Thanks Dhrumil,

    i apply the encapsulation ppp on the virtual template but it does not appear on the config. its the default behavior for VT as it works on ppp environment.

    the enable peer neighbor route, i just missed that part. dont understand what you mean

    regards

  • thanks jkdrouter, so how do i proceed with this lab, as lab 6 goes in the same direction.

    who from INE can explain me how to proceed from that point. Do someone has done this lab effectively.

    regards

  • That is right, IOS might work differently depending on platform/version. When you enable "peer neighbor-route" command on vitrual template, in most IOSs it is enabled by default as soon as you enable ppp encap, it will install /32 IP as directly connected interface which will recurse back to the virtual access interface it is learnt from. this way, you will have proper /32s installed as next hop connected IPs and other subnets are reached properly.

    Now, sometimes, you might have to bounce the physical interface or might need to reload the router but i believe, that should work.

  • That is right, IOS might work differently depending on platform/version. When you enable "peer neighbor-route" command on vitrual template, in most IOSs it is enabled by default as soon as you enable ppp encap, it will install /32 IP as directly connected interface which will recurse back to the virtual access interface it is learnt from. this way, you will have proper /32s installed as next hop connected IPs and other subnets are reached properly.

    Now, sometimes, you might have to bounce the physical interface or might need to reload the router but i believe, that should work.

    With peer neighbor-route after a reload it shows tha same state:


    RSRack5R5#sh ip route 128.5.136.0

    Routing entry for 128.5.136.0/24

      Known via "ospf 1", distance 110, metric 11, type intra area

      Last update from 128.5.125.1 on Virtual-Access2, 00:00:36 ago

      Routing Descriptor Blocks:

      * 128.5.125.1, from 150.5.3.3, 00:00:36 ago, via Virtual-Access2

          Route metric is 11, traffic share count is 1


    RSRack5R5#sh ip route 128.5.125.1

    Routing entry for 128.5.125.1/32

      Known via "connected", distance 0, metric 0 (connected, via interface)

      Routing Descriptor Blocks:

      * directly connected, via Virtual-Access1

          Route metric is 0, traffic share count is 1



    IMHO it is a definit bug. TAC would say "It is not designed to be used this way" ;)


    just guessing.


    Gabor

  •  

    thanks jkdrouter, so how do i proceed with this lab, as lab 6 goes in the same direction.

    who from INE can explain me how to proceed from that point. Do someone has done this lab effectively.

     


    To proceed, you can use jkdrouter's proposal:

     

     

    RSRack5R5#sh run in virtual-template 1 | b interface

    interface Virtual-Template1

    ip unnumbered Loopback1

    ip ospf network point-to-point

    end

     


    RSRack5R5#sh run in lo1 | b interface

    interface Loopback1

     ip address 128.5.125.5 255.255.255.0

    end

     


    RSRack5R2#sh run in virtual-template 1 | b interface

    interface Virtual-Template1

     ip unnumbered Loopback1

     ip ospf network point-to-point

    end

     


    RSRack5R2#sh run in lo 1 | b interface

    interface Loopback1

     ip address 128.5.125.2 255.255.255.0

    end


     


    RSRack5R1#sh running-config in virtual-template 1 | b interface

    interface Virtual-Template1

     ip unnumbered Loopback1

     ip ospf network point-to-point

    end

     



    RSRack5R1#sh running-config in lo 1 | b interface

    interface Loopback1

     ip address 128.5.125.1 255.255.255.0

    end

     



    RSRack5R5#sh ip route 128.5.136.3

    Routing entry for 128.5.136.0/24

      Known via "ospf 1", distance 110, metric 11, type intra area

      Last update from 128.5.125.1 on Virtual-Access1, 00:10:43 ago

      Routing Descriptor Blocks:

      * 128.5.125.1, from 150.5.3.3, 00:10:43 ago, via Virtual-Access1

          Route metric is 11, traffic share count is 1

     



    RSRack5R5#sh ip route 128.5.125.1

    Routing entry for 128.5.125.1/32

      Known via "connected", distance 0, metric 0 (connected, via interface)

      Routing Descriptor Blocks:

      * directly connected, via Virtual-Access1

          Route metric is 0, traffic share count is 1











     



  • not working for me..

    I've setup ip unnumbered to loo 1 and ip addresses on loopback1. I've tried with p-t-p and p-t-m on virtual-template1 but from R1 I can't ping R2 loo 2.

    From R5 I can ping R1 and R2 loopbacks.

    In this way I cannot setup the virtual link and go ahead with tasks

    Am I the only one with this issue?

  • Thanks for this soltution Gabor. :)

    This lab is eating me more time than a full-scale lab. It's crazy!

    Vincent

     

  • This lab is completely wrong. Lets open up a Q/A ticket. Even the SG solution doesn't even work! and also found some more typos in the SG. This is why at times I get frustrated with INE labs!!!

  • yes you are right. there is an issue with this setup. I faced the same issue labing this up today.

    I ended up removing the PPPoFR setup to a regular HUB-n-SPOKE topology.

     

  • Hi Guys

     

    I faced this connectivity issue on WB-LAB5 OSPF. ALL my configs follow exactly whats in the Solution Guide.

     

     

    R5 can see routes from R1 via 128.1.125.1 (R1's PPPoFR interface).

    Bur R5 cannot ping any network reachable via R1. Also a trace route from SW1 to networks off R1 result in a loop between R5 and R2.

     

    Did any one face a similar issue. What did I miss here. Appreciate any feedback.

     

     

     

    Results of show/ping/trace

    -------------------------

     

     

     

    Rack1R5#sh ip rou os

         51.0.0.0/32 is subnetted, 1 subnets

    O E2    51.51.51.51 [110/20] via 128.1.125.2, 00:21:18, Virtual-Access2

         128.1.0.0/16 is variably subnetted, 13 subnets, 2 masks

    O       128.1.136.0/24 [110/2] via 128.1.125.1, 00:21:18, Virtual-Access2

    O       128.1.12.0/24 [110/11112] via 128.1.125.2, 00:21:18, Virtual-Access2

    O E2    128.1.14.0/24 [110/20] via 128.1.125.1, 00:08:17, Virtual-Access2

    O IA    128.1.27.0/24 [110/2] via 128.1.125.2, 00:21:18, Virtual-Access2

    O E2    128.1.48.0/24 [110/20] via 128.1.125.1, 00:08:17, Virtual-Access2

    O IA 192.10.1.0/24 [110/11113] via 128.1.125.2, 00:21:18, Virtual-Access2

         150.1.0.0/16 is variably subnetted, 8 subnets, 2 masks

    O IA    150.1.7.7/32 [110/11113] via 128.1.125.2, 00:21:18, Virtual-Access2

    O IA    150.1.6.6/32 [110/3] via 128.1.125.1, 00:21:18, Virtual-Access2

    O IA    150.1.3.3/32 [110/3] via 128.1.125.1, 00:21:18, Virtual-Access2

    O IA    150.1.2.2/32 [110/2] via 128.1.125.2, 00:21:18, Virtual-Access2

    O IA    150.1.1.1/32 [110/2] via 128.1.125.1, 00:21:19, Virtual-Access2

    O E2    150.1.8.0/24 [110/20] via 128.1.125.1, 00:08:19, Virtual-Access2

    Rack1R5#

     

     

     

    Rack1R5#sh run int s0/0/0.1

    Building configuration...

     

    Current configuration : 173 bytes

    !

    interface Serial0/0/0.1 multipoint

     snmp trap link-status

     frame-relay interface-dlci 501 ppp Virtual-Template1

     frame-relay interface-dlci 502 ppp Virtual-Template1

    end

     

     

     

    Rack1R5#sh run int Virtual-Template1

    Building configuration...

     

    Current configuration : 111 bytes

    !

    interface Virtual-Template1

     ip address 128.1.125.5 255.255.255.0

     ip ospf network point-to-multipoint

     

     

    ON R5

    ----

     

    Rack1R5#ping 150.1.1.1

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 150.1.1.1, timeout is 2 seconds:

    .....

    Success rate is 0 percent (0/5)

     

     

    ON R1 Sourcing from RPF interface

    --------------------------------

     

    Rack1R1#ping 150.1.5.5

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 150.1.5.5, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 60/60/64 ms

     

     

     

    ON R1 soucing from Loop0

    --------------------------

     

    Rack1R1#ping 150.1.5.5 so lo0

     

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 150.1.5.5, timeout is 2 seconds:

    Packet sent with a source address of 150.1.1.1

    .....

    Success rate is 0 percent (0/5)

     

     

    SW1

    ---

     

    Rack1SW1#traceroute 150.1.1.1

     

    Type escape sequence to abort.

    Tracing the route to 150.1.1.1

     

      1 128.1.12.2 0 msec 8 msec 0 msec

      2 128.1.125.5 34 msec 33 msec 34 msec

      3 128.1.125.2 25 msec 42 msec 34 msec

      4 128.1.125.5 75 msec 67 msec 67 msec

      5 128.1.125.2 67 msec 76 msec 67 msec

      6 128.1.125.5 109 msec 101 msec 101 msec

      7 128.1.125.2 100 msec 109 msec 101 msec

      8 128.1.125.5 151 msec 143 msec 134 msec

      9 128.1.125.2 143 msec 134 msec 142 msec

     10 128.1.125.5 177 msec 176 msec 176 msec

     11 128.1.125.2 176 msec 168 msec 168 msec

     12 128.1.125.5 209 msec 210 msec 210 msec

     13 128.1.125.2 209 msec 210 msec 210 msec

     14 128.1.125.5 252 msec 243 msec 251 msec

     15 128.1.125.2 244 msec 243 msec 243 msec

     16 128.1.125.5 277 msec 269 msec 285 msec

     17 128.1.125.2 277 msec 276 msec 286 msec

     18 128.1.125.5 318 msec 311 msec 311 msec

     19 128.1.125.2 310 msec 311 msec 302 msec

     20 128.1.125.5 352 msec 352 msec 344 msec

     21 128.1.125.2 353 msec 352 msec 344 msec

     22 128.1.125.5 394 msec 369 msec 386 msec

     23 128.1.125.2 378 msec 386 msec 377 msec

     24 128.1.125.5 428 msec 420 msec 419 msec

     25 128.1.125.2 395 msec 427 msec 420 msec

     26 128.1.125.5 461 msec 453 msec 453 msec

     27 128.1.125.2 445 msec 453 msec 453 msec

     

     

    R2 and R6 have routes in routing table but are not able to reach any networks beyond R1

    ----------------------------------------------------------------------------------------

  • Hi Guys

     

    I faced this connectivity issue on WB-LAB5 OSPF. ALL my configs follow exactly whats in the Solution Guide.

     

     

    R5 can see routes from R1 via 128.1.125.1 (R1's PPPoFR interface).

    Bur R5 cannot ping any network reachable via R1. Also a trace route from SW1 to networks off R1 result in a loop between R5 and R2.

     

    Did any one face a similar issue. What did I miss here. Appreciate any feedback.

     

    R2 and R6 have routes in routing table but are not able to reach any networks beyond R1

    ----------------------------------------------------------------------------------------

    Hi 

    First of all test the point-to-point reachability between R1 & R5 and make sure that the point to point link is ok. When pinging from R5 to R1's loopback interface, enable "debug ip packet detail" command which would show you the reason of not routing the traffic.

    R1 can ping R5's loopback interface indicates that the physical interface of R1 and R5's loopback know each others. I suspect that the reason could be in PPPoFR or any common mistake which you are not being able to determine. Please give a try with what I mentioned above and let us know what happens. Also post the configuration of R1 and "show ip route" if you still face the same issue.

    Good luck!

  • Thanks Hari for feedback. I ran this lab yeterday I cannot provide the sh ip route output of R1 but I can tell you that it has all routes in table wih correct next hops. From other posts regarding this issue i assume that others also faced similar symptoms.

    My configs are exact same as solution guide. PPPoFR is up and working for same subnet reachabilty between R1,R2, and R5. Virtual-liks across area 125 is ok. Virtual-temp interfaces are OSPF P2MP network type.

    My lab exam is coming up soon so I dont think I am able to repeat this lab again I have to move on to other labs.

    Thanks again.

Sign In or Register to comment.