eigrp stub not working

I have configured a set of routers exactly like the examples in the route.part2.eigrp.1.00.pdf within a GNS3 project and followed all the instructions to setup a stub interface however when I run the debug eigrp packets terse I still get queries at router R1. Here is the output.  My configuration is at the end of this output.

*Mar  2 23:20:57.376: EIGRP: received packet with MD5 authentication, key id = 1
*Mar  2 23:20:58.712: EIGRP: received packet with MD5 authentication, key id = 1
*Mar  2 23:20:58.712: EIGRP: Received QUERY on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:58.712:   AS 1, Flags 0x0, Seq 242/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  2 23:20:58.716: EIGRP: Enqueueing ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:58.716:   Ack seq 242 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 23:20:58.720: EIGRP: Sending ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:58.720:   AS 1, Flags 0x0, Seq 0/242 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 23:20:59.084: EIGRP: received packet with MD5 authentication, key id = 1
*Mar  2 23:20:59.088: EIGRP: Received UPDATE on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.088:   AS 1, Flags 0x0, Seq 243/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  2 23:20:59.088: EIGRP: Enqueueing ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.092:   Ack seq 243 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 23:20:59.092: EIGRP: Sending ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.096:   AS 1, Flags 0x0, Seq 0/243 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 23:20:59.104: EIGRP: Enqueueing QUERY on FastEthernet0/0.12 iidbQ un/rely 0/1 serno 116-116
*Mar  2 23:20:59.108: EIGRP: Enqueueing QUERY on FastEthernet0/0.12 nbr 10.1.12.2 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 116-116
*Mar  2 23:20:59.112: EIGRP: Sending QUERY on FastEthernet0/0.12
*Mar  2 23:20:59.112:   AS 1, Flags 0x0, Seq 76/0 idbQ 0/0 iidbQ un/rely 0/0 serno 116-116
*Mar  2 23:20:59.168: EIGRP: Received ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.168:   AS 1, Flags 0x0, Seq 0/76 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
*Mar  2 23:20:59.172: EIGRP: FastEthernet0/0.12 multicast flow blocking cleared
*Mar  2 23:20:59.172: EIGRP: received packet with MD5 authentication, key id = 1
*Mar  2 23:20:59.172: EIGRP: Received REPLY on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.176:   AS 1, Flags 0x0, Seq 246/76 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  2 23:20:59.176: EIGRP: Enqueueing ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.176:   Ack seq 246 iidbQ un/rely 0/0 peerQ un/rely 1/0
*Mar  2 23:20:59.180: EIGRP: Sending ACK on FastEthernet0/0.12 nbr 10.1.12.2
*Mar  2 23:20:59.184:   AS 1, Flags 0x0, Seq 0/246 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rel

R1#sh run | sec router
router eigrp 1
 passive-interface Loopback0
 passive-interface Loopback1
 passive-interface Loopback2
 passive-interface Loopback3
 network 1.0.0.0
 network 10.0.0.0
 network 0.0.0.0
 no auto-summary
 eigrp stub connected static summary
R1#

R1#sh run | sec interface
interface Loopback0
 ip address 1.0.0.1 255.255.0.0
interface Loopback1
 ip address 1.1.0.1 255.255.0.0
interface Loopback2
 ip address 1.2.0.1 255.255.0.0
interface Loopback3
 ip address 1.3.0.1 255.255.0.0
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
interface FastEthernet0/0.12
 encapsulation dot1Q 1 native
 ip address 10.1.12.1 255.255.255.252
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP-KEY-CHAIN
 ip summary-address eigrp 1 1.0.0.0 255.255.0.0 5

 R2#sh ip eigrp neighbors detail fastEthernet 0/0
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   10.1.12.1               Fa0/0             12 00:17:10   88   528  0  77
   Restart time 00:16:58
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 5
   Stub Peer Advertising ( CONNECTED STATIC SUMMARY ) Routes
   Suppressing queries
R2#

 

Comments

  • EIGRP is something that I had lots of issues with while running on GNS. Maybe because its a Cisco Baby only and dont like to get run on somewhere else.

    I would suggest you to save your configs on all routers and reload them all together.

     

    Also It will be great if you can draw your test topology in MS paint or something (to save time) and present configs for each device you configured.

     



    HTH...

    Deepak Arora

    http://www.deepakarora1984.blogspot.com

  • What I have noticed is that R2 Sends the query however R1 ACKs the message but does not reply.

    image

    R1 Config:
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    key chain EIGRP-KEY-CHAIN
     key 1
       key-string cisco
    !
    interface Loopback0
     ip address 1.0.0.1 255.255.0.0
    !
    interface Loopback1
     ip address 1.1.0.1 255.255.0.0
    !
    interface Loopback2
     ip address 1.2.0.1 255.255.0.0
    !
    interface Loopback3
     ip address 1.3.0.1 255.255.0.0
    !
    interface FastEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/0.12
     encapsulation dot1Q 1 native
     ip address 10.1.12.1 255.255.255.252
     ip authentication mode eigrp 1 md5
     ip authentication key-chain eigrp 1 EIGRP-KEY-CHAIN
     ip summary-address eigrp 1 1.0.0.0 255.255.0.0 5
    !
    interface FastEthernet1/0
     no ip address
     delay 10
     shutdown
     duplex auto
     speed auto
    !
    interface FastEthernet2/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    router eigrp 1
     passive-interface Loopback0
     passive-interface Loopback1
     passive-interface Loopback2
     passive-interface Loopback3
     network 1.0.0.0
     network 10.0.0.0
     network 0.0.0.0
     no auto-summary
     eigrp stub connected static summary
    !
    ip http server
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Null0
    !

    control-plane
    !
    line con 0
    line aux 0
    line vty 0 4
     logging synchronous
     login
    !
    !
    end

    R2 Config:


    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    !
    !
    ip cef
    no ip domain lookup
    !
    key chain EIGRP-KEY-CHAIN
     key 1
       key-string cisco
    !
    interface Loopback0
     ip address 10.1.2.1 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 10.1.12.2 255.255.255.252
     ip authentication mode eigrp 1 md5
     ip authentication key-chain eigrp 1 EIGRP-KEY-CHAIN
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     ip address 10.1.25.1 255.255.255.252
     ip authentication mode eigrp 1 md5
     ip authentication key-chain eigrp 1 EIGRP-KEY-CHAIN
     delay 15
     duplex auto
     speed auto
    !
    interface FastEthernet2/0
     ip address 10.1.23.1 255.255.255.252
     ip authentication mode eigrp 1 md5
     ip authentication key-chain eigrp 1 EIGRP-KEY-CHAIN
     duplex auto
     speed auto
    !
    router eigrp 1
     variance 2
     passive-interface Loopback0
     network 10.0.0.0
     no auto-summary
    !
    control-plane
    !
    line con 0
    line aux 0
    line vty 0 4
     logging synchronous
     login
    !
    !
    end

     

     

     

  • Query packets uses RTP If I remember correctly. So they must be acknowledged. 

     



    HTH...

    Deepak Arora

    http://www.deepakarora1984.blogspot.com

Sign In or Register to comment.