Task 3.5

Is there any reason why we can not use a route-map applied to the E0/0 interface of R4 to accomplish Task 3.5? My solution is below...

ip access-list extended VLAN7->5
permit ip 164.1.7.0 0.0.0.255 164.1.5.0 0.0.0.255
!
route-map ETHERNET permit 10
match ip address VLAN7->5
set ip next-hop 164.1.45.5
route-map ETHERNET permit 1000

Thanks,
Robb

Comments

  • Nevermind... I just saw the rules about no policy routing...
  • I used an inbound distribute list applied to OSPF to prevent the route to VLAN5 from the FR link being advertised into the routing table.
    Would this be acceptable, it doesn't appear to break any rules and it keeps OSPF areas clearly defined.

    router ospf 1
    distribute-list route-map INTRA_AREA in
    !
    ip prefix-list VLAN5 seq 5 permit 164.1.5.0/24
    !
    route-map INTRA_AREA deny 10
    match ip address prefix-list VLAN5
    match interface Serial0/1
    !
    route-map INTRA_AREA permit 20

    Andy
Sign In or Register to comment.