1.17 EtherChannel over 802.1q Tunneling

Hi all,

 

  I'm having problem completing this lab. At first, I tried to do it my way, but didn't succeed so I followed the answer posted in the solutions. However, I copy paste them into the configuration and the tunnel still didn't come up. I'm using lab equipments at packetlife.net, which has an identical L2 configuration among the switches, except that all ports on Sw2 are GE rather than FE. I also tried to tweak the speed and duplex specifically between Sw1 and Sw2, but the tunnel still didn't come up. Please help...

================================================================


hostname Rack1Sw1

ip routing

!

interface Port-channel14

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

!

interface FastEthernet0/13

 description f0/13-15 connects Sw2

 switchport trunk encapsulation dot1q

 switchport mode trunk

 speed 100

 duplex full

 channel-group 14 mode active

!

interface FastEthernet0/14

 switchport trunk encapsulation dot1q

 switchport mode trunk

 speed 100

 duplex full

 channel-group 14 mode active

!

interface FastEthernet0/15

 switchport trunk encapsulation dot1q

 switchport mode trunk

 speed 100

 duplex full

 channel-group 14 mode active

!

interface FastEthernet0/19

 description f0/19-21 originally connects to Sw4 directly

 switchport trunk encapsulation dot1q

 switchport mode trunk

 shutdown

 channel-group 14 mode active

!

interface FastEthernet0/20

 switchport trunk encapsulation dot1q

 switchport mode trunk

 shutdown

 channel-group 14 mode active

!         

interface FastEthernet0/21

 switchport trunk encapsulation dot1q

 switchport mode trunk

 shutdown

 channel-group 14 mode active

=========================================================


hostname Rack1Sw2

system mtu routing 1504

ip routing

!

interface Port-channel21

 description L2 EtherChannel to Sw1

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface Port-channel24

 description L3 EtherChannel to Sw4

 no switchport

 ip address 155.1.108.8 255.255.255.0

!

interface GigabitEthernet0/13

 description g0/13-15 connects to Sw1

 switchport access vlan 100

 switchport trunk encapsulation dot1q

 switchport mode dot1q-tunnel

 speed 100

 duplex full

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel point-to-point lacp

 no cdp enable

!

interface GigabitEthernet0/14

 switchport access vlan 200

 switchport trunk encapsulation dot1q

 switchport mode dot1q-tunnel

 speed 100

 duplex full

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel point-to-point lacp

 no cdp enable

!

interface GigabitEthernet0/15

 switchport access vlan 300

 switchport trunk encapsulation dot1q

 switchport mode dot1q-tunnel

 speed 100

 duplex full

 l2protocol-tunnel cdp

 l2protocol-tunnel stp

 l2protocol-tunnel point-to-point lacp

 no cdp enable

!

interface GigabitEthernet0/16

 description g0/16-18 connects to Sw3

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet0/17

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet0/18

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet0/19

 description g0/19-21 forms etherchannel between Sw2 and Sw4

 no switchport

 no ip address

 channel-group 24 mode on

!         

interface GigabitEthernet0/20

 no switchport

 no ip address

 channel-group 24 mode on

!

interface GigabitEthernet0/21

 no switchport

 no ip address

 channel-group 24 mode on

 

 

Comments


  • hostname Rack1Sw3

    !

    ip routing

    !

    interface Port-channel31

     description L2 EtherChannel trunk to Sw1

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/13

     switchport trunk encapsulation dot1q

     switchport mode trunk

     channel-group 31 mode passive

    !

    interface FastEthernet0/14

     switchport trunk encapsulation dot1q

     switchport mode trunk

     channel-group 31 mode passive

    !

    interface FastEthernet0/15

     switchport trunk encapsulation dot1q

     switchport mode trunk

     channel-group 31 mode passive

    !

    interface FastEthernet0/16

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/17

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/18

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/19

     switchport access vlan 100

     switchport trunk encapsulation dot1q

     switchport mode dot1q-tunnel

     l2protocol-tunnel cdp

     l2protocol-tunnel stp

     l2protocol-tunnel point-to-point lacp

     no cdp enable

    !

    interface FastEthernet0/20

     switchport access vlan 200

     switchport trunk encapsulation dot1q

     switchport mode dot1q-tunnel

     l2protocol-tunnel cdp

     l2protocol-tunnel stp

     l2protocol-tunnel point-to-point lacp

     no cdp enable

    !

    interface FastEthernet0/21

     switchport access vlan 300

     switchport trunk encapsulation dot1q

     switchport mode dot1q-tunnel

     l2protocol-tunnel cdp

     l2protocol-tunnel stp

     l2protocol-tunnel point-to-point lacp

     no cdp enable

    !

    ==============================================

     


    hostname Rack1Sw4

    ip routing

    !

    interface Port-channel41

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface Port-channel42

     description L3 EtherChannel to Sw2

     no switchport

     ip address 155.1.108.10 255.255.255.0

    !

    interface FastEthernet0/13

     description EtherChannel connect to Sw1 f0/13-15 directly but shut

     switchport trunk encapsulation dot1q

     switchport mode trunk

     shutdown

     channel-group 41 mode passive

    !

    interface FastEthernet0/14

     switchport trunk encapsulation dot1q

     switchport mode trunk

     shutdown

     channel-group 41 mode passive

    !

    interface FastEthernet0/15

     switchport trunk encapsulation dot1q

     switchport mode trunk

     shutdown

     channel-group 41 mode passive

    !

    interface FastEthernet0/16

     description etherchannel connect to Sw2

     no switchport

     no ip address

     channel-group 42 mode on

    !

    interface FastEthernet0/17

     no switchport

     no ip address

     channel-group 42 mode on

    !

    interface FastEthernet0/18

     no switchport

     no ip address

     channel-group 42 mode on

    !

    interface FastEthernet0/19

     description trunk to Sw3

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/20

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    interface FastEthernet0/21

     switchport trunk encapsulation dot1q

     switchport mode trunk

    !

    =========================================

    Only Sw3 shows established dot1q tunnel, Sw2 doesn't

     


    Rack1Sw3#show dot1q-t

     

    dot1q-tunnel mode LAN Port(s)

    -----------------------------

    Fa0/19

    Fa0/20

    Fa0/21

    =====================



    Rack1Sw2#show dot1q-tunnel    


    dot1q-tunnel mode LAN Port(s)

    -----------------------------

    No ports have been configured as dot1q-tunnel



  • I added 'channel-group 41 mode passive' on Sw4, the tunnel came up, but now ports on Sw1 are down due to Sw2's loop guard enabled and therefore the etherchannel is not up. Sw4 doesn't seem to be part of Sw1's CDP neighbors, and even after disabling Loop Guard on Sw2, Sw1 ports are still down! Help

     

    Regards,

    Angela

  • I too face the same issue. I dont have any problen in tunnelling the Trunk. But I could not tunnel the Port channel sucessfully :(.. It gives me an error like this "l2ptguard error detected on Fa0/15" and going to err-disabled state..

     

    Please help..

  • I tried the lab again today, and it seems like Sw1 and Sw4 are completely un-aware of each other's STP configuration and claims themselves as root. No sign of connected CDP neighbors either. However, R1 can ping R4 and vice versa, no sign they are directly connected either. Seems like Dot1q tunnel only segregate the switches, and do nothing more.

  • Sorry to resurrect an old thread but I was working on this lab last night.

    R1 and R4 will not see each other as directly connected via CDP as CDP works only on the local link. R1 connects to SW1 and R4 connects to SW4 but note that a dot1q tunnel is not configured on SW1 and SW4 so R1 and R4 CDP packets are not tunnelled.

    What you will find is SW1 and SW4 will appear to be directly connected as the CDP packets they send out are tunnelled via SW2 and SW3 as SW2 and SW3 are configured for dot1q tunnels.

    I would also mention that it is worth shutting down ports before placing them into an Etherchannle to prevent unnecessary errors from occuring.

    Hope this helps.

    Chris

  • Hey,

     

     

    I'm not sure if you have fixed the issue.  With the time that has elapsed i would think so.  But just for anyone else in the same situation it will be an easy fix.  Let's look at  your configs on sw1:

     

    the important thing to know is that you are establishing a cdp neighborship to SW4 but it is not direct.  It is being tunneled through SW2 and SW3.  in your config you still had the direct links fa0/19-21 configured directly to SW4.  For this example you want to disable those links.  The configuration that you have on those links needs to move to the links Fa0/13-15 connecting to the tunneling switch SW2.

    int range fa0/13-15:

    switchport trunk encap dot

    swithcport mode trunk

    channel-group 14 mode des or active (your choice)

     

    int port 14

    switchport trunk encap dot

    switchport mode trunk

     

    same configs on SW4 ports connecting to SW3 fa0/19-21

     

    on the edge providers switches SW2 and SW3:

    SW2:

    int fa0/13 - 15:

    switchport access vlan 100,200,300 respectively

    switchport mode dot-1q-tunnel

    l2protocol-tunnel cdp

    int fa0/16-18:

    switchport trunk encap dot

    switchport mode trunk

     

    SW3:


    nt fa0/19 - 21:

    switchport access vlan 100,200,300 respectively

    switchport mode dot-1q-tunnel

    l2protocol-tunnel cdp

    int fa0/16-18:

    switchport trunk encap dot

    switchport mode trunk

     

    This should help out.  Pretty simple configuration.  As long as you take methodical approach.  

    Edge Core:

    1.trunk between edge switches

    2.tunnel to customer interfaces with metro tag vlan

     

    Customer:

    1.trunk to provider interfaces

    2.channel-group

    Hope this helps.

     

     

     

Sign In or Register to comment.