1.1 Layer 2 features

Hi, I think SG does not configure RSPAN vlan in SW2.

By concept vlan 10 have to exists into every switch.

SG only configures it in SW1 and SW3, missed SW2.

 

Ed


 

Comments

  • SW1, SW2 and SW3 are on the same vtp domain and are in server mode.  Once the trunks are up, SW2 should learn the RSPAN vlan 10

  • switchport nonegotiate - is it really needed in this task?

    I know that task wording states that we should not use any negotiations but dtp is not used if we  fix trunk mode to dot1q and switchport mode to trunk.

  • switchport nonegotiate - is it really needed in this task?

    I know that task wording states that we should not use any negotiations but dtp is not used if we  fix trunk mode to dot1q and switchport mode to trunk.

     

     

     

    DTP is still used when configuring trunk mode to DOT1Q and sw mode trunk :

     

    RSRack1SW1(config-if)#
    *Mar  1 00:10:15.396: %LINK-3-UPDOWN: Interface Port-channel12, changed state to down
    *Mar  1 00:10:15.396: %LINK-3-UPDOWN: Interface FastEthernet0/13, changed state to up
    *Mar  1 00:10:15.405: %LINK-3-UPDOWN: Interface FastEthernet0/14, changed state to up
    *Mar  1 00:10:15.405: %LINK-3-UPDOWN: Interface FastEthernet0/15, changed state to up
    RSRack1SW1(config-if)#do sh dtp int fa
    *Mar  1 00:10:18.945: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/14, changed state to up
    *Mar  1 00:10:18.970: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/15, changed state to up
    *Mar  1 00:10:19.045: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/13, changed state to up
    RSRack1SW1(config-if)#do sh dtp int fa0/13
    DTP information for FastEthernet0/13:
      TOS/TAS/TNS:                              TRUNK/ON/TRUNK
      TOT/TAT/TNT:                              802.1Q/802.1Q/802.1Q
      Neighbor address 1:                       001C57C85D0F
      Neighbor address 2:                       000000000000
      Hello timer expiration (sec/state):       26/RUNNING
      Access timer expiration (sec/state):      never/STOPPED
      Negotiation timer expiration (sec/state): never/STOPPED
      Multidrop timer expiration (sec/state):   never/STOPPE
    *Mar  1 00:10:19.918: %LINK-3-UPDOWN: Interface Port-channel12, changed state to up
    *Mar  1 00:10:20.924: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel12, changed state to upD
      FSM state:                                S6:TRUNK
      # times multi & trunk                     0
      Enabled:                                  yes
      In STP:                                   no

      Statistics
      ----------
      2 packets received (2 good)
      0 packets dropped
          0 nonegotiate, 0 bad version, 0 domain mismatches,
          0 bad TLVs, 0 bad TAS, 0 bad TAT, 0 bad TOT, 0 other
      3 packets output (3 good)
          3 native, 0 software encap isl, 0 isl hardware native
      0 output errors
      0 trunk timeouts
      3 link ups, last link up on Mon Mar 01 1993, 00:10:15
      3 link downs, last link down on Mon Mar 01 1993, 00:10:08

     

     

     

    You need to disable it ;

     

     

     

    RSRack1SW1#
    RSRack1SW1#sh dtp int fa0/13
    DTP information for FastEthernet0/13:
      TOS/TAS/TNS:                              TRUNK/NONEGOTIATE/TRUNK
      TOT/TAT/TNT:                              802.1Q/802.1Q/802.1Q
      Neighbor address 1:                       000000000000
      Neighbor address 2:                       000000000000
      Hello timer expiration (sec/state):       never/STOPPED
      Access timer expiration (sec/state):      never/STOPPED
      Negotiation timer expiration (sec/state): never/STOPPED
      Multidrop timer expiration (sec/state):   never/STOPPED
      FSM state:                                S6:TRUNK
      # times multi & trunk                     0
      Enabled:                                  yes
      In STP:                                   no

      Statistics
      ----------
      0 packets received (0 good)
      0 packets dropped
          0 nonegotiate, 0 bad version, 0 domain mismatches,
          0 bad TLVs, 0 bad TAS, 0 bad TAT, 0 bad TOT, 0 other
      0 packets output (0 good)
          0 native, 0 software encap isl, 0 isl hardware native
      0 output errors

    RSRack1SW1#sh run int fa0/13
    Building configuration...

    Current configuration : 145 bytes
    !
    interface FastEthernet0/13
     switchport trunk encapsulation dot1q
     switchport mode trunk
     switchport nonegotiate
     channel-group 12 mode on
    end

     

  • The task says "Configure EtherChannel..... Do not use automatic negotiations" - This means no PAGP or LACP

    The next task says configure 4 byte trunking encapsulaton.

    I did "switchport mode trunk" on both sides.

    In my opinion, this does not infer that the trunking should also be configured without negotiations or DTP disabled. And besides that, although DTP messages are still sent, the trunk is not being negotiated if both sides are "mode trunk". If one side was 'Auto' or 'Desirable', and the other side was 'Trunk' or 'Desirable', then the trunk would be negotiated. But not if both sides are 'Trunk', the trunk is still static- DTP messages are just sent incase the other side happens to be "auto" or "desirable"

  • The task says "Configure EtherChannel..... Do not use automatic negotiations" - This means no PAGP or LACP

    The next task says configure 4 byte trunking encapsulaton.

    This task say "Do not use automatic negotiations" but does not clearly mentioned which negotiation (etherchannel or trunking) so its a proctor question but if proctor does give any confirmative answer then its better to use "switchport nonegotiate" for trunk and "mode on" for port channel. That will make sure no negotiations are happening. 

     

  • This task say "Do not use automatic negotiations" but does not clearly mentioned which negotiation (etherchannel or trunking) so its a proctor question but if proctor does give any confirmative answer then its better to use "switchport nonegotiate" for trunk and "mode on" for port channel. That will make sure no negotiations are happening. 

    I agree - this task is open to interpretation, I would definitely ask the proctor, but if he doesn't help a lot, I would configure the two features to not rely on automatic negotiations, just like you said dcancerian.

    Just my 2 cents.

  • The task says "Configure EtherChannel..... Do not use automatic negotiations" - This means no PAGP or LACP

    The next task says configure 4 byte trunking encapsulaton.

    I did "switchport mode trunk" on both sides.

    In my opinion, this does not infer that the trunking should also be configured without negotiations or DTP disabled. And besides that, although DTP messages are still sent, the trunk is not being negotiated if both sides are "mode trunk". If one side was 'Auto' or 'Desirable', and the other side was 'Trunk' or 'Desirable', then the trunk would be negotiated. But not if both sides are 'Trunk', the trunk is still static- DTP messages are just sent incase the other side happens to be "auto" or "desirable"

    In my understanding "do not use automatic negotiations" is only for this etherchannel task (not for trunk task) which means do not use PAGP or LACP for etherchannel negotiation..

    Good Luck

  • In my understanding "do not use automatic negotiations" is only for this etherchannel task (not for trunk task) which means do not use PAGP or LACP for etherchannel negotiation..

    Good Luck

     

    Narayan,

    Just so I understand, why do you think this? I am not saying it is wrong, but I also take trunking and DTP as an automatic negotiation of trunk, so I take both trunking and etherchannel as capable of automatically forming and thus if the task asks not use to automatic negotiations, I would disable DTP and use etherchannel mode on.
    I am just curious here :)

    Thanks 

  • In my understanding "do not use automatic negotiations" is only for this etherchannel task (not for trunk task) which means do not use PAGP or LACP for etherchannel negotiation..

    Good Luck

    Narayan,

    Just so I understand, why do you think this? I am not saying it is wrong, but I also take trunking and DTP as an automatic negotiation of trunk, so I take both trunking and etherchannel as capable of automatically forming and thus if the task asks not use to automatic negotiations, I would disable DTP and use etherchannel mode on.
    I am just curious here :)

     

    Narayan,

    Your interpretation for this task may be correct but i would say its subjective so its a proctor question. However there is no harm if we just disable DTP for trunk as well to be on the safer side. since task does not mentioned about this at all.

  • Hi qqabdal,

    On first etherchannel configuration task you can see "Do not use automatic negotiations": this true do not use PAGP or LACP. Second task saying to configure trunk, how can you configure second task by just relaying on frist's requirement? In this case either there should be something more information for trunk configuration else we should leave as it is (default DTP) or we can run to proctor.

  • Hi qqabdal,

    On first etherchannel configuration task you can see "Do not use automatic negotiations": this true do not use PAGP or LACP. Second task saying to configure trunk, how can you configure second task by just relaying on frist's requirement? In this case either there should be something more information for trunk configuration else we should leave as it is (default DTP) or we can run to proctor.

    Thanks for the clarification. I would ask this to the proctor just to be on the safe side. Thank you!

  • Hi,

     

    I didn't get why we have dot1q here.

    "4 byte encapsulation" .. for me it's ISL, isn't it ?

  • Hi,

    No; dot1q is 4 bytes, ISL is 26 bytes for the header and 4 bytes for FCS, totaling 30bytes of overhead.

    HTH

    Good luck!

Sign In or Register to comment.