Cisco IP Communicator 7 on Windows 7 64bits

Hi all,

I installed Cisco IP Communicator 7 on my new Windows 7 64bits notebook PC and tried to run it but it keeps "Configuring IP" and will not even let me specify TFTP Servers using the Preferences and Network options. Has anyone experienced this and resolved it before? If so kindly give a clue of what one is to do!

Thanks.

Comments

  • I ran into the issue of not being able to change the network settings just yesterday on my laptop.  I'm running Win7 32-bit but might work.  I had to run the IPC as Administrator in order for me to be allowed to change those network settings.

    Open "C:Program FilesCisco SystemsCisco IP Communicator" right-click on communicatork9.exe and use 'Run as Administrator'.

    Not sure if that will work for you but did for me.

     

    HTH

  • I just tried based on your advice and it worked now. But am surprised because the account that I login to Windows 7 is an administrative account, and it was thesame account i used even install the CIPC on the Windows 7 Notebook PC in the first place. Thanks a lot.

  • I noticed an additional problem I have with IP Communicator on my Windows 7 Notebook PC. The PC has both an Internal MIC and an External MIC Port, but the Audio Tuning Wizard automatically chose the External MIC as its Recording Device when I run IP Communicator and does not offer me the option to use the Internal MIC. So now I don't have an External MIC and therefore I can not speak using IP Communicator. Could this be that the Laptop Manufacturer has some restrictions on the use of the Internal MIC for Recording. The Notebook PC is HP Brand. In the past I came accross some hints of restrictions on the use Internal MIC to prevent piracy. 

  • Hello Patmien,

     

    The first issue with administrator rights is a "feature" built into Windows 7. The logic described for the feature is that it keeps programs such as viruses from running as administrator. As for the MIC, you can fix this with the following steps:

     

    Start -> Control Panel -> Sound -> Recording: Then locate the internal MIC, and make it the default recording device. Close CIPC, then reopen, and it should recognize your internal MIC.

     

    Hope this helps.

  • Greetings everyone,

    i know it´s a little late, but it could help someone running into this problem.

    I was stuck trying to make the IPC run as an administrator but it refused to let me change te TFTP server values, so i decided to add permission  (i mean windows AD permissions) to the registry Key of Cisco IP Communicator (HKEY_CURRENT_USERSoftwareCisco Systems, Inc.Communicator), and now every option form Network Thumbnail in the IPC preferences is available to change.

     

  • I had a similar issue with Windows 7.  You must run ipcommunicator in "Run as Administrator) from the start menu.  Once you do, then you will have rights to modify the TFTP servers.

  • I installed Cisco IP Communicator on my new Windows 10 64bits Dell Laptop and tried to run it but it keeps "Configuring IP" and will not even let me specify TFTP Servers using the Preferences and Network options. Has anyone experienced this and resolved it before? If so kindly help on how to resolve.

Sign In or Register to comment.