Task 4.4 MPLS Traffic Engineering

I am not able to get my traffic engineering between R4 and R6 (either direction to come up).    I have double checked all my configs and verified everything in the path and I am still not able to get the tunnel in an up/up state.  Below is the outputs from R4 and R6. I noticed in the debugs that both R4 and R6 refer to the ip-addresses on the frame-relay link between R1 and R2 being unknown, but when I do a debug mpls traffic-eng path verify on R6 i get a path-verifed (see below).  On R4 when I do a show mpls traffic-eng topology igp-id ospf 131.5.12.2, i get does not exist. On R6 when I do a show mpls traffic-eng topology igp-id ospf 131.5.12.1, i get does not exist.        

IGP id (131.5.12.2) does not exist!

R6

MPLS TE:

  MPLS traffic-eng path calculation lookup events debugging is on

SPRack5R6(config-if)#

*Sep 27 21:19:58.265: 

TE-PCALC: Tunnel0 Path Setup to 131.5.4.4: FULL_PATH

*Sep 27 21:19:58.265: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:19:58.265: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:19:58.265: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:19:58.265: 

TE-PCALC: Tunnel0 Path Setup to 131.5.4.4: FULL_PATH

*Sep 27 21:19:58.265: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:19:58.265: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:19:58.265: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:19:58.265: TE-PCALC_PATH: create_path_hoplist:ip addr 131.5.12.1 unknown.

*Sep 27 21:19:58.265: 

TE-PCALC: Tunnel0 Path Setup to 131.5.4.4:

SPRack5R6(config-if)#

*Sep 27 21:19:58.265: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:19:58.265: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:19:58.265: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:19:58.265: TE-PCALC_PATH:Path from 131.5.6.6 -> 131.5.4.4:

*Sep 27 21:19:58.265: TE-PCALC_PATH:    131.5.34.3->131.5.34.4(admin_weight=5):

*Sep 27 21:19:58.265: TE-PCALC_PATH:    131.5.23.3->0.0.0.0(admin_weight=3):

*Sep 27 21:19:58.265: TE-PCALC_PATH:    131.5.23.2->0.0.0.0(admin_weight=3):

*Sep 27 21:19:58.265: TE-PCALC_PATH:    131.5.26.6->131.5.26.2(admin_weight=1):

*Sep 27 21:19:58.265: TE-PCALC_PATH

*Sep 27 21:19:58.265: TE-PCALC_PATH:    num_hops 5, accumlated_aw 5, min_bw 33750

 

SPRack5R6#debug mpls traffic-eng path verify 

MPLS traffic-eng path calculation verify events debugging is on

SPRack5R6#

*Sep 27 21:21:58.265: 

TE-PCALC: Tunnel0 Path Setup to 131.5.4.4:

*Sep 27 21:21:58.265: TE-PCALC: bw 10000, min_bw 33750, metric: 5

*Sep 27 21:21:58.265: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:21:58.265: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:21:58.265: TE-PCALC_VERIFY: Verify 

        131.5.6.6, 131.5.26.6 points to 

        131.5.2.2, 131.5.23.2

*Sep 27 21:21:58.265: TE-PCALC_VERIFY: Verify 

        131.5.2.2, 131.5.23.2 points to 

        131.5.3.3, 131.5.23.3

*Sep 27 21:21:58.265: TE-PCALC_VERIFY: Verify 

        131.5.3.3, 131.5.23.3 points to 

        131.5.4.4, 131.5.34.4

*Sep 27 21:21:58.265: TE-PCALC_VERIFY: (rrr_pcalc_verify_path) Verify Passed

 

R4

 

SPRack5R4#

*Sep 27 21:24:05.881: 

TE-PCALC: Tunnel0 Path Setup to 131.5.6.6: FULL_PATH

*Sep 27 21:24:05.881: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:24:05.881: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:24:05.881: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:24:05.881: 

TE-PCALC: Tunnel0 Path Setup to 131.5.6.6: FULL_PATH

*Sep 27 21:24:05.881: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:24:05.881: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:24:05.881: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:24:05.881: TE-PCALC_PATH: create_path_hoplist:ip addr 131.5.12.2 unknown.

*Sep 27 21:24:05.881: 

TE-PCALC: Tunnel0 Path Setup to 131.5.6.6:

SPRack5R4#

*Sep 27 21:24:05.881: TE-PCALC: bw 10000, min_bw 0, metric: 0

*Sep 27 21:24:05.881: TE-PCALC: setup_pri 7, hold_pri 7

*Sep 27 21:24:05.881: TE-PCALC: affinity_bits 0x0, affinity_mask 0xFFFF

*Sep 27 21:24:05.881: TE-PCALC_PATH:No Path

 

R1


Building configuration...

 

Current configuration : 3556 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SPRack5R1

!

boot-start-marker

boot-end-marker

!

!

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

mpls traffic-eng tunnels

no mpls traffic-eng auto-bw timers frequency 0

mpls label protocol ldp

call rsvp-sync

!

!

!

!

!

memory-size iomem 64

!

!

!

interface Loopback0

 ip address 131.5.1.1 255.255.255.255

 ip ospf network point-to-point

 no clns route-cache

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface FastEthernet1/0

 ip address 204.12.5.1 255.255.255.0

 duplex auto

 speed auto

 no clns route-cache

!

interface FastEthernet1/1

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface Serial2/0

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 no frame-relay inverse-arp

 frame-relay lmi-type cisco

 no clns route-cache

!

interface Serial2/0.12 point-to-point

 bandwidth 45000

 ip address 131.5.12.1 255.255.255.248

 ip ospf network broadcast

 ip ospf priority 0

 mpls traffic-eng tunnels

 mpls ip

 frame-relay interface-dlci 102   

 ip rsvp bandwidth

!

interface Serial2/0.13 point-to-point

 bandwidth 45000

 ip address 131.5.13.1 255.255.255.248

 ip ospf network broadcast

 ip ospf priority 0

 mpls traffic-eng tunnels

 mpls ip

 frame-relay interface-dlci 113   

 ip rsvp bandwidth

!

interface Serial2/1

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface Serial2/2

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface Serial2/3

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface ATM3/0

 no ip address

 no atm enable-ilmi-trap

 no clns route-cache

!

interface ATM3/0.1 mpls

 ip address 150.5.101.1 255.255.255.0

 no atm enable-ilmi-trap

 mpls atm control-vc 1 64

 mpls label protocol tdp

 mpls ip

!

router ospf 1

 router-id 131.1.1.1

 log-adjacency-changes

 network 131.5.1.1 0.0.0.0 area 0

 network 131.5.12.1 0.0.0.0 area 0

 network 131.5.13.1 0.0.0.0 area 0

 network 150.5.101.1 0.0.0.0 area 0

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

!

router isis 

 net 10.9999.9999.9999.9999.00

!

router bgp 100

 no synchronization

 bgp log-neighbor-changes

 neighbor 131.5.4.4 remote-as 100

 neighbor 131.5.4.4 update-source Loopback0

 neighbor 131.5.4.4 route-reflector-client

 neighbor 131.5.4.4 next-hop-self

 neighbor 131.5.4.4 send-community

 neighbor 131.5.5.5 remote-as 100

 neighbor 131.5.5.5 update-source Loopback0

 neighbor 131.5.5.5 route-reflector-client

 neighbor 131.5.5.5 next-hop-self

 neighbor 131.5.5.5 send-community

 neighbor 131.5.6.6 remote-as 100

 neighbor 131.5.6.6 update-source Loopback0

 neighbor 131.5.6.6 route-reflector-client

 neighbor 131.5.6.6 next-hop-self

 neighbor 131.5.6.6 send-community

 neighbor 131.5.9.9 remote-as 100

 neighbor 131.5.9.9 update-source Loopback0

 neighbor 131.5.9.9 route-reflector-client

 neighbor 131.5.9.9 next-hop-self

 neighbor 131.5.9.9 send-community

 neighbor 204.12.5.254 remote-as 54

 neighbor 204.12.5.254 route-map AS_54 in

 no auto-summary

!

ip classless

!

no ip http server

!

ip bgp-community new-format

!

!

!

route-map AS54_IN permit 10

 set community 100:54

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

line con 0

 exec-timeout 0 0

 logging synchronous

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 privilege level 15

 no login

!

!

end

 

R2


Building configuration...

 

Current configuration : 2643 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname SPRack5R2

!

boot-start-marker

boot-end-marker

!

!

ip subnet-zero

ip cef

!

!

no ip domain-lookup

!

mpls traffic-eng tunnels

no mpls traffic-eng auto-bw timers frequency 0

mpls ldp neighbor 131.5.6.6 password CISCO

mpls ldp router-id Loopback0

mpls label protocol ldp

!

key chain OSPF_KEY

 key 1

call rsvp-sync

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 131.5.2.2 255.255.255.255

 ip ospf network point-to-point

 no clns route-cache

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface FastEthernet1/0

 ip address 131.5.26.2 255.255.255.0

 ip ospf authentication message-digest

 ip ospf authentication-key OSPF_KEY

 ip ospf network point-to-multipoint non-broadcast

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls ip

 no clns route-cache

 ip rsvp bandwidth

!

interface FastEthernet1/1

 no ip address

 shutdown

 duplex auto

 speed auto

 no clns route-cache

!

interface Serial2/0

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 no frame-relay inverse-arp

 frame-relay lmi-type cisco

 no clns route-cache

!

interface Serial2/0.12 point-to-point

 bandwidth 45000

 ip address 131.5.12.2 255.255.255.248

 ip ospf network broadcast

 ip ospf priority 0

 mpls traffic-eng tunnels

 mpls ip

 frame-relay interface-dlci 201   

 ip rsvp bandwidth

!

interface Serial2/0.23 point-to-point

 bandwidth 45000

 ip address 131.5.23.2 255.255.255.248

 ip ospf network broadcast

 ip ospf priority 0

 mpls traffic-eng tunnels

 mpls ip

 frame-relay interface-dlci 213   

 ip rsvp bandwidth

!

interface Serial2/1

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface Serial2/2

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface Serial2/3

 no ip address

 shutdown

 serial restart-delay 0

 no clns route-cache

!

interface ATM3/0

 no ip address

 no atm enable-ilmi-trap

 no clns route-cache

!

router ospf 1

 router-id 131.5.2.2

 log-adjacency-changes

 network 131.5.2.2 0.0.0.0 area 0

 network 131.5.12.2 0.0.0.0 area 0

 network 131.5.23.2 0.0.0.0 area 0

 network 131.5.26.2 0.0.0.0 area 0

 neighbor 131.5.26.6

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

!

ip classless

!

no ip http server

!

!

!

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

line con 0

 exec-timeout 0 0

 logging synchronous

 stopbits 1

line aux 0

 stopbits 1

line vty 0 4

 privilege level 15

 no login

!

!

end

 

 

 

Comments

  • I changed the ospf network type on the frame-relay link R1 to R2 from Broadcast to point-to-multipoint and the tunnel comes up.  When I debug the route announce for the tunnel I did not see the interface being advertised until I changed the OSPF network type.

Sign In or Register to comment.