CME MOH for internal Phones

Anyone knows if MOH works for calls between ephones in CME or callmanager fallback. I have all the necessary config in the router and PSTN callers can hear music but internal callers cannot..any input on this would be apprecaited

 

config

 

telephony-service

moh music-on-hold.au

multicast moh 239.1.1.1 port 16384

ccm-manager music on hold

 

 

Comments

  • i forgot to mention that ip multicast is enabled and pim dense mode is also enabled

  • <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">






    Hi,

     

    I don’t know if this is of any help, but I usually use a longer statement
    for MOH.

    Here is my current config:

     

    moh music-on-hold.au

    multicast moh 239.1.1.1 port 16384 route 10.10.42.254 192.168.1.102

     

    Where 10.10.42.254 is the voice vlan interface where the phones are
    attached.

    interface Vlan11

    description **VOICEVLAN**

    ip address 10.10.42.254 255.255.255.0

    ip pim dense-mode

     

    And 192.168.1.102 is another ethernet interface where I have a softphone
    attached

    interface FastEthernet0/0

    description **LANINTERF_DONOTCHANGE*

    ip address 192.168.1.102 255.255.255.0

    ip pim dense-mode

    duplex auto

    speed auto

     

    Vlan11 is the vlan I both source my telephony-service in, and where my hard
    e-phones have ip addresses.

    The key to “multicast moh 239.1.1.1 port 16384 route 10.10.42.254
    192.168.1.102” is telling it where to direct the music Winking smile

     

    KR

    Lasse

     



     


    From: ciscoindia

    Sent: Wednesday, September 15, 2010 6:32 PM


    Subject: [CCIE Voice] CME MOH for internal Phones

     

    Anyone knows if MOH works for calls between ephones in CME or callmanager
    fallback. I have all the necessary config in the router and PSTN callers can
    hear music but internal callers cannot..any input on this would be
    apprecaited

     

    config

     

    telephony-service

    moh music-on-hold.au

    multicast moh 239.1.1.1 port 16384

    ccm-manager music on hold

     

     

     



    Internetwork
    Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription information
    may be found
    at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • hi,

    you have to define a loopback interface and then define the routing of the moh media on the telephony services
    here is an example


    interface Loopback0

     ip address 10.1.1.1 255.255.255.255
    !
    interface GigabitEthernet0/1
     ip address 192.168.10.1 255.255.255.0
     h323-gateway voip interface
     h323-gateway voip bind srcaddr 192.168.10.1

    !
    ccm-manager music-on-hold
    !
    call-manager-fallback
      ip source-address 166.64.10.196 port 2000
     moh SampleAudioSource.wav
     multicast moh 239.1.1.1 port 16384 route 192.168.10.1 10.1.1.1

    !

    keep in mind that this example will work only if the audio file is g711u if codec changes, multicast ip address is different.






    On Wed, Sep 15, 2010 at 11:34 AM, ciscoindia <[email protected]> wrote:

    i forgot to mention that ip multicast is enabled and pim dense mode is also enabled




    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx







  • Loopback interface is only needed for MOH to PSTN, not local moh to phones
    connected to the CME.

     

     

    Lasse



     


    From: j4k

    Sent: Thursday, September 16, 2010 3:32 AM


    Subject: Re: [CCIE Voice] CME MOH for internal
    Phones

     

    hi,

     

    you have to define a loopback interface and then define the routing of the
    moh media on the telephony services
    here is an example

     


     

    interface Loopback0

    ip address 10.1.1.1 255.255.255.255

    !

    interface GigabitEthernet0/1

    ip address 192.168.10.1 255.255.255.0


    h323-gateway voip interface

    h323-gateway voip bind srcaddr 192.168.10.1

    !


    ccm-manager music-on-hold

    !


    call-manager-fallback

      ip source-address 166.64.10.196 port 2000

    moh SampleAudioSource.wav

    multicast moh 239.1.1.1 port 16384 route 192.168.10.1 10.1.1.1

    !

     

    keep in mind that this example will work only if the audio file is g711u if
    codec changes, multicast ip address is different.

     

     

     

     

     

    On Wed, Sep 15, 2010 at 11:34 AM, ciscoindia <[email protected]>
    wrote:

    i forgot to mention that ip multicast is enabled and pim dense mode is also
    enabled




    Internetwork
    Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription
    information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

     





    Internetwork
    Expert - The Industry Leader in CCIE
    Preparation
    http://www.internetworkexpert.com

    Subscription information
    may be found
    at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx
Sign In or Register to comment.