Changing Putty "Idle-timeout"

Hello,

Is there a way to alter the idle timeout for connections that are made with Putty?? Each time am entering commands in notepad so that i just paste, i find the screen gone. The session disconnects automatically. This entails re-connecting to the terminal server which is cumbersome

 

I have changed the "seconds between keepalives" option in putty without any success

 

Help will be appreaciated!!!

 

Michael

Comments

  • in case you are connecting with a router then you should put exec-timeout  0 0 command to never go idle.

    HTH

    On Sun, Jul 18, 2010 at 11:51 AM, mnabutali <[email protected]> wrote:

    Hello,

    Is there a way to alter the idle timeout for connections that are made with Putty?? Each time am entering commands in notepad so that i just paste, i find the screen gone. The session is disconnects automatically. This entails re-connecting to the terminal server which is cumbersome

     

    I have changed the "seconds between keepalives" option in putty without any success

     

    Help will be appreaciated!!!

     

    Michael




    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • Thanks Nadeem,

    Thanks for your reply. Its not the router that disconnects the session. Its Windows. This happens when am doing remote labs. When i log into the access server (racks.ine.com), Putty session disconnects automatically after an idle period of two - four minutes. I hope this clarifies what am asking. The router is already set to exec-t 0 0

    rgds

  • Hi

    In putty Under connection you will find a option

    "Sending of null packets to keep session active"

    Just change the value to 1 or 2 and you are good to go.

    HTH

    Mahir

     

    image

  • Thanks mate - will try it out tommorow when i have a remote lab

Sign In or Register to comment.