PSTN-WAN Router Connectivity Question


Hi All,

I am in the process of building my home lab and need clarification on my PSTN-WAN router.

What does the PSTN router’s Fast 0/0 interface connect to?

I have checked some old config’s from the previous lab’s and it seems to connect to the 6500, so does it now connect to HQ’s 3750?

If this is the case, do you also connect the 7960 PSTN phone to HQ’s 3750 and hardcode the phone to register with the PSTN CME?

Thank you.


 

 

 

Comments

  • Clivero,

     

    Below is a sample PSTN-WAN-Router sub-configuration regarding controller and interface annotations stating where they are attached. Hope it helps.

     


     

    hostname PSTN

    !

    controller T1 0/0

     framing esf

     clock source internal

     linecode b8zs

     cablelength short 133

     pri-group timeslots 1-3,24

     description == Voice Circuit to CorpHQ

    !

    controller T1 0/1

     framing esf

     clock source internal

     linecode b8zs

     cablelength short 133

     channel-group 0 timeslots 1-24 speed 64

     description == Data Circuit to CorpHQ

    !

    controller E1 0/2

     clock source internal

     pri-group timeslots 1-3,16

     description == Voice Circuit to Branch2

    !

    controller E1 0/3

     clock source internal

     channel-group 0 timeslots 1-31

     description == Data Circuit to Branch2

    !

    controller T1 0/4

     framing esf

     clock source internal

     linecode b8zs

     cablelength short 133

     pri-group timeslots 1-3,24

     description == Voice Circuit to Branch1

    !

    controller T1 0/5

     framing esf

     clock source internal

     linecode b8zs

     cablelength short 133

     channel-group 0 timeslots 1-24 speed 64

     description == Data Circuit to Branch2

    !

    !

    interface Loopback0

     ip address 177.1.254.254 255.255.255.255

    !

    interface FastEthernet0/0

     description == VPN CONNECTIVITY TO VORACK

     ip address 177.253.52.1 255.255.255.0

     ip pim dense-mode

     duplex auto

     speed auto

    !

    interface Serial0/0:23

     description == Voice PRI to CorpHQ

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn map address transparent

     isdn supp-service name calling

     isdn negotiate-bchan resend-setup

     isdn outgoing ie network-facility 

     isdn outgoing ie redirecting-number 

     no cdp enable

    !

    interface FastEthernet0/1

     description == IP CONNECTION TO CorpHQ Router F0/1 int

     ip address 177.1.19.1 255.255.255.0

     ip pim dense-mode

     duplex auto

     speed auto

    !

    interface Serial0/1:0

     description == Frame-Relay Circuit to R1-HQ

     no ip address

     encapsulation frame-relay

     no keepalive

     cdp enable

     frame-relay lmi-type ansi

     frame-relay intf-type dce

     frame-relay route 101 interface Serial0/5:0 101

    !

    !

    interface Serial0/2:15

     description == Voice PRI to Branch2

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn map address transparent

     isdn negotiate-bchan resend-setup

     no isdn outgoing ie network-facility

     isdn outgoing display-ie

     isdn outgoing ie redirecting-number     

     no cdp enable

    !

    interface Serial0/3:0

     description == Frame-Relay Circuit to R3-BR2

     no ip address

     encapsulation frame-relay

     no keepalive

     nrzi-encoding

     cdp enable

     frame-relay lmi-type ansi

     frame-relay intf-type dce

    !

    interface Serial0/4:23

     description == Voice PRI to Branch1

     no ip address

     encapsulation hdlc

     isdn switch-type primary-ni

     isdn protocol-emulate network

     isdn incoming-voice voice

     isdn map address transparent

     isdn supp-service name calling

     isdn negotiate-bchan resend-setup

     isdn outgoing ie network-facility 

     isdn outgoing ie redirecting-number 

     no cdp enable

    !

    interface Serial0/5:0

     description == Frame-Relay Circuit to R2-BR1

     no ip address

     encapsulation frame-relay

     no keepalive

     no fair-queue

     cdp enable

     frame-relay lmi-type ansi

     frame-relay intf-type dce

     frame-relay route 101 interface Serial0/1:0 101

    !

    router ospf 1

     log-adjacency-changes

     network 0.0.0.0 255.255.255.255 area 0

    !

    !

    voice-port 0/0:23

     description == Voice PRI to CorpHQ

    !

    voice-port 0/2:15

     description == Voice PRI to Branch2

    !

    voice-port 0/4:23

     description == Voice PRI to Branch1

    !

    !

    !

    !

    !

    line con 0

     exec-timeout 0 0

     privilege level 15

     logging synchronous level 0 limit 20

    line aux 0

    line vty 0 15

     exec-timeout 0 0

     privilege level 15

     password cisco

     logging synchronous

     login

     transport input telnet

    !

    scheduler allocate 20000 1000

    ntp source Loopback0

    ntp master 10

    !

    end

     

    PSTN# 

     

  • Hello Clivero,

     

    The Fa 0/0 interface on the PSTN router is used for connectivity to the rack. We use this interface to facilitate VPN access into the rack from the outside. In a home lab scenario this interface would not need to be used unless you wanted all telnet traffic to pass through the PSTN rather than using an access server.

    As for the PSTN phone, you could connect it to HQ's switch, or any other sites switch if you setup a VLAN for the port. Finally, you could connect an additional switch to the PSTN, or a power module to the phone, and then a direct ethernet connection to the PSTN router. This last method, if possible in your network, I would recommend as you can ensure that your PSTN phone works when site connectivity is down.

     

    Hope this helps

Sign In or Register to comment.