How to Enable Caller ID on E1 ???


Hi there 

Currently I have cisco 3845 and CCM V4.1 installed and configured and working just fine but when somebody calls from outside I mean from PSTN we get unknown No .. so what do I need to see the No on screen of cisco ip phone ...

do we need to enable the caller ID service from PSTN provider and what about cell phones also when they call the inside No's and then do some configs on VG or what ...

I need to  know the required configs exactly and if we need to enable the service from PSTN or not.....

Comments

  • Is this an E1-PRI or an E1-R2?

    Can you provide us with relevant config thus far?

    Cheers,

    Mark Snow 



    On May 31, 2010, at 17:00, shevchenko <[email protected]> wrote:


    Hi there 

    Currently I have cisco 3845 and CCM V4.1 installed and configured and working just fine but when somebody calls from outside I mean from PSTN we get unknown No .. so what do I need to see the No on screen of cisco ip phone ...

    do we need to enable the caller ID service from PSTN provider and what about cell phones also when they call the inside No's and then do some configs on VG or what ...

    I need to  know the required configs exactly and if we need to enable the service from PSTN or not.....




    Internetwork Expert - The Industry Leader in CCIE Preparation

    http://www.internetworkexpert.com



    Subscription information may be found at:

    http://www.ieoc.com/forums/ForumSubscriptions.aspx
  • It is A E1-PRI and it is a single site deployment where we have two VG with E1's to PSTN and of course our CCM after those two VGs..

    and here is a copy of the config

     

    boot-start-marker

    boot system flash:c3845-ipvoicek9-mz.124-4.T7.bin

    boot-end-marker

    no aaa new-model

    resource policy

    network-clock-participate wic 0 

    ip subnet-zero

    ip cef

    isdn switch-type primary-net5

    voice-card 0

     no dspfarm

    controller E1 0/0/0

     pri-group timeslots 1-31 service mgcp

    interface Loopback0

     ip address x.x.x.x

    interface GigabitEthernet0/0

     ip address x.x.x.x x.x.x.x

     duplex auto

     speed auto

     media-type rj45

     negotiation auto

    interface GigabitEthernet0/1

     ip address x.x.x.x x.x.x.x

     duplex auto

     speed auto

     media-type rj45

     negotiation auto

    interface Serial0/0/0:15

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn incoming-voice voice

     isdn bind-l3 ccm-manager

     no cdp enable

    ip classless

    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 2

    ip http server

    no ip http secure-server

    control-plane

    voice-port 0/0/0:15

    ccm-manager fallback-mgcp 

    ccm-manager redundant-host x.x.x.x

    ccm-manager mgcp

    ccm-manager music-on-hold

    ccm-manager config server x.x.x.x  

    ccm-manager config

    !

    mgcp

    mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

    mgcp dtmf-relay voip codec all mode out-of-band

    mgcp rtp unreachable timeout 1000 action notify

    mgcp modem passthrough voip mode nse

    mgcp package-capability rtp-package

    no mgcp package-capability res-package

    mgcp package-capability sst-package

    no mgcp package-capability fxr-package

    mgcp package-capability pre-package

    no mgcp timer receive-rtcp

    mgcp sdp simple

    mgcp fax t38 inhibit

    no mgcp explicit hookstate

    mgcp rtp payload-type g726r16 static

    mgcp bind control source-interface Loopback0

    mgcp bind media source-interface Loopback0

    !

    mgcp profile default

    dial-peer voice 2 pots

     service mgcpapp

     port 0/0/0:15

    call-manager-fallback

     max-conferences 8 gain -6

    line con 0

     logging synchronous

     stopbits 1

    line aux 0

     stopbits 1

    line vty 0 4

    login

    scheduler allocate 20000 1000

    end

     

  • With E1-PRI, the most probable reason you might not be receiving caller-ID is if there is an issue with the Telco not sending it properly.


    Mark Snow, CCIE #14073
    (Voice, Security)
    Instructor
    Internetwork Expert, Inc.
    mailto:[email protected]
    http://blog.ine.com
    Toll Free: 877-224-8987
    Outside US: 775-826-4344

    - docendo discitur



    On May 31, 2010, at 11:57 PM, shevchenko wrote:

    It is A E1-PRI

    and here is a copy of the config


    boot-start-marker

    boot system flash:c3845-ipvoicek9-mz.124-4.T7.bin

    boot-end-marker

    no aaa new-model

    resource policy

    network-clock-participate wic 0 

    ip subnet-zero

    ip cef

    isdn switch-type primary-net5

    voice-card 0

     no dspfarm

    controller E1 0/0/0

     pri-group timeslots 1-31 service mgcp

    interface Loopback0

     ip address x.x.x.x

    interface GigabitEthernet0/0

     ip address x.x.x.x x.x.x.x

     duplex auto

     speed auto

     media-type rj45

     negotiation auto

    interface GigabitEthernet0/1

     ip address x.x.x.x x.x.x.x

     duplex auto

     speed auto

     media-type rj45

     negotiation auto

    interface Serial0/0/0:15

     no ip address

     encapsulation hdlc

     isdn switch-type primary-net5

     isdn incoming-voice voice

     isdn bind-l3 ccm-manager

     no cdp enable

    ip classless

    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0

    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 2

    ip http server

    no ip http secure-server

    control-plane

    voice-port 0/0/0:15

    ccm-manager fallback-mgcp 

    ccm-manager redundant-host x.x.x.x

    ccm-manager mgcp

    ccm-manager music-on-hold

    ccm-manager config server x.x.x.x  

    ccm-manager config

    !

    mgcp

    mgcp call-agent x.x.x.x 2427 service-type mgcp version 0.1

    mgcp dtmf-relay voip codec all mode out-of-band

    mgcp rtp unreachable timeout 1000 action notify

    mgcp modem passthrough voip mode nse

    mgcp package-capability rtp-package

    no mgcp package-capability res-package

    mgcp package-capability sst-package

    no mgcp package-capability fxr-package

    mgcp package-capability pre-package

    no mgcp timer receive-rtcp

    mgcp sdp simple

    mgcp fax t38 inhibit

    no mgcp explicit hookstate

    mgcp rtp payload-type g726r16 static

    mgcp bind control source-interface Loopback0

    mgcp bind media source-interface Loopback0

    !

    mgcp profile default

    dial-peer voice 2 pots

     service mgcpapp

     port 0/0/0:15

    call-manager-fallback

     max-conferences 8 gain -6

    line con 0

     logging synchronous

     stopbits 1

    line aux 0

     stopbits 1

    line vty 0 4

    login

    scheduler allocate 20000 1000

    end





    Internetwork Expert - The Industry Leader in CCIE Preparation
    http://www.internetworkexpert.com

    Subscription information may be found at:
    http://www.ieoc.com/forums/ForumSubscriptions.aspx

  • You mean as I said that we have to subscribe with PSTN first for the service ... but is there any further configurations here are required if the PSTN activated it ...?

    One more thing what do I do to make a PLAR services between two local lines inside the site .... and another between one inside and one outside over PSTN ...

  •  shevchenko,

    Yes, you must subscribe with your carrier for this service. Nothing more (should) need required on your end to make Inbound CallerID work properly. In order to make Outbound CallerID work properly, you may need to check one of the two check boxes on your CUCM MGCP Gateway Endpoint webpage:

    Send Calling Name in FacilityIE

    or

    Send DisplayIE

    I guess I should maybe first ask - what type of ISDN switch are you connecting to?

     

    As for PLAR - I need a bit of clarification in order to answer you best.

    Are you are asking how to configure PLAR for a DID number coming in across the PRI?

    Or is this for an analog FXO line coming in?

     

    Kind Regards,

  • PLAR here has two parts 

    I work in an airport and this service on old POTS they have for the Tower and fire department ... and between the tower and the main emergency HQ in another town so I need two sets of PLAR

    one internally two IP phones between the tower and fire department inside the airport in which it is like hotline tower picks the phone off hook and it rings in fire dept. with no dialing no's just off hook action.

    and the second one between tower and HQ but the tower has IP Phone and the HQ old POTS telephone so it will come through E1 PRI.

    Thanks so much for your time ... 

  •  shevchenko,

    No problem. Sounds like in both cases, an IP Phone starts the PLAR (e.g. An IP Phone goes off-hook, and when they do, the other side should immediately ring).

    For both situations, create a new Partition that is called something intuitive (such as PT-PLAR-1), and then create a new CSS and place that PT inside of it (e.g. CSS-PLAR-1 >> PT-PLAR-1).

    Now create a new Translation Pattern, but do not fill anything in the Pattern field. Instead only fill in the number of the IP Phone you wish to ring, in the "Called Party Transformation Mask" box. Also Assign a CSS to the new Translation Pattern (do not use the new CSS-PLAR-1), just any CSS that can "reach" the phone you wish to ring. 

    Finally go to the phone that will be performing the PLAR (i.e. the one that as soon as you go off-hook - the other phone should ring) - and assign it the newly created CSS-PLAR-1.

    That should do it - reset the phone and test.

    Rinse and repeat that process (with 2 new CSS's and PT's) for the other PLAR you wish to have.

     

    Cheers,

  • Thanks Mark for your precious time and as soon as I get back to work (Currently in vacation) I will apply it and confirm back to you .... :)

Sign In or Register to comment.