how I connect the sham-link ?

                                 sham-link

R1 -------------------------------------------------------------R2

|                                                                                |

|                                                                                |

|                                                                                |

R3-------------------------------------------------------------- R4

                           backdoor

 

Hi Guys,

I have a problem OSPF Sham-link.  look at the drawing, R1 and R2 is ISP. R3 and R4 is OSPF backdoor and CE . 

I use /24 in sham-link.  24bit was not connected between R1 and R2.

I find problem. sham-link must be /32 ip address in MPLS Study book in Ciscopress.

so I make stitic route to /32bit and  redistribute static route in bgp.

but, static route didn't make on routing table.

EX> ip route vrf 10.10.10.1 255.255.255.255 2.2.2.2

2.2.2.2 is real ip address. bgp update source ip address is  2.2.2.2.

How do i ? 

 

==================================

R1

int lo 10

ip vrf forwarding ISP

ip address 10.10.10.1 255.255.255.0  (sham-link ip address)

 

ip route vrf ISP 10.10.10.2 255.255.255.255  2.2.2.2

 

router ospf 1 vrf ISP

network 10.1.1.1 255.255.255.0

redi bgp 100 subnets

 

router bgp 100

no bgp default ipv

neighbor 2.2.2.2 remote-as 100

neighbor 1.1.1.1 up so lo 0

ad vpnv4

neighbor 2.2.2.2 active

neighbor 2.2.2.2 send-community exten

ad ipv4 vrf ISP

redi ospf 1 vrf ISP

redi static

 

 

 

Comments

  • perhaps you might wanna post this under CCIE SP General... Someone there might be able to help you. But you want to perhaps check "ip route vrf ISP 10.10.10.2 255.255.255.255  2.2.2.2" as its best to be pointing to a physical interface. The reason its not appearing in your VRF table is that the next-hop is unreachable and thus will not be redistributed into BGP. I could be wrong. Perhaps it would be better if you post all your configs, so there is a clear understanding.

Sign In or Register to comment.